comment copier sans incrémenter

Le
jiffey
Bonjour à vous !

J'en profite pour vous dire que je trouve ce forum extraordinaire. J'ai
toujours eu réponse à mes questions, les gens sont sympa, bref que du bonheur
!

Alors voici j'ai dans une colonne des formules du style :

=SI(ESTERREUR(SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;18;FAUX));RECHERCHEV(D6;'tableau croisé DO
2006'!A:U;18;FAUX)));0;SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;18;FAUX));RECHERCHEV(D6;'tableau croisé DO 2006'!A:U;18;FAUX)))


Je souhaiterais la copier dans une autre colonne mais sans que cela modifie
la valeur (dans cet exemple D6) et par contre en modifiant la valeur colonne
de la recherchev (ici 18).

Concrètement : je souhaiterais que la formule en la copiant devienne :

=SI(ESTERREUR(SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;16;FAUX));RECHERCHEV(D6;'tableau croisé DO
2006'!A:U;16;FAUX)));0;SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;16;FAUX));RECHERCHEV(D6;'tableau croisé DO 2006'!A:U;16;FAUX))).

Et ceci sans le faire à la mano. Il faudrait une manip assez simple style
copier-coller une colonne (ce qui ne marche évidemment pas car "D6" change et
"18" reste inchangé). Peut-être faut-il passer par une macro mais je ne vois
pas laquelle :((

Voilà, j'espère avoir été clair.

Merci d'avance pour votre aide ;-D

A++

Jiffey
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4484171
Bonjour,

http://cjoint.com/?eBg2Hi1xYZ

JB

On 27 avr, 03:00, jiffey
Bonjour à vous !

J'en profite pour vous dire que je trouve ce forum extraordinaire. J'ai
toujours eu réponse à mes questions, les gens sont sympa, bref que du bonheur
!

Alors voici j'ai dans une colonne des formules du style :

=SI(ESTERREUR(SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;18;FAUX));RECHERCHEV(D6;'tableau croisé DO
2006'!A:U;18;FAUX)));0;SI(D6="";(RECHERCHEV(G6;'tableau croisé livr é
2006'!A:R;18;FAUX));RECHERCHEV(D6;'tableau croisé DO 2006'!A:U;18;FAUX) ))

Je souhaiterais la copier dans une autre colonne mais sans que cela modif ie
la valeur (dans cet exemple D6) et par contre en modifiant la valeur colo nne
de la recherchev (ici 18).

Concrètement : je souhaiterais que la formule en la copiant devienne :

=SI(ESTERREUR(SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;16;FAUX));RECHERCHEV(D6;'tableau croisé DO
2006'!A:U;16;FAUX)));0;SI(D6="";(RECHERCHEV(G6;'tableau croisé livr é
2006'!A:R;16;FAUX));RECHERCHEV(D6;'tableau croisé DO 2006'!A:U;16;FAUX) )).

Et ceci sans le faire à la mano. Il faudrait une manip assez simple sty le
copier-coller une colonne (ce qui ne marche évidemment pas car "D6" cha nge et
"18" reste inchangé). Peut-être faut-il passer par une macro mais je ne vois
pas laquelle... :((

Voilà, j'espère avoir été clair.

Merci d'avance pour votre aide ;-D

A++

Jiffey


dre
Le #4484101
Bonjour,

Pour que D6 ne change pas lors d'un copier coller, il faut lui appliquer une
référence absolue pour la colonne : $D6

Pour modifier le 18 en 16 on peut se référer au numéro de colonne, mais la
formule dépend de la colonne copiée et de celle dans laquelle on colle.
En présisant ces deux colonnes une formule peut être proposée.

dré




Bonjour à vous !

J'en profite pour vous dire que je trouve ce forum extraordinaire. J'ai
toujours eu réponse à mes questions, les gens sont sympa, bref que du bonheur
!

Alors voici j'ai dans une colonne des formules du style :

=SI(ESTERREUR(SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;18;FAUX));RECHERCHEV(D6;'tableau croisé DO
2006'!A:U;18;FAUX)));0;SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;18;FAUX));RECHERCHEV(D6;'tableau croisé DO 2006'!A:U;18;FAUX)))


Je souhaiterais la copier dans une autre colonne mais sans que cela modifie
la valeur (dans cet exemple D6) et par contre en modifiant la valeur colonne
de la recherchev (ici 18).

Concrètement : je souhaiterais que la formule en la copiant devienne :

=SI(ESTERREUR(SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;16;FAUX));RECHERCHEV(D6;'tableau croisé DO
2006'!A:U;16;FAUX)));0;SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;16;FAUX));RECHERCHEV(D6;'tableau croisé DO 2006'!A:U;16;FAUX))).

Et ceci sans le faire à la mano. Il faudrait une manip assez simple style
copier-coller une colonne (ce qui ne marche évidemment pas car "D6" change et
"18" reste inchangé). Peut-être faut-il passer par une macro mais je ne vois
pas laquelle... :((

Voilà, j'espère avoir été clair.

Merci d'avance pour votre aide ;-D

A++

Jiffey



jiffey
Le #4483801
Merci beaucoup Dré & JB !

Dré => Nickelm pour la valeur absolue, je ne connaissais pas et ca va
m'aider beaucoup. Par contre, quelle serait alors la formule pour le pb du N)
de la colonne ?

JB : le tableau matriciel me semble très intéressant mais je n'arrive pas à
l'utiliser pour mon pb...

Si vous voulez je peux vous envoyer mon tableau par @... si vous voulez voir
exactement de quoi il s'agit.

Merci d'avance

Jffey


Bonjour,

Pour que D6 ne change pas lors d'un copier coller, il faut lui appliquer une
référence absolue pour la colonne : $D6

Pour modifier le 18 en 16 on peut se référer au numéro de colonne, mais la
formule dépend de la colonne copiée et de celle dans laquelle on colle.
En présisant ces deux colonnes une formule peut être proposée.

dré




Bonjour à vous !

J'en profite pour vous dire que je trouve ce forum extraordinaire. J'ai
toujours eu réponse à mes questions, les gens sont sympa, bref que du bonheur
!

Alors voici j'ai dans une colonne des formules du style :

=SI(ESTERREUR(SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;18;FAUX));RECHERCHEV(D6;'tableau croisé DO
2006'!A:U;18;FAUX)));0;SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;18;FAUX));RECHERCHEV(D6;'tableau croisé DO 2006'!A:U;18;FAUX)))


Je souhaiterais la copier dans une autre colonne mais sans que cela modifie
la valeur (dans cet exemple D6) et par contre en modifiant la valeur colonne
de la recherchev (ici 18).

Concrètement : je souhaiterais que la formule en la copiant devienne :

=SI(ESTERREUR(SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;16;FAUX));RECHERCHEV(D6;'tableau croisé DO
2006'!A:U;16;FAUX)));0;SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;16;FAUX));RECHERCHEV(D6;'tableau croisé DO 2006'!A:U;16;FAUX))).

Et ceci sans le faire à la mano. Il faudrait une manip assez simple style
copier-coller une colonne (ce qui ne marche évidemment pas car "D6" change et
"18" reste inchangé). Peut-être faut-il passer par une macro mais je ne vois
pas laquelle... :((

Voilà, j'espère avoir été clair.

Merci d'avance pour votre aide ;-D

A++

Jiffey





jiffey
Le #4483791
RE, Dré,

Est-ce qu'on pourrait pas avoir une formule style :

copier formule avec N° colonne recherchev +2 (par exemple) ? Afin que la
recherchev aille dans la colonne 18 et non 16.

Jiffey


Bonjour,

Pour que D6 ne change pas lors d'un copier coller, il faut lui appliquer une
référence absolue pour la colonne : $D6

Pour modifier le 18 en 16 on peut se référer au numéro de colonne, mais la
formule dépend de la colonne copiée et de celle dans laquelle on colle.
En présisant ces deux colonnes une formule peut être proposée.

dré




Bonjour à vous !

J'en profite pour vous dire que je trouve ce forum extraordinaire. J'ai
toujours eu réponse à mes questions, les gens sont sympa, bref que du bonheur
!

Alors voici j'ai dans une colonne des formules du style :

=SI(ESTERREUR(SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;18;FAUX));RECHERCHEV(D6;'tableau croisé DO
2006'!A:U;18;FAUX)));0;SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;18;FAUX));RECHERCHEV(D6;'tableau croisé DO 2006'!A:U;18;FAUX)))


Je souhaiterais la copier dans une autre colonne mais sans que cela modifie
la valeur (dans cet exemple D6) et par contre en modifiant la valeur colonne
de la recherchev (ici 18).

Concrètement : je souhaiterais que la formule en la copiant devienne :

=SI(ESTERREUR(SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;16;FAUX));RECHERCHEV(D6;'tableau croisé DO
2006'!A:U;16;FAUX)));0;SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;16;FAUX));RECHERCHEV(D6;'tableau croisé DO 2006'!A:U;16;FAUX))).

Et ceci sans le faire à la mano. Il faudrait une manip assez simple style
copier-coller une colonne (ce qui ne marche évidemment pas car "D6" change et
"18" reste inchangé). Peut-être faut-il passer par une macro mais je ne vois
pas laquelle... :((

Voilà, j'espère avoir été clair.

Merci d'avance pour votre aide ;-D

A++

Jiffey





dre
Le #4483721
Avec un petit extrait de ton fichier sur Ci-Joint ce sera plus facile pour te
répondre avec exactitude.

dré




RE, Dré,

Est-ce qu'on pourrait pas avoir une formule style :

copier formule avec N° colonne recherchev +2 (par exemple) ? Afin que la
recherchev aille dans la colonne 18 et non 16.

Jiffey


Bonjour,

Pour que D6 ne change pas lors d'un copier coller, il faut lui appliquer une
référence absolue pour la colonne : $D6

Pour modifier le 18 en 16 on peut se référer au numéro de colonne, mais la
formule dépend de la colonne copiée et de celle dans laquelle on colle.
En présisant ces deux colonnes une formule peut être proposée.

dré




Bonjour à vous !

J'en profite pour vous dire que je trouve ce forum extraordinaire. J'ai
toujours eu réponse à mes questions, les gens sont sympa, bref que du bonheur
!

Alors voici j'ai dans une colonne des formules du style :

=SI(ESTERREUR(SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;18;FAUX));RECHERCHEV(D6;'tableau croisé DO
2006'!A:U;18;FAUX)));0;SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;18;FAUX));RECHERCHEV(D6;'tableau croisé DO 2006'!A:U;18;FAUX)))


Je souhaiterais la copier dans une autre colonne mais sans que cela modifie
la valeur (dans cet exemple D6) et par contre en modifiant la valeur colonne
de la recherchev (ici 18).

Concrètement : je souhaiterais que la formule en la copiant devienne :

=SI(ESTERREUR(SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;16;FAUX));RECHERCHEV(D6;'tableau croisé DO
2006'!A:U;16;FAUX)));0;SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;16;FAUX));RECHERCHEV(D6;'tableau croisé DO 2006'!A:U;16;FAUX))).

Et ceci sans le faire à la mano. Il faudrait une manip assez simple style
copier-coller une colonne (ce qui ne marche évidemment pas car "D6" change et
"18" reste inchangé). Peut-être faut-il passer par une macro mais je ne vois
pas laquelle... :((

Voilà, j'espère avoir été clair.

Merci d'avance pour votre aide ;-D

A++

Jiffey







Corto
Le #4483651
Bonjour,
tu peux utiliser CELLULE("col";X:X)+2

Corto

RE, Dré,

Est-ce qu'on pourrait pas avoir une formule style :

copier formule avec N° colonne recherchev +2 (par exemple) ? Afin que la
recherchev aille dans la colonne 18 et non 16.

Jiffey


Bonjour,

Pour que D6 ne change pas lors d'un copier coller, il faut lui appliquer une
référence absolue pour la colonne : $D6

Pour modifier le 18 en 16 on peut se référer au numéro de colonne, mais la
formule dépend de la colonne copiée et de celle dans laquelle on colle.
En présisant ces deux colonnes une formule peut être proposée.

dré




Bonjour à vous !

J'en profite pour vous dire que je trouve ce forum extraordinaire. J'ai
toujours eu réponse à mes questions, les gens sont sympa, bref que du bonheur
!

Alors voici j'ai dans une colonne des formules du style :

=SI(ESTERREUR(SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;18;FAUX));RECHERCHEV(D6;'tableau croisé DO
2006'!A:U;18;FAUX)));0;SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;18;FAUX));RECHERCHEV(D6;'tableau croisé DO 2006'!A:U;18;FAUX)))


Je souhaiterais la copier dans une autre colonne mais sans que cela modifie
la valeur (dans cet exemple D6) et par contre en modifiant la valeur colonne
de la recherchev (ici 18).

Concrètement : je souhaiterais que la formule en la copiant devienne :

=SI(ESTERREUR(SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;16;FAUX));RECHERCHEV(D6;'tableau croisé DO
2006'!A:U;16;FAUX)));0;SI(D6="";(RECHERCHEV(G6;'tableau croisé livré
2006'!A:R;16;FAUX));RECHERCHEV(D6;'tableau croisé DO 2006'!A:U;16;FAUX))).

Et ceci sans le faire à la mano. Il faudrait une manip assez simple style
copier-coller une colonne (ce qui ne marche évidemment pas car "D6" change et
"18" reste inchangé). Peut-être faut-il passer par une macro mais je ne vois
pas laquelle... :((

Voilà, j'espère avoir été clair.

Merci d'avance pour votre aide ;-D

A++

Jiffey







Publicité
Poster une réponse
Anonyme