Comment créé un service

Le
Jac
Bonjour j'ai un problème depuis plusieurs semaines que je n'arrive pas à
régler. Lorsque les usagers se log dans windows xp sp2 desfois le process
explorer.exe ne roule pas et on ne voit pas aucun icône et le taskbar. J'ai
essayé plusieurs trucs trouvé sur des forums à ce sujet sans succès.
J'avais pensé faire un service qui vérifie lorsqu'on se log si le process
explorer.exe fonctionne ou pas. Si il ne fonctionne pas alors on le lance.

J'ai utilisé le language autoit pour cela alors voici mon code


-
#include "ServiceControl.au3"

$servicename = "VerifyExplorer"
$ServiceExist = RegRead("HKLMSYSTEMCurrentControlSetServices" &
$servicename,"DisplayName")

IF $ServiceExist <> "VerifyExplorer" Then
_CreateService("", $servicename, $servicename,
"C:Verify_Explorersrvany.exe", "LocalSystem", "", 0x110)
RegWrite("HKLMSYSTEMCurrentControlSetServices" & $servicename &
"Parameters", "Application", "REG_SZ", @ScriptFullPath)
RegWrite("HKLMSYSTEMCurrentControlSetServices" & $servicename, "Type",
"REG_DWORD", 0x110)
EndIf

While Not ProcessExists("explorer.exe")
Run("explorer.exe")
Sleep(5000);
WEnd
Exit
-

Si je termine le process "explorer.exe" et que je lance se script, tout
fonctionne à merveille. Les icônes reviennent et la taskbar aussi. Mais si
je démarre le service, le process "explorer.exe" démarre mais il ne se passe
rien. Aucun icône et/ou taskbar apparait

Merci de m'aider

JF
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JF
Le #1257472
*Bonjour Jac* !

Bonjour j'ai un problème depuis plusieurs semaines que je n'arrive pas à
régler. Lorsque les usagers se log dans windows xp sp2 desfois le process
explorer.exe ne roule pas et on ne voit pas aucun icône et le taskbar. J'ai
essayé plusieurs trucs trouvé sur des forums à ce sujet sans succès.


Le problème c'est que tu ne dis pas ce que tu as essayé, ni la
situation exacte
http://groups.google.com/group/microsoft.public.windowsxp.general/browse_thread/thread/c0501512b2ee786e/

Alors on recommence :
190 ) Explorateur qui plante:
http://a.vouillon.free.fr/faq-winxp.htm#190
Explorateur Windows - Instabilité
http://www.d2i.ch/pn/az/e.html#e023

Il est clair, comme tout le monde te l'a suggéré, que cette situation
est anormale. Et qu'il vaut mieux trouver la cause. Mais comme tu
réponds rarement aux fils que tu génères ...

--
Salutations, Jean-François
Index du site de PN : www.d2i.ch/pn/az
Outlook Express : Suivez vos fils avec [CTL+H]
Montrez-nous ce que vous voyez : http://fspsa.free.fr/copiecran.htm

Publicité
Poster une réponse
Anonyme