Comment éviter #NA

Le
Jol
Bonjour,
A travers cette formule je complète un tableau.
=SI(ESTERREUR(EQUIV($H8;Zone1));"";INDEX(Zone2;EQUIV($H8;Zone1;0)))
Lorsque la valeur entrée en cellule H8 est non numérique et inexistante dans
ma base de données (celle dans laquelle je vais chercher mes infos, elle se
trouve dans le même classeur) j'ai #NA qui s'affiche alors que je pensais
que rien n'apparaitrait. Si j'entre une info numérique (qui n'existe pas
dans la base) les cellules restent vide, ce que je veux.
Qu'est-ce que j'oublie ?

En vous remerciant
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichD
Le #24293791
Bonjour,

Essaie de cette manière :

=SI(ESTNA(EQUIV($H8;Zone1));"";INDEX(Zone2;EQUIV($H8;Zone1;0)))



MichD
------------------------------------------
Jacky
Le #24293781
Bonsoir,

Qu'est-ce que j'oublie ?


Il manque l'argument 0 (faux) dans la recherche d'erreur
SI(ESTERREUR(EQUIV($H8;zone1;0 <====
=SI(ESTERREUR(EQUIV($H8;zone1;0));"";INDEX(Zone2;EQUIV($H8;zone1;0)))

--
Salutations
JJ


"Jol"
Bonjour,
A travers cette formule je complète un tableau.
=SI(ESTERREUR(EQUIV($H8;Zone1));"";INDEX(Zone2;EQUIV($H8;Zone1;0)))
Lorsque la valeur entrée en cellule H8 est non numérique et inexistante dans ma base de données (celle dans
laquelle je vais chercher mes infos, elle se trouve dans le même classeur) j'ai #NA qui s'affiche alors que
je pensais que rien n'apparaitrait. Si j'entre une info numérique (qui n'existe pas dans la base) les
cellules restent vide, ce que je veux.
Qu'est-ce que j'oublie ?

En vous remerciant
Jol
Le #24293961
Merci,
Cette solution fonctionne parfaitement.

"Jacky" news:jiro2h$f46$
Bonsoir,

Qu'est-ce que j'oublie ?


Il manque l'argument 0 (faux) dans la recherche d'erreur
SI(ESTERREUR(EQUIV($H8;zone1;0 <==== >
=SI(ESTERREUR(EQUIV($H8;zone1;0));"";INDEX(Zone2;EQUIV($H8;zone1;0)))

--
Salutations
JJ


"Jol" jirk9j$75t$
Bonjour,
A travers cette formule je complète un tableau.
=SI(ESTERREUR(EQUIV($H8;Zone1));"";INDEX(Zone2;EQUIV($H8;Zone1;0)))
Lorsque la valeur entrée en cellule H8 est non numérique et inexistante
dans ma base de données (celle dans laquelle je vais chercher mes infos,
elle se trouve dans le même classeur) j'ai #NA qui s'affiche alors que je
pensais que rien n'apparaitrait. Si j'entre une info numérique (qui
n'existe pas dans la base) les cellules restent vide, ce que je veux.
Qu'est-ce que j'oublie ?

En vous remerciant




bcar
Le #24303801
Bonjour,
Si par hasard tu possède un Excel 2007, tu peux regarder
du côté de la fonction SIERREUR pour améliorer ta formule

Le 03/03/2012 08:38, Jol a écrit :
Merci,
Cette solution fonctionne parfaitement.

"Jacky" news:jiro2h$f46$
Bonsoir,

Qu'est-ce que j'oublie ?


Il manque l'argument 0 (faux) dans la recherche d'erreur
SI(ESTERREUR(EQUIV($H8;zone1;0 <==== >>
=SI(ESTERREUR(EQUIV($H8;zone1;0));"";INDEX(Zone2;EQUIV($H8;zone1;0)))

--
Salutations
JJ


"Jol" jirk9j$75t$
Bonjour,
A travers cette formule je complète un tableau.
=SI(ESTERREUR(EQUIV($H8;Zone1));"";INDEX(Zone2;EQUIV($H8;Zone1;0)))
Lorsque la valeur entrée en cellule H8 est non numérique et
inexistante dans ma base de données (celle dans laquelle je vais
chercher mes infos, elle se trouve dans le même classeur) j'ai #NA
qui s'affiche alors que je pensais que rien n'apparaitrait. Si
j'entre une info numérique (qui n'existe pas dans la base) les
cellules restent vide, ce que je veux.
Qu'est-ce que j'oublie ?

En vous remerciant







Publicité
Poster une réponse
Anonyme