Comment faire des calculs avec des cellules comportant "N/A"?

Le
Tom
Je dois faire des calculs dans un tableau excel mais certaines cellules
contiennent le message d'erreur #N/A (résultat d'une recherveV vide)
Comment puis je faire pour remplacer ou considérer ce message comme étant
une valeure nulle?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michdenis
Le #22138951
Bonjour,

Pour enlever les #N/A tu utilises ceci :

=Si(estna(Taformule);"";taformule)




"Tom"
Je dois faire des calculs dans un tableau excel mais certaines cellules
contiennent le message d'erreur #N/A (résultat d'une recherveV vide)
Comment puis je faire pour remplacer ou considérer ce message comme étant
une valeure nulle?
ThierryP
Le #22138941
Bonjour à toi aussi,
Tu peux tester le résultat par
=SI(ESTNA(RECHERCHEV(A2;B1:B4;1;0));"";RECHERCHEV(A2;B1:B4;1;0))

Le plus efficace étant d'utiliser la combinaison des fonctions INDEX et EQUIV
(il y a des tonnes d'exemples sur le forum ou chez Misange (Excelabo.net))

Le 19/05/2010 15:59, Tom a écrit :
Je dois faire des calculs dans un tableau excel mais certaines cellules
contiennent le message d'erreur #N/A (résultat d'une recherveV vide)
Comment puis je faire pour remplacer ou considérer ce message comme étant
une valeure nulle?



De rien, ce fut un plaisir

--


@+ thierryp
-----------------
Passer pour un idiot aux yeux d'un imbécile est une volupté de fin gourmet - G.
Courteline
Publicité
Poster une réponse
Anonyme