Comment faire intervenir la valeur d'une cellule dans une conditio

Le
steph08081979
Hello tout le monde,

Utilisant parfois des formules assez compliquées et cherchant sans cesse à
m'améliorer, j'aimerais trouver une solution pour ceci:

Comment faire intervenir la valeur d'une cellule dans une condition?

Par exemple:

au lieu de:
=SOMME(SI(($C$4:$C$369="steph08081979")*($B$4:$B$369="métal");$A$4:$A$369))

avoir cela et que cela fonctionne:
=SOMME(SI(($C$4:$C$369="A379")*($B$4:$B$369="B378");$A$4:$A$369))

Cela permettrait de tirer la formule sans devoir tout changer au cas où le
type de ressource changerait ("métal" qui deviendrait "hydrogène") et au cas
où le pseudo changerait ("steph08081979" qui deviendrait "Darkenger").

Au fait pour ceux qui ne connaissent pas ce genre de formule, elle doit être
entrée sous la forme de formule matricielle. Après avoir taper la formule, il
faut appuyez sur F2 et sur CTRL+MAJ+ENTRÉE. Si la formule n'est pas entrée
sous la forme d'une formule matricielle, l'erreur #VALEUR ! est renvoyée.

Je remercie ceux qui pourront répondre à cette question.

Bonne continuation
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Modeste
Le #16417281
Bonsour® steph08081979 avec ferveur ;o))) vous nous disiez :

cherchant sans cesse à m'améliorer


cela est un bon principe ;o)))

Comment faire intervenir la valeur d'une cellule dans une condition?
Par exemple:
au lieu de:
=SOMME(SI(($C$4:$C$369="steph08081979")*($B$4:$B$369="métal"); $A$4:$A$369))
avoir cela et que cela fonctionne:
=SOMME(SI(($C$4:$C$369="A379")*($B$4:$B$369="B378");$A$4:$A$369))

Cela permettrait de tirer la formule sans devoir tout changer au cas
où le type de ressource changerait ("métal" qui deviendrait
"hydrogène") et au cas où le pseudo changerait ("steph08081979" qui
deviendrait "Darkenger").



nommer la cellule A379 : pseudo
nommer la cellule B378 : TypeRessource


=SOMMEPROD(($C$4:$C$369=pseudo)*($B$4:$B$369=TypeRessource)*$A$4:$A $369)

;o)))
c'est une pseudo matricielle qui se valide simplement par : Entrée

--
--
@+
;o)))
Sam
Le #16418751
Bonjour, en enlevant les guillemets
=SOMME(SI(($C$4:$C$369£79)*($B$4:$B$369³78);$A$4:$A$369))
Cordialement
Michel dit "Sam"

"steph08081979" message de news:
Hello tout le monde,

Utilisant parfois des formules assez compliquées et cherchant sans cesse à
m'améliorer, j'aimerais trouver une solution pour ceci:

Comment faire intervenir la valeur d'une cellule dans une condition?

Par exemple:

au lieu de:
=SOMME(SI(($C$4:$C$369="steph08081979")*($B$4:$B$369="métal");$A$4:$A$369))

avoir cela et que cela fonctionne:
=SOMME(SI(($C$4:$C$369="A379")*($B$4:$B$369="B378");$A$4:$A$369))

Cela permettrait de tirer la formule sans devoir tout changer au cas où le
type de ressource changerait ("métal" qui deviendrait "hydrogène") et au
cas
où le pseudo changerait ("steph08081979" qui deviendrait "Darkenger").

Au fait pour ceux qui ne connaissent pas ce genre de formule, elle doit
être
entrée sous la forme de formule matricielle. Après avoir taper la formule,
il
faut appuyez sur F2 et sur CTRL+MAJ+ENTRÉE. Si la formule n'est pas entrée
sous la forme d'une formule matricielle, l'erreur #VALEUR ! est renvoyée.

Je remercie ceux qui pourront répondre à cette question.

Bonne continuation...


steph08081979
Le #16470731
Hello Modeste et Sam,

Vous maîtrisez vraiment très bien Excel.

Je vous remercie pour vos conseils.

Bonne soirée.
Publicité
Poster une réponse
Anonyme