Comment faire un mise en forme conditionnelle pour un graphique?

Le
kaku
Est-il possible de contruire un graphique en histogramme avec une mise en
forme conditionnelle? Par exemple que les données négative apparaissent sous
forme de barre rouges et les positives sous forme de barres vertes?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #21436921
Bonjour.
Construis deux série à partir de la série initiale (en colonne A dans
l'exemple) :
une pour les valeurs positives, avec la formule :
=SI(A1>=0;A1;NA())
à recopier vers le bas
et une pour les valeurs négatives :
=SI(A1<0;A1;NA())
et construis ton graphique avec ces deux séries. Un exemple ici :
http://www.cijoint.fr/cjlink.php?file=cj201003/cijhc4ZiQh.xls
Cordialement.
Daniel

Est-il possible de contruire un graphique en histogramme avec une mise en
forme conditionnelle? Par exemple que les données négative apparaissent sous
forme de barre rouges et les positives sous forme de barres vertes?
Sam
Le #21437171
Bonjour,
avec Excel2003, on peut obtenir 2 couleurs (mais je n'ai pas réussi à
maitriser la couleur négative)
après avoir cliquer droit sur le graphique / Format de la série de données /
Motifs / Aires
cochez Inversée si négative

On obtient pour les données positives la couleur choisie et pour les
données négatives un bleu-violet

Cordialement
Michel dit "Sam"

"kaku"
Est-il possible de contruire un graphique en histogramme avec une mise en
forme conditionnelle? Par exemple que les données négative apparaissent
sous
forme de barre rouges et les positives sous forme de barres vertes?
Daniel.C
Le #21438061
Bonjour.
C'est popssible avec XL2010 ;-)
Daniel

Bonjour,
avec Excel2003, on peut obtenir 2 couleurs (mais je n'ai pas réussi à
maitriser la couleur négative)
après avoir cliquer droit sur le graphique / Format de la série de données /
Motifs / Aires
cochez Inversée si négative

On obtient pour les données positives la couleur choisie et pour les données
négatives un bleu-violet

Cordialement
Michel dit "Sam"

"kaku"
Est-il possible de contruire un graphique en histogramme avec une mise en
forme conditionnelle? Par exemple que les données négative apparaissent
sous
forme de barre rouges et les positives sous forme de barres vertes?
Guy85
Le #21438641
Bonjour Daniel.
Je profite du post.
Est-il possible d'avoir une seule courbe avec un changement de couleur
suivant + ou - ?
J'ai Excel 2003 et Excel 2010.
Cordialement
Guy

"Daniel.C"
Bonjour.
Construis deux série à partir de la série initiale (en colonne A dans
l'exemple) :
une pour les valeurs positives, avec la formule :
=SI(A1>=0;A1;NA())
à recopier vers le bas
et une pour les valeurs négatives :
=SI(A1<0;A1;NA())
et construis ton graphique avec ces deux séries. Un exemple ici :
http://www.cijoint.fr/cjlink.php?file=cj201003/cijhc4ZiQh.xls
Cordialement.
Daniel

Est-il possible de contruire un graphique en histogramme avec une mise en
forme conditionnelle? Par exemple que les données négative apparaissent
sous forme de barre rouges et les positives sous forme de barres vertes?




Daniel.C
Le #21438711
Oui, comme l'a dit Sam, dans la mise en forme des séries de données,
dans "remplissage", choisis l'option "Inverser si négatif" et choisis
les couleurs pour les valeurs positives et négatives; ceci pour XL2010.
Tu as une option similaire avec XL2003, mais sans possibilité de
choisir une couleur pour les valeurs négatives. Je n'ai pas essayé
d'enregistrer sous XL2010 et de l'ouvrir avec XL2003 pour voir.
Daniel

Bonjour Daniel.
Je profite du post.
Est-il possible d'avoir une seule courbe avec un changement de couleur
suivant + ou - ?
J'ai Excel 2003 et Excel 2010.
Cordialement
Guy

"Daniel.C"
Bonjour.
Construis deux série à partir de la série initiale (en colonne A dans
l'exemple) :
une pour les valeurs positives, avec la formule :
=SI(A1>=0;A1;NA())
à recopier vers le bas
et une pour les valeurs négatives :
=SI(A1<0;A1;NA())
et construis ton graphique avec ces deux séries. Un exemple ici :
http://www.cijoint.fr/cjlink.php?file=cj201003/cijhc4ZiQh.xls
Cordialement.
Daniel

Est-il possible de contruire un graphique en histogramme avec une mise en
forme conditionnelle? Par exemple que les données négative apparaissent
sous forme de barre rouges et les positives sous forme de barres vertes?




Guy85
Le #21439171
Bonjour,
J'ai essayé avec le modèle de graphique que tu as mis.
Il y a 10 propositions à gauche, mais je ne trouve pas "remplissage".
Cordialement
Guy

"Daniel.C" OL%
Oui, comme l'a dit Sam, dans la mise en forme des séries de données, dans
"remplissage", choisis l'option "Inverser si négatif" et choisis les
couleurs pour les valeurs positives et négatives; ceci pour XL2010. Tu as
une option similaire avec XL2003, mais sans possibilité de choisir une
couleur pour les valeurs négatives. Je n'ai pas essayé d'enregistrer sous
XL2010 et de l'ouvrir avec XL2003 pour voir.
Daniel

Bonjour Daniel.
Je profite du post.
Est-il possible d'avoir une seule courbe avec un changement de couleur
suivant + ou - ?
J'ai Excel 2003 et Excel 2010.
Cordialement
Guy

"Daniel.C"
Bonjour.
Construis deux série à partir de la série initiale (en colonne A dans
l'exemple) :
une pour les valeurs positives, avec la formule :
=SI(A1>=0;A1;NA())
à recopier vers le bas
et une pour les valeurs négatives :
=SI(A1<0;A1;NA())
et construis ton graphique avec ces deux séries. Un exemple ici :
http://www.cijoint.fr/cjlink.php?file=cj201003/cijhc4ZiQh.xls
Cordialement.
Daniel

Est-il possible de contruire un graphique en histogramme avec une mise
en forme conditionnelle? Par exemple que les données négative
apparaissent sous forme de barre rouges et les positives sous forme de
barres vertes?










Daniel.C
Le #21439291
Regarde l'image jointe. Si tu ne t'y retrouve pas, remets le lien de
ton classeur sur www.cjoint.com
http://cjoint.com/?dzr1Jq45KL
Daniel

Bonjour,
J'ai essayé avec le modèle de graphique que tu as mis.
Il y a 10 propositions à gauche, mais je ne trouve pas "remplissage".
Cordialement
Guy

"Daniel.C" OL%
Oui, comme l'a dit Sam, dans la mise en forme des séries de données, dans
"remplissage", choisis l'option "Inverser si négatif" et choisis les
couleurs pour les valeurs positives et négatives; ceci pour XL2010. Tu as
une option similaire avec XL2003, mais sans possibilité de choisir une
couleur pour les valeurs négatives. Je n'ai pas essayé d'enregistrer sous
XL2010 et de l'ouvrir avec XL2003 pour voir.
Daniel

Bonjour Daniel.
Je profite du post.
Est-il possible d'avoir une seule courbe avec un changement de couleur
suivant + ou - ?
J'ai Excel 2003 et Excel 2010.
Cordialement
Guy

"Daniel.C"
Bonjour.
Construis deux série à partir de la série initiale (en colonne A dans
l'exemple) :
une pour les valeurs positives, avec la formule :
=SI(A1>=0;A1;NA())
à recopier vers le bas
et une pour les valeurs négatives :
=SI(A1<0;A1;NA())
et construis ton graphique avec ces deux séries. Un exemple ici :
http://www.cijoint.fr/cjlink.php?file=cj201003/cijhc4ZiQh.xls
Cordialement.
Daniel

Est-il possible de contruire un graphique en histogramme avec une mise
en forme conditionnelle? Par exemple que les données négative
apparaissent sous forme de barre rouges et les positives sous forme de
barres vertes?










Guy85
Le #21439501
Voilà le fichier :
http://cjoint.com/?dzsoupTDnK
Guy

"Daniel.C" %
Regarde l'image jointe. Si tu ne t'y retrouve pas, remets le lien de ton
classeur sur www.cjoint.com
http://cjoint.com/?dzr1Jq45KL
Daniel

Bonjour,
J'ai essayé avec le modèle de graphique que tu as mis.
Il y a 10 propositions à gauche, mais je ne trouve pas "remplissage".
Cordialement
Guy

"Daniel.C" OL%
Oui, comme l'a dit Sam, dans la mise en forme des séries de données,
dans "remplissage", choisis l'option "Inverser si négatif" et choisis
les couleurs pour les valeurs positives et négatives; ceci pour XL2010.
Tu as une option similaire avec XL2003, mais sans possibilité de choisir
une couleur pour les valeurs négatives. Je n'ai pas essayé d'enregistrer
sous XL2010 et de l'ouvrir avec XL2003 pour voir.
Daniel

Bonjour Daniel.
Je profite du post.
Est-il possible d'avoir une seule courbe avec un changement de couleur
suivant + ou - ?
J'ai Excel 2003 et Excel 2010.
Cordialement
Guy

"Daniel.C"
Bonjour.
Construis deux série à partir de la série initiale (en colonne A dans
l'exemple) :
une pour les valeurs positives, avec la formule :
=SI(A1>=0;A1;NA())
à recopier vers le bas
et une pour les valeurs négatives :
=SI(A1<0;A1;NA())
et construis ton graphique avec ces deux séries. Un exemple ici :
http://www.cijoint.fr/cjlink.php?file=cj201003/cijhc4ZiQh.xls
Cordialement.
Daniel

Est-il possible de contruire un graphique en histogramme avec une
mise en forme conditionnelle? Par exemple que les données négative
apparaissent sous forme de barre rouges et les positives sous forme
de barres vertes?
















Daniel.C
Le #21439491
Ce n'est pas valable pour les courbes. Ca fonctionne pour les
histogrammes et les barres et peut-être d'autres types de graphiques.
Daniel

Voilà le fichier :
http://cjoint.com/?dzsoupTDnK
Guy

"Daniel.C" %
Regarde l'image jointe. Si tu ne t'y retrouve pas, remets le lien de ton
classeur sur www.cjoint.com
http://cjoint.com/?dzr1Jq45KL
Daniel

Bonjour,
J'ai essayé avec le modèle de graphique que tu as mis.
Il y a 10 propositions à gauche, mais je ne trouve pas "remplissage".
Cordialement
Guy

"Daniel.C" OL%
Oui, comme l'a dit Sam, dans la mise en forme des séries de données, dans
"remplissage", choisis l'option "Inverser si négatif" et choisis les
couleurs pour les valeurs positives et négatives; ceci pour XL2010. Tu as
une option similaire avec XL2003, mais sans possibilité de choisir une
couleur pour les valeurs négatives. Je n'ai pas essayé d'enregistrer sous
XL2010 et de l'ouvrir avec XL2003 pour voir.
Daniel

Bonjour Daniel.
Je profite du post.
Est-il possible d'avoir une seule courbe avec un changement de couleur
suivant + ou - ?
J'ai Excel 2003 et Excel 2010.
Cordialement
Guy

"Daniel.C"
Bonjour.
Construis deux série à partir de la série initiale (en colonne A dans
l'exemple) :
une pour les valeurs positives, avec la formule :
=SI(A1>=0;A1;NA())
à recopier vers le bas
et une pour les valeurs négatives :
=SI(A1<0;A1;NA())
et construis ton graphique avec ces deux séries. Un exemple ici :
http://www.cijoint.fr/cjlink.php?file=cj201003/cijhc4ZiQh.xls
Cordialement.
Daniel

Est-il possible de contruire un graphique en histogramme avec une mise
en forme conditionnelle? Par exemple que les données négative
apparaissent sous forme de barre rouges et les positives sous forme de
barres vertes?
















Guy85
Le #21439481
ok merci

"Daniel.C" eyKSj$
Ce n'est pas valable pour les courbes. Ca fonctionne pour les histogrammes
et les barres et peut-être d'autres types de graphiques.
Daniel

Voilà le fichier :
http://cjoint.com/?dzsoupTDnK
Guy

"Daniel.C" %
Regarde l'image jointe. Si tu ne t'y retrouve pas, remets le lien de ton
classeur sur www.cjoint.com
http://cjoint.com/?dzr1Jq45KL
Daniel

Bonjour,
J'ai essayé avec le modèle de graphique que tu as mis.
Il y a 10 propositions à gauche, mais je ne trouve pas "remplissage".
Cordialement
Guy

"Daniel.C" OL%
Oui, comme l'a dit Sam, dans la mise en forme des séries de données,
dans "remplissage", choisis l'option "Inverser si négatif" et choisis
les couleurs pour les valeurs positives et négatives; ceci pour
XL2010. Tu as une option similaire avec XL2003, mais sans possibilité
de choisir une couleur pour les valeurs négatives. Je n'ai pas essayé
d'enregistrer sous XL2010 et de l'ouvrir avec XL2003 pour voir.
Daniel

Bonjour Daniel.
Je profite du post.
Est-il possible d'avoir une seule courbe avec un changement de
couleur suivant + ou - ?
J'ai Excel 2003 et Excel 2010.
Cordialement
Guy

"Daniel.C" news:
Bonjour.
Construis deux série à partir de la série initiale (en colonne A
dans l'exemple) :
une pour les valeurs positives, avec la formule :
=SI(A1>=0;A1;NA())
à recopier vers le bas
et une pour les valeurs négatives :
=SI(A1<0;A1;NA())
et construis ton graphique avec ces deux séries. Un exemple ici :
http://www.cijoint.fr/cjlink.php?file=cj201003/cijhc4ZiQh.xls
Cordialement.
Daniel

Est-il possible de contruire un graphique en histogramme avec une
mise en forme conditionnelle? Par exemple que les données négative
apparaissent sous forme de barre rouges et les positives sous forme
de barres vertes?






















Publicité
Poster une réponse
Anonyme