comment faire pour avoir le nombre de mardi entre deux date

Le
GEORGES
MERCI ATOUS POUR VOTRE AIDE
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
FS
Le #20795271
Bonjour,

Avec la date de départ en A1 et celle de fin de période en B1 :

=SOMME((JOURSEM(DATE(ANNEE(A1);MOIS(A1);LIGNE(INDIRECT("1:"&(B1-A1))));2)=2)*1)

(Matricielle : validation par Ctrl+Maj+Entrée)

1 pour rechercher les lundis, 2 les mardis, etc.

FS
--
Frédéric SIGONNEAU
Modules et modèles pour Excel :
http://frederic.sigonneau.free.fr/

GEORGES a écrit :
MERCI ATOUS POUR VOTRE AIDE


FS
Le #20795471
Correction :
(Je ne sais pas pourquoi j'avais fait l'hypothèse que ta date de départ
était "obligatoirement" le 1er d'un mois).
Donc, avec 2 dates quelconques de début et de fin en A1 et B1, et
toujours validation matricielle :

=SOMME((JOURSEM(DATE(ANNEE($A$1);MOIS($A$1);LIGNE(INDIRECT(JOUR($A$1)&":"&(JOUR($A$1)+($B$1-$A$1)))));2)=1)*1)

Note : J'ai fait une autre hypothèse qui n'est peut-être pas la bonne
pour toi : les jours de début et de fin de période sont inclus dans le
calcul.

FS
--
Frédéric SIGONNEAU
Modules et modèles pour Excel :
http://frederic.sigonneau.free.fr/

GEORGES a écrit :
MERCI ATOUS POUR VOTRE AIDE


JB
Le #20796271
Bonsoir,

Dates en A1 et B1

=SOMMEPROD(--(JOURSEM(LIGNE(INDIRECT(A1&":"&B1));2)=2))

JB
http://boisgontierjacques.free.fr



On 18 déc, 16:50, GEORGES
MERCI ATOUS POUR VOTRE AIDE


AndréBdR
Le #20797961
Il y a même plus court il y a quelque temps:
=ENT((B1-JOURSEM(B1-2)-A1+8)/7)
Bonne journée, bien au chaud.

"JB"
Bonsoir,

Dates en A1 et B1

=SOMMEPROD(--(JOURSEM(LIGNE(INDIRECT(A1&":"&B1));2)=2))

JB
http://boisgontierjacques.free.fr



On 18 déc, 16:50, GEORGES
MERCI ATOUS POUR VOTRE AIDE


Publicité
Poster une réponse
Anonyme