Comment faire SOUS.TOTAL de NB.SI

Le
eric
Dans un tableau avec filtre sur Excel 2003, savez vous comment je peux
utiliser la fonction SOUS.TOTAL à partir de la fonction NB.SI?

En fait, ce que je veux savoir, c'est pour un ensemble de lignes filtrées,
quel est le nombre total de lignes où il ya une cellule égale à 100.

La fonction SOUS.TOTAL me permet de gérer les réponses avec le filtre

La fonction NB.SI me permet de trouver le total non filtré des cellules
égales à 100

Mais je n'arrive pas à combiner ces 2 Fonctions

Merci d'avance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Le #4393631
Bonsoir "eric"

Dans un tableau avec filtre sur Excel 2003, savez vous comment je peux
utiliser la fonction SOUS.TOTAL à partir de la fonction NB.SI?

En fait, ce que je veux savoir, c'est pour un ensemble de lignes filtrées,
quel est le nombre total de lignes où il ya une cellule égale à 100.

La fonction SOUS.TOTAL me permet de gérer les réponses avec le filtre

La fonction NB.SI me permet de trouver le total non filtré des cellules
égales à 100

Mais je n'arrive pas à combiner ces 2 Fonctions

Merci d'avance


=SOMMEPROD((filtre)*(plage0))
Exemple
=SOMMEPROD((A1:A20="A")*(B1:B200))
compte les cellules de B = à 100 pour la colonne A ="A" (ton filtre)

--
Ricky [MVP] Visitez les FAQ...
http://www.faqoe.com
http://www.excelabo.net
http://faqword.free.fr

JB
Le #4393621
Bonjour,

=SOMMEPROD((SOUS.TOTAL(3;INDIRECT("D"&LIGNE(D2:D1000)))*(D2:D1000>0) ))

Cordialement JB

On 11 avr, 18:32, eric
Dans un tableau avec filtre sur Excel 2003, savez vous comment je peux
utiliser la fonction SOUS.TOTAL à partir de la fonction NB.SI?

En fait, ce que je veux savoir, c'est pour un ensemble de lignes filtré es,
quel est le nombre total de lignes où il ya une cellule égale à 100.

La fonction SOUS.TOTAL me permet de gérer les réponses avec le filtre

La fonction NB.SI me permet de trouver le total non filtré des cellules
égales à 100

Mais je n'arrive pas à combiner ces 2 Fonctions

Merci d'avance


JB
Le #4393611
=SOMMEPROD((SOUS.TOTAL(3;INDIRECT("D"&LIGNE(D2:D1000)))*(D2:D10000)))
Valider avec Maj+Ctrl+Entrée

JB

On 11 avr, 18:32, eric
Dans un tableau avec filtre sur Excel 2003, savez vous comment je peux
utiliser la fonction SOUS.TOTAL à partir de la fonction NB.SI?

En fait, ce que je veux savoir, c'est pour un ensemble de lignes filtré es,
quel est le nombre total de lignes où il ya une cellule égale à 100.

La fonction SOUS.TOTAL me permet de gérer les réponses avec le filtre

La fonction NB.SI me permet de trouver le total non filtré des cellules
égales à 100

Mais je n'arrive pas à combiner ces 2 Fonctions

Merci d'avance


Publicité
Poster une réponse
Anonyme