Comment ne pas tenir compte des informations filtrees

Le
Mistersaku
Bonjour a tous,

J'utilise la fonction NB.SI pour compter le nombre de fois ou la lettre
''a'' apparait dans ma colonne mais quand je fais un filtre sur une autre
colonne j'aimerais compter que les ''a'' apparant, tous les ''a'' filtres ne
doit pas etre compte. Comment puis je faire??

Merci de votre aide.

Mistersaku
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #4274551
bonjour Mistersaku,

utilise la fonction SommProd,
par exemple en reproduisant la condition si le filtre sur la colonne B est = 1

=SOMMEPROD((A2:A100="a")*(B2:B100=1))

si la condition des filtres en est une "contient"
il faudra utiliser un tcd.

isabelle

Bonjour a tous,

J'utilise la fonction NB.SI pour compter le nombre de fois ou la lettre
''a'' apparait dans ma colonne mais quand je fais un filtre sur une autre
colonne j'aimerais compter que les ''a'' apparant, tous les ''a'' filtres ne
doit pas etre compte. Comment puis je faire??

Merci de votre aide.

Mistersaku


Mistersaku
Le #4274501
Bonjour Isabelle,

J'ai essaye ce que tu m'as dit mais ca ne fonctionne pas ou peut etre que je
n'est pas etait assez clair.
Je cherche a connaitre le nombre de lettres identiques que j'ai dans une
colonne donnee. Mais le probleme c'est quand j'utilise un filtre sur une
autre colonne, le nombre de lignes diminue mais j'obtiens toujours le meme
nombre avec la fonction NB.SI.
Ce que j'essaye d'obtenir ressemble un peu a ca.

Avant filtre

Nombre de a 5
Nombre de b 2
Lettre Nombre
a 1
a 1
a 1
a 1
a 2
b 2
b 3

Apres un filtre dans la colonne B, en ne prennant que les 1, le filtre peut
etre fait sur n'importe quell colonne.

Nombre de a 4
Nombre de b 0
Lettre Nombre
a 1
a 1
a 1
a 1







bonjour Mistersaku,

utilise la fonction SommProd,
par exemple en reproduisant la condition si le filtre sur la colonne B est = 1

=SOMMEPROD((A2:A100="a")*(B2:B100=1))

si la condition des filtres en est une "contient"
il faudra utiliser un tcd.

isabelle

Bonjour a tous,

J'utilise la fonction NB.SI pour compter le nombre de fois ou la lettre
''a'' apparait dans ma colonne mais quand je fais un filtre sur une autre
colonne j'aimerais compter que les ''a'' apparant, tous les ''a'' filtres ne
doit pas etre compte. Comment puis je faire??

Merci de votre aide.

Mistersaku





JB
Le #4274471
Bonjour,

=SOMMEPROD((SOUS.TOTAL(3;INDIRECT("a"&LIGNE(A2:A1000)))*(A2:A1000="a")))

http://cjoint.com/?eeqtZoppSu

JB


On 4 avr, 15:58, Mistersaku wrote:
Bonjour Isabelle,

J'ai essaye ce que tu m'as dit mais ca ne fonctionne pas ou peut etre que je
n'est pas etait assez clair.
Je cherche a connaitre le nombre de lettres identiques que j'ai dans une
colonne donnee. Mais le probleme c'est quand j'utilise un filtre sur une
autre colonne, le nombre de lignes diminue mais j'obtiens toujours le meme
nombre avec la fonction NB.SI.
Ce que j'essaye d'obtenir ressemble un peu a ca.

Avant filtre

Nombre de a 5
Nombre de b 2
Lettre Nombre
a 1
a 1
a 1
a 1
a 2
b 2
b 3

Apres un filtre dans la colonne B, en ne prennant que les 1, le filtre pe ut
etre fait sur n'importe quell colonne.

Nombre de a 4
Nombre de b 0
Lettre Nombre
a 1
a 1
a 1
a 1




bonjour Mistersaku,

utilise la fonction SommProd,
par exemple en reproduisant la condition si le filtre sur la colonne B est = 1

=SOMMEPROD((A2:A100="a")*(B2:B100=1))

si la condition des filtres en est une "contient"
il faudra utiliser un tcd.

isabelle

Bonjour a tous,

J'utilise la fonction NB.SI pour compter le nombre de fois ou la lett re
''a'' apparait dans ma colonne mais quand je fais un filtre sur une a utre
colonne j'aimerais compter que les ''a'' apparant, tous les ''a'' fil tres ne
doit pas etre compte. Comment puis je faire??

Merci de votre aide.

Mistersaku- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -




Mistersaku
Le #4274271
Merci JB,

Ca fonctionne tres bien mais pourquoi quand j'insert une colonne ca ne
fonctionne plus, pourtant la formule et la suivante

=SOMMEPROD((SOUS.TOTAL(3;INDIRECT("a"&LIGNE(B2:B1000)))*(B2:B1000="a")))


Bonjour,

=SOMMEPROD((SOUS.TOTAL(3;INDIRECT("a"&LIGNE(A2:A1000)))*(A2:A1000="a")))

http://cjoint.com/?eeqtZoppSu

JB


On 4 avr, 15:58, Mistersaku wrote:
Bonjour Isabelle,

J'ai essaye ce que tu m'as dit mais ca ne fonctionne pas ou peut etre que je
n'est pas etait assez clair.
Je cherche a connaitre le nombre de lettres identiques que j'ai dans une
colonne donnee. Mais le probleme c'est quand j'utilise un filtre sur une
autre colonne, le nombre de lignes diminue mais j'obtiens toujours le meme
nombre avec la fonction NB.SI.
Ce que j'essaye d'obtenir ressemble un peu a ca.

Avant filtre

Nombre de a 5
Nombre de b 2
Lettre Nombre
a 1
a 1
a 1
a 1
a 2
b 2
b 3

Apres un filtre dans la colonne B, en ne prennant que les 1, le filtre peut
etre fait sur n'importe quell colonne.

Nombre de a 4
Nombre de b 0
Lettre Nombre
a 1
a 1
a 1
a 1




bonjour Mistersaku,

utilise la fonction SommProd,
par exemple en reproduisant la condition si le filtre sur la colonne B est = 1

=SOMMEPROD((A2:A100="a")*(B2:B100=1))

si la condition des filtres en est une "contient"
il faudra utiliser un tcd.

isabelle

Bonjour a tous,

J'utilise la fonction NB.SI pour compter le nombre de fois ou la lettre
''a'' apparait dans ma colonne mais quand je fais un filtre sur une autre
colonne j'aimerais compter que les ''a'' apparant, tous les ''a'' filtres ne
doit pas etre compte. Comment puis je faire??

Merci de votre aide.

Mistersaku- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -









JB
Le #4274241
Il faut modifier le no de colonne: b au lieu de a

=SOMMEPROD((SOUS.TOTAL(3;INDIRECT("b"&LIGNE(B2:B1000)))*(B2:B1000="a")))

JB

On 4 avr, 18:32, Mistersaku wrote:
Merci JB,

Ca fonctionne tres bien mais pourquoi quand j'insert une colonne ca ne
fonctionne plus, pourtant la formule et la suivante

=SOMMEPROD((SOUS.TOTAL(3;INDIRECT("a"&LIGNE(B2:B1000)))*(B2:B1000="a" )))




Bonjour,

=SOMMEPROD((SOUS.TOTAL(3;INDIRECT("a"&LIGNE(A2:A1000)))*(A2:A1000=" a")))

http://cjoint.com/?eeqtZoppSu

JB

On 4 avr, 15:58, Mistersaku wrote:
Bonjour Isabelle,

J'ai essaye ce que tu m'as dit mais ca ne fonctionne pas ou peut etre que je
n'est pas etait assez clair.
Je cherche a connaitre le nombre de lettres identiques que j'ai dans une
colonne donnee. Mais le probleme c'est quand j'utilise un filtre sur une
autre colonne, le nombre de lignes diminue mais j'obtiens toujours le meme
nombre avec la fonction NB.SI.
Ce que j'essaye d'obtenir ressemble un peu a ca.

Avant filtre

Nombre de a 5
Nombre de b 2
Lettre Nombre
a 1
a 1
a 1
a 1
a 2
b 2
b 3

Apres un filtre dans la colonne B, en ne prennant que les 1, le filtr e peut
etre fait sur n'importe quell colonne.

Nombre de a 4
Nombre de b 0
Lettre Nombre
a 1
a 1
a 1
a 1




bonjour Mistersaku,

utilise la fonction SommProd,
par exemple en reproduisant la condition si le filtre sur la colonn e B est = 1

=SOMMEPROD((A2:A100="a")*(B2:B100=1))

si la condition des filtres en est une "contient"
il faudra utiliser un tcd.

isabelle

Bonjour a tous,

J'utilise la fonction NB.SI pour compter le nombre de fois ou la lettre
''a'' apparait dans ma colonne mais quand je fais un filtre sur u ne autre
colonne j'aimerais compter que les ''a'' apparant, tous les ''a'' filtres ne
doit pas etre compte. Comment puis je faire??

Merci de votre aide.

Mistersaku- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -- Masquer le texte d es messages précédents -



- Afficher le texte des messages précédents -






Mistersaku
Le #4274221
Je te dois une fiere chandelle ca fonctionne tres bien, merci beaucoup.

Mistersaku


Il faut modifier le no de colonne: b au lieu de a

=SOMMEPROD((SOUS.TOTAL(3;INDIRECT("b"&LIGNE(B2:B1000)))*(B2:B1000="a")))

JB

On 4 avr, 18:32, Mistersaku wrote:
Merci JB,

Ca fonctionne tres bien mais pourquoi quand j'insert une colonne ca ne
fonctionne plus, pourtant la formule et la suivante

=SOMMEPROD((SOUS.TOTAL(3;INDIRECT("a"&LIGNE(B2:B1000)))*(B2:B1000="a")))




Bonjour,

=SOMMEPROD((SOUS.TOTAL(3;INDIRECT("a"&LIGNE(A2:A1000)))*(A2:A1000="a")))

http://cjoint.com/?eeqtZoppSu

JB

On 4 avr, 15:58, Mistersaku wrote:
Bonjour Isabelle,

J'ai essaye ce que tu m'as dit mais ca ne fonctionne pas ou peut etre que je
n'est pas etait assez clair.
Je cherche a connaitre le nombre de lettres identiques que j'ai dans une
colonne donnee. Mais le probleme c'est quand j'utilise un filtre sur une
autre colonne, le nombre de lignes diminue mais j'obtiens toujours le meme
nombre avec la fonction NB.SI.
Ce que j'essaye d'obtenir ressemble un peu a ca.

Avant filtre

Nombre de a 5
Nombre de b 2
Lettre Nombre
a 1
a 1
a 1
a 1
a 2
b 2
b 3

Apres un filtre dans la colonne B, en ne prennant que les 1, le filtre peut
etre fait sur n'importe quell colonne.

Nombre de a 4
Nombre de b 0
Lettre Nombre
a 1
a 1
a 1
a 1




bonjour Mistersaku,

utilise la fonction SommProd,
par exemple en reproduisant la condition si le filtre sur la colonne B est = 1

=SOMMEPROD((A2:A100="a")*(B2:B100=1))

si la condition des filtres en est une "contient"
il faudra utiliser un tcd.

isabelle

Bonjour a tous,

J'utilise la fonction NB.SI pour compter le nombre de fois ou la lettre
''a'' apparait dans ma colonne mais quand je fais un filtre sur une autre
colonne j'aimerais compter que les ''a'' apparant, tous les ''a'' filtres ne
doit pas etre compte. Comment puis je faire??

Merci de votre aide.

Mistersaku- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -











Publicité
Poster une réponse
Anonyme