Comment réparer xp ?

Le
Lionel.L
bonjour

j'utilise windows xp + sp3
aujourd'hui après son scan hebdomadaire, spybot me signale un trojan
dont j'ai déjà oublié le nom mais qui a visiblement fait beaucoup de dégats.
Je ne m'affole pas et je demande à spybot de corriger les problèmes,
suite a quoi mon ordinateur m'indique qu'il va redémarrer.

au redémarrage le choses se gâtent:
car des fichiers nécéssaires au boot de windows sont désormais manquants
(ntoskrnl.exe en tête).

Je ne m'affole toujours pas et j'introduis mon cd d'install et reboot a
nouveau sur le cd cette foi.
Je choisi l'option de réparation, jusque la rien d'anormal.
Mais a un moment donné, le programme d'install me demande le mot de
passe administrateur que j'indique (dans mon cas rien du tout) j'appuie
sur entrée puis je me retrouve avec l'invité de commande:
c:windows et puis plus rien !

que faire a partir de maintenant ?
car les fichiers manquants ne sont pas directement accessibles sur le
cdrom de windows (ce serait trop simple)

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 4
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
testeur
Le #19412301
C'est probablement le record de boot qui a été modifié ou supprimé.
Avec votre CD, une fois sous l'invite de commande tapez
FIXMBR
puis FIXBOOT
vous avez la liste des commandes en faisant HELP
Vous pouvez vérifier que votre fichier ntoskrnl.exe est bien dans C:WindowsSystem32

Au pire il faut faire une réparation, avec votre CD windows :
1ere question : faire Installer
Il va retrouver votre ancien système et vous proposer de le réparer, donc à la deuxième question
faire R

Tous vos fichiers personnels sont gardés.
Seules les mises à jour postérieure à votre CD sont perdues.

Olivier
Jean-Claude BELLAMY
Le #19412511
"Lionel.L" news:
bonjour

j'utilise windows xp + sp3
aujourd'hui après son scan hebdomadaire, spybot me signale un trojan dont
j'ai déjà oublié le nom mais qui a visiblement fait beaucoup de dégats.
Je ne m'affole pas et je demande à spybot de corriger les problèmes, suite
a quoi mon ordinateur m'indique qu'il va redémarrer.

au redémarrage le choses se gâtent:
car des fichiers nécéssaires au boot de windows sont désormais manquants
(ntoskrnl.exe en tête).



Très souvent, cette erreur est due en réalité à un mauvais "aiguillage" de
partition dans le fichier boot.ini.
En effet, la ligne "multi(x)disk(y)rdisk(z)partition(n)" a pour but de
situer le fichier NTOSKRNL.EXE (le noyau de NT).
Donc si p.ex. le n° de partition est erroné (suite, px. à la création ou
suppression d'autres partitions), le fichier NTOSKRNL ne sera pas trouvé,
d'où ce message d'erreur.


Je ne m'affole toujours pas et j'introduis mon cd d'install et reboot a
nouveau sur le cd cette foi.
Je choisi l'option de réparation, jusque la rien d'anormal.



Et bien si !
(du côté de la logique de Microsoft, j'entends)

Pour réparer Windws, il NE FAUT PAS choisir "réparation" tout de suite !
Cette commande sert à lancer la CDR (Console de récupération) laquelle, dans
un cas comme le tien, ne sert à rien ...

Mais a un moment donné, le programme d'install me demande le mot de passe
administrateur que j'indique (dans mon cas rien du tout) j'appuie sur
entrée puis je me retrouve avec l'invité de commande:
c:windows et puis plus rien !


NORMAL !
C'est çà la CDR ! ;-)

que faire a partir de maintenant ?


RIEN, sinon rebooter et passer en VRAIE réparation de Windows !

car les fichiers manquants ne sont pas directement accessibles sur le
cdrom de windows (ce serait trop simple)



Va sur mon site, ici :
http://www.bellamyjc.org/fr/windows2000.html#repair

J'explique comment procéder !


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP] - http://www.bellamyjc.org
Lionel.L
Le #19414511
Le soucis c'est que l'install ne me propose pas du tout la possibilité
de réparation après que j'ai accepté le contrat de licence.

Et après vérification, le fichier ntoskrnl.exe n'est pas présent sur le
disque dur.
Jean-Claude BELLAMY
Le #19415731
"Lionel.L" news:
Le soucis c'est que l'install ne me propose pas du tout la possibilité de
réparation après que j'ai accepté le contrat de licence.


????
Utiliserais-tu un CD de constructeur ne permettant que la réinstallation
"from scratch" ?

Et après vérification, le fichier ntoskrnl.exe n'est pas présent sur le
disque dur.



En es-tu bien sûr ?
Car ce fichier ne disparait pas comme çà !
Il est situé dans %systemroot%system32
p.ex. c:windowssystem32


--
May the Force be with You!
La Connaissance s'accroît quand on la partage
----------------------------------------------------------
Jean-Claude BELLAMY [MVP] - http://www.bellamyjc.org
Lionel.L
Le #19416631
Jean-Claude BELLAMY a écrit :
????
Utiliserais-tu un CD de constructeur ne permettant que la réinstallation
"from scratch" ?


Je ne crois pas, mon PC provient d'un assembleur et j'ai acheté windows
séparément.

En es-tu bien sûr ?
Car ce fichier ne disparait pas comme çà !
Il est situé dans %systemroot%system32
p.ex. c:windowssystem32


J'en suis désormais certain
Dans le repertoire sytem32, la commande dir ntos*.exe ne donne aucun
résultat,
et il n'a en effet pas disparu (ainsi que d'autres) par magie, je
soupçonne fortement spybot de l'avoir purement et simplement effacé.
Donc pour poser ma question autrement comment récupérer manuellement ce
fichier sur le cd d'installation ?
Lionel.L
Le #19417581
Problème en cours de résolution, j'ai dut faire un tour de passe passe
en mettant un faux fichier dans le répertoire system32 afin de pouvoir
lancer une install et avoir accès au menu de réparation.
reinstallation en cours actuellement.

Merci tout de même pour les conseils.
Lionel.L
Le #19418271
bonsoir

l'installation s'est déroulée sans problèmes notoires.
Windows me présente l'invité d'ouverture de session, je choisi ma
session qui semble s'ouvrir puis se referme aussitôt.
Même problème en mode sans échec quelle que soit la session choisie
(utilisateur ou admin).

C'est désespérant.
JF
Le #19419301
*Bonjour Lionel.L* !

J'en suis désormais certain
Dans le repertoire sytem32, la commande dir ntos*.exe ne donne aucun
résultat,






Pour rappel on trouve une copie du fichier dans
c:windowssystem32dllcache


l'installation s'est déroulée sans problèmes notoires.
Windows me présente l'invité d'ouverture de session, je choisi ma session qui
semble s'ouvrir puis se referme aussitôt.
Même problème en mode sans échec quelle que soit la session choisie
(utilisateur ou admin).




http://fspsa.free.fr/ubcd4win.htm#impossibilite-entrer-session-resolu
Vérifier la variable Userinit :
HKLMSOFTWAREMicrosoftWindows NTCurrentVersionWinlogon
Userinit = C:WINDOWSsystem32userinit.exe,
qui est la valeur normale.
On peut mettre
Userinit = userinit.exe,
pour se prémunir des problèmes de lettre.

--
Salutations, Jean-François
http://fspsa.free.fr/Index-de-la-FAQ-WINXP-de-Panthere-Noire.htm
http://fspsa.free.fr/Capture-Ecran-et-Publication-vers-Newsgroups.htm
http://fspsa.free.fr/Virus-Malwares-Comment-on-se-fait-infecter.htm
Herser
Le #19419891
Lionel.L wrote:
bonsoir

l'installation s'est déroulée sans problèmes notoires.
Windows me présente l'invité d'ouverture de session, je choisi ma
session qui semble s'ouvrir puis se referme aussitôt.
Même problème en mode sans échec quelle que soit la session choisie
(utilisateur ou admin).

C'est désespérant.



Bonsoir
Le virus que tu as "gagné" est plus méchant que prévu.
Le conseil de JF devrait te redonner la main, mais j'ai peur que ce ce soit
pas fini.
Si tu y arrives, fait un scan HiJackThis :
http://www.zebulon.fr/dossiers/43-hijackthis.html
Si tu n'arrives pas interpréter le log d'analyse, envoie le sur un forum de
désinfection.
Ou sur CiJoint et renvoie nous le lien ici :
http://www.cijoint.fr/index.php
On essaiera d'en savoir un peu plus sur le malware, et comment t'en
débarrasser

Herser
JF
Le #19421631
*Bonjour Herser* !

Lionel.L wrote:
l'installation s'est déroulée sans problèmes notoires.
Windows me présente l'invité d'ouverture de session, je choisi ma
session qui semble s'ouvrir puis se referme aussitôt.
Même problème en mode sans échec quelle que soit la session choisie
(utilisateur ou admin).


Bonsoir
Le virus que tu as "gagné" est plus méchant que prévu.
Le conseil de JF devrait te redonner la main, mais j'ai peur que ce ce soit
pas fini.
Si tu y arrives, fait un scan HiJackThis :
http://www.zebulon.fr/dossiers/43-hijackthis.html
Si tu n'arrives pas interpréter le log d'analyse, envoie le sur un forum de
désinfection.
Ou sur CiJoint et renvoie nous le lien ici :
http://www.cijoint.fr/index.php
On essaiera d'en savoir un peu plus sur le malware, et comment t'en
débarrasser
Herser



Tu as raison d'anticiper afin que Lionel ne nous quitte pas trop vite,
sans nettoyer son système. J'avais d'ailleurs ajouté un conseil à la
fin de la section
http://fspsa.free.fr/ubcd4win.htm#impossibilite-entrer-session-resolu
==>

<citation>
Compléter avec un petit nettoyage de parasites :
http://www.malekal.com/tutorial_MSNFix.php
http://www.malekal.com/tutorial_MalwareBytes_AntiMalware.php
<citation>

Rappel : ZHP est une bonne aide à l'interprétation des logs :

Zeb Help Process
Aide à l'analyse des 135 000 items possibles des rapports de HiJackThis
et autres générateurs de logs (liste)
http://www.premiumorange.com/zeb-help-process
http://www.premiumorange.com/zeb-help-process/zhp_liste_rapport.html
Tu verras je pense avec satisfaction que MBAM fait partie de la liste.

Mci coop !

--
Salutations, Jean-François
http://fspsa.free.fr/Index-de-la-FAQ-WINXP-de-Panthere-Noire.htm
http://fspsa.free.fr/Capture-Ecran-et-Publication-vers-Newsgroups.htm
http://fspsa.free.fr/contamination-lecteurs-amovibles.htm
Publicité
Poster une réponse
Anonyme