Comment rétablir les propriétés d'une connexion au SGBD après un détachement

Le
ML
Bonjour,

Je rencontre une difficulté suite au détachement, puis au rattachement d'une
base de données SQLServer 2005.

Le problème rencontré concerne plus particulièrement les paramètres de la
connexion.


Description du scénario :

.Avant le détachement de la base de données, la connexion utilisée a les
propriétés de mappage d'utilisateur :
.Case à cocher activée de mappage de la base de données. Le nom de la base
de données, l'utilisateur et le schéma par défaut sont identiques, et ont
le même nom que celui de la connexion.
.Le nom d'utilisateur figure bien dans la liste des schémas d'appartenance
de l'utilisteur.
.Le membre : db_owner est coché dans la liste d'appartenance au rôle de
base de données.

Après le rattchement de cette base de données, les propriétés de mappage de
l'utilisateur de cette même connexion sont modifiées :
.Case à cocher déactivée de mappage de la base de données. Le nom de la
base de données est présent, mais l'utilisateur et le schéma par défaut ne
sont plus renseignés.

De ce fait, il n'est plus possible d'établir de connexion au SGBD à l'aide
de ce nom de connexion.


Si j'entreprends de modifier ces propriétés en rendant la case à cocher
active, puis en renseignant le nom d'utilisateur et schéma par défaut, une
erreur survient quand je valide la saisie. (utilisateur existant dans la
base de données).


Quelle est la procédure pour rétablir les propriétés de cette connexion ?


Configuration actuelle :
.Serveur 2003.
.Base de sonnées Sqlserver 2005.


D'avance merci pourtout renseignement.

MhL.














d'utilisateur
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
TheSteph
Le #16547371
J'ai déjà eu ce genre de problème que j'ai résolu en supprimant
l'utilisateur (via dans le "dossier" sécurité de cette db) et ensuite en le
recréant et en re-cochant les bonnes options.

Steph.


"ML" news:OIdpspi$
Bonjour,

Je rencontre une difficulté suite au détachement, puis au rattachement
d'une base de données SQLServer 2005.

Le problème rencontré concerne plus particulièrement les paramètres de la
connexion.


Description du scénario :

.Avant le détachement de la base de données, la connexion utilisée a les
propriétés de mappage d'utilisateur :
.Case à cocher activée de mappage de la base de données. Le nom de la base
de données, l'utilisateur et le schéma par défaut sont identiques, et ont
le même nom que celui de la connexion.
.Le nom d'utilisateur figure bien dans la liste des schémas d'appartenance
de l'utilisteur.
.Le membre : db_owner est coché dans la liste d'appartenance au rôle de
base de données.

Après le rattchement de cette base de données, les propriétés de mappage
de l'utilisateur de cette même connexion sont modifiées :
.Case à cocher déactivée de mappage de la base de données. Le nom de la
base de données est présent, mais l'utilisateur et le schéma par défaut
ne sont plus renseignés.

De ce fait, il n'est plus possible d'établir de connexion au SGBD à l'aide
de ce nom de connexion.


Si j'entreprends de modifier ces propriétés en rendant la case à cocher
active, puis en renseignant le nom d'utilisateur et schéma par défaut, une
erreur survient quand je valide la saisie. (utilisateur existant dans la
base de données).


Quelle est la procédure pour rétablir les propriétés de cette connexion ?


Configuration actuelle :
.Serveur 2003.
.Base de sonnées Sqlserver 2005.


D'avance merci pourtout renseignement.

MhL.














d'utilisateur






EmanuelL
Le #16547901
Bonjour,

Je confirme la solution de TheSteph.


Après mure réflexion, TheSteph a écrit :
J'ai déjà eu ce genre de problème que j'ai résolu en supprimant l'utilisateur
(via dans le "dossier" sécurité de cette db) et ensuite en le recréant et en
re-cochant les bonnes options.

Steph.


"ML" news:OIdpspi$
Bonjour,

Je rencontre une difficulté suite au détachement, puis au rattachement
d'une base de données SQLServer 2005.

Le problème rencontré concerne plus particulièrement les paramètres de la
connexion.


Description du scénario :

.Avant le détachement de la base de données, la connexion utilisée a les
propriétés de mappage d'utilisateur :
.Case à cocher activée de mappage de la base de données. Le nom de la base
de données, l'utilisateur et le schéma par défaut sont identiques, et ont
le même nom que celui de la connexion.
.Le nom d'utilisateur figure bien dans la liste des schémas d'appartenance
de l'utilisteur.
.Le membre : db_owner est coché dans la liste d'appartenance au rôle de
base de données.

Après le rattchement de cette base de données, les propriétés de mappage de
l'utilisateur de cette même connexion sont modifiées :
.Case à cocher déactivée de mappage de la base de données. Le nom de la
base de données est présent, mais l'utilisateur et le schéma par défaut ne
sont plus renseignés.

De ce fait, il n'est plus possible d'établir de connexion au SGBD à l'aide
de ce nom de connexion.


Si j'entreprends de modifier ces propriétés en rendant la case à cocher
active, puis en renseignant le nom d'utilisateur et schéma par défaut, une
erreur survient quand je valide la saisie. (utilisateur existant dans la
base de données).


Quelle est la procédure pour rétablir les propriétés de cette connexion ?


Configuration actuelle :
.Serveur 2003.
.Base de sonnées Sqlserver 2005.


D'avance merci pourtout renseignement.

MhL.














d'utilisateur









--

*!* -----------------------------------
EmanuelL
Membre d'AtoutFox
www.atoutfox.org
Fred BROUARD
Le #16550421
les connexions étant stockées au niveau de la base master lorsque vous
détachez et rattachez une base de production sur un autre serveur il n'y
a plus de liens entre les compte de connexion et les utilisateurs qui
eux sont stockées dans la base.

le moyen le plus simple est de scripter tous les comptes de connexion
pour votre base, et ce depuis le serveur source, pour ensuite rejouer le
script sur le serveur cible.

A +

ML a écrit :
Bonjour,

Je rencontre une difficulté suite au détachement, puis au rattachement d'une
base de données SQLServer 2005.

Le problème rencontré concerne plus particulièrement les paramètres de la
connexion.


Description du scénario :

.Avant le détachement de la base de données, la connexion utilisée a les
propriétés de mappage d'utilisateur :
.Case à cocher activée de mappage de la base de données. Le nom de la base
de données, l'utilisateur et le schéma par défaut sont identiques, et ont
le même nom que celui de la connexion.
.Le nom d'utilisateur figure bien dans la liste des schémas d'appartenance
de l'utilisteur.
.Le membre : db_owner est coché dans la liste d'appartenance au rôle de
base de données.

Après le rattchement de cette base de données, les propriétés de mappage de
l'utilisateur de cette même connexion sont modifiées :
.Case à cocher déactivée de mappage de la base de données. Le nom de la
base de données est présent, mais l'utilisateur et le schéma par défaut ne
sont plus renseignés.

De ce fait, il n'est plus possible d'établir de connexion au SGBD à l'aide
de ce nom de connexion.


Si j'entreprends de modifier ces propriétés en rendant la case à cocher
active, puis en renseignant le nom d'utilisateur et schéma par défaut, une
erreur survient quand je valide la saisie. (utilisateur existant dans la
base de données).


Quelle est la procédure pour rétablir les propriétés de cette connexion ?


Configuration actuelle :
.Serveur 2003.
.Base de sonnées Sqlserver 2005.


D'avance merci pourtout renseignement.

MhL.














d'utilisateur








--
Frédéric BROUARD, MVP SQL Server, expert bases de données et langage SQL
Le site sur le langage SQL et les SGBDR : http://sqlpro.developpez.com
Audit, conseil, expertise, formation, modélisation, tuning, optimisation
*********************** http://www.sqlspot.com *************************
Publicité
Poster une réponse
Anonyme