Comment trouver 2 cellules ayant la même valeur

Le
untemios
Dans une BDD gérant un club de danse, je veux calculer la cotisation
d'un couple. Pour cela j'ai besoin d'additionner divers éléments comme
le nombre de cours suivis et les réductions correspondantes. Chaque
adhérent occupe une ligne dans la BDD et les couples ont en plus un
numéro identique.
Dans la colonne B,la colonne des numéros de couples, il y a donc 2
numéros identiques( 2 numéro 1; 2 numéro 2;.2 numéro 31).
Question: Comment récupérer le numéro des 2 lignes de chaque couple?
Merci de m'aider
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
DanielCo
Le #23276431
Bonjour,
Mettons que les numéro des couples soient en colonne A et autre chose
(le nombre de cours suivis par exemple); le total des cours suivis par
le couple sera fourni par la formule :
=SOMMEPROD((A1:A100=2)*B1:B100)
Cordialement.
Daniel


Dans une BDD gérant un club de danse, je veux calculer la cotisation
d'un couple. Pour cela j'ai besoin d'additionner divers éléments comme
le nombre de cours suivis et les réductions correspondantes. Chaque
adhérent occupe une ligne dans la BDD et les couples ont en plus un
numéro identique.
Dans la colonne B,la colonne des numéros de couples, il y a donc 2
numéros identiques( 2 numéro 1; 2 numéro 2;....2 numéro 31).
Question: Comment récupérer le numéro des 2 lignes de chaque couple?
Merci de m'aider
DanielCo
Le #23276471
PS. popur un numéro de couple égal à 2.
Daniel


Bonjour,
Mettons que les numéro des couples soient en colonne A et autre chose (le
nombre de cours suivis par exemple); le total des cours suivis par le couple
sera fourni par la formule :
=SOMMEPROD((A1:A100=2)*B1:B100)
Cordialement.
Daniel


Dans une BDD gérant un club de danse, je veux calculer la cotisation
d'un couple. Pour cela j'ai besoin d'additionner divers éléments comme
le nombre de cours suivis et les réductions correspondantes. Chaque
adhérent occupe une ligne dans la BDD et les couples ont en plus un
numéro identique.
Dans la colonne B,la colonne des numéros de couples, il y a donc 2
numéros identiques( 2 numéro 1; 2 numéro 2;....2 numéro 31).
Question: Comment récupérer le numéro des 2 lignes de chaque couple?
Merci de m'aider
untemios
Le #23276551
On 11 avr, 18:06, DanielCo
PS. popur un numéro de couple égal à 2.
Daniel







> Bonjour,
> Mettons que les numéro des couples soient en colonne A et autre chose (le
> nombre de cours suivis par exemple); le total des cours suivis par le c ouple
> sera fourni par la formule :
> =SOMMEPROD((A1:A100=2)*B1:B100)
> Cordialement.
> Daniel

>> Dans une BDD gérant un club de danse,  je veux calculer la cotisat ion
>> d'un couple. Pour cela j'ai besoin d'additionner divers éléments c omme
>> le nombre de cours suivis et les réductions correspondantes. Chaque
>> adhérent occupe une ligne dans la BDD et les couples ont en plus un
>> numéro identique.
>> Dans la colonne B,la colonne des numéros de couples, il y a donc 2
>> numéros identiques( 2 numéro 1; 2 numéro 2;....2 numéro 31).
>> Question: Comment récupérer le numéro des  2 lignes de chaque couple?
>> Merci de m'aider



j'ai essayé avec =SOMMEPROD((B4:B393=1)*AH4:AH393*AI4:AI393)
Les numeros de couples se trouvent colonne B et leurs cours suivis en
colonneAH pour les danses de salon et AI pour les claquettes.
Pour le couple 1, qui fait 3 danses de salon( donc 6 à eux deux) et 0
claquettes, j'ai pour résultat 0.
Ai-je mal écrit?
DanielCo
Le #23276601
Ta formule est correcte pour les claquettes. Pour les danses de salon,
il faut utiliser :
=SOMMEPROD((B4:B393=1)*AH4:AH393)
Daniel


On 11 avr, 18:06, DanielCo
PS. popur un numéro de couple égal à 2.
Daniel







Bonjour,
Mettons que les numéro des couples soient en colonne A et autre chose (le
nombre de cours suivis par exemple); le total des cours suivis par le
couple sera fourni par la formule :
=SOMMEPROD((A1:A100=2)*B1:B100)
Cordialement.
Daniel



Dans une BDD gérant un club de danse,  je veux calculer la cotisation
d'un couple. Pour cela j'ai besoin d'additionner divers éléments comme
le nombre de cours suivis et les réductions correspondantes. Chaque
adhérent occupe une ligne dans la BDD et les couples ont en plus un
numéro identique.
Dans la colonne B,la colonne des numéros de couples, il y a donc 2
numéros identiques( 2 numéro 1; 2 numéro 2;....2 numéro 31).
Question: Comment récupérer le numéro des  2 lignes de chaque couple?
Merci de m'aider







j'ai essayé avec =SOMMEPROD((B4:B393=1)*AH4:AH393*AI4:AI393)
Les numeros de couples se trouvent colonne B et leurs cours suivis en
colonneAH pour les danses de salon et AI pour les claquettes.
Pour le couple 1, qui fait 3 danses de salon( donc 6 à eux deux) et 0
claquettes, j'ai pour résultat 0.
Ai-je mal écrit?
untemios
Le #23276811
On 11 avr, 18:58, DanielCo
Ta formule est correcte pour les claquettes. Pour les danses de salon,
il faut utiliser :
=SOMMEPROD((B4:B393=1)*AH4:AH393)
Daniel







> On 11 avr, 18:06, DanielCo >> PS. popur un numéro de couple égal à 2.
>> Daniel

>>> Bonjour,
>>> Mettons que les numéro des couples soient en colonne A et autre cho se (le
>>> nombre de cours suivis par exemple); le total des cours suivis par le
>>> couple sera fourni par la formule :
>>> =SOMMEPROD((A1:A100=2)*B1:B100)
>>> Cordialement.
>>> Daniel

>>>> Dans une BDD gérant un club de danse,  je veux calculer la cotis ation
>>>> d'un couple. Pour cela j'ai besoin d'additionner divers éléments comme
>>>> le nombre de cours suivis et les réductions correspondantes. Chaqu e
>>>> adhérent occupe une ligne dans la BDD et les couples ont en plus u n
>>>> numéro identique.
>>>> Dans la colonne B,la colonne des numéros de couples, il y a donc 2
>>>> numéros identiques( 2 numéro 1; 2 numéro 2;....2 numéro 31).
>>>> Question: Comment récupérer le numéro des  2 lignes de chaqu e couple?
>>>> Merci de m'aider

> j'ai essayé avec =SOMMEPROD((B4:B393=1)*AH4:AH393*AI4:AI393)
> Les numeros de couples se trouvent colonne B et leurs cours suivis en
> colonneAH pour les danses de salon et AI pour les claquettes.
> Pour le couple 1, qui fait 3 danses de salon( donc 6 à eux deux) et 0
> claquettes, j'ai pour résultat 0.
> Ai-je mal écrit?



Merci beaucoup.
Je récupère bien la somme des cours suivis.
Demain, j'essaie d'intégrer tout ça dans ma formule pour voir si
j'obtiens le résultat escompté...car là, j'en ai assez!!!
Je te tiens au courant;
Encore merci
untemios
Le #23278651
J'ai essayé ta formule en VBA et je n'y arrive pas;
Je viens de poster mon problème sous le titre" variable dans une
formule index" où je tente d'expliquer mon problème.
Peux-tu y jeter un oeil?

Merci d'avance
Jean luc
Jacquouille
Le #23278691
Bonjour
Je commence tout doucement à ne plus comprendre.
Peux-tu mettre ton fichier (ou partie) expurgé des données confidentielles)
sur CJOINT ?
Peux-tu aussi répondre en HAUT du message? j'use environ 1 mm de chaque
doigt chaque fois que je lis tes interventions. -)



Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"untemios" a écrit dans le message de groupe de discussion :



J'ai essayé ta formule en VBA et je n'y arrive pas;
Je viens de poster mon problème sous le titre" variable dans une
formule index" où je tente d'expliquer mon problème.
Peux-tu y jeter un oeil?

Merci d'avance
Jean luc
Publicité
Poster une réponse
Anonyme