Comparaison de chaînes

Le
cmoi
Bonjour,

Je voudrais savoir si il existe une fonction vba toute prête pour comparer
des
chaînes de caractères sans tenir compte de la casse (majuscule ou minuscule)
ni des accents é=e, à=a, etc.

J'ai besoin de cette fonction sur Excel, mais ce serait mieux si elle
fonctionne sur toutes les applications.

Merci pour vos réponses et bonne fin de semaine.

MP
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #5241061
bonjour Mp,

=EXACT(MINUSCULE(A1);MINUSCULE(B1))

isabelle

Bonjour,

Je voudrais savoir si il existe une fonction vba toute prête pour comparer
des
chaînes de caractères sans tenir compte de la casse (majuscule ou minuscule)
ni des accents é=e, à=a, etc.

J'ai besoin de cette fonction sur Excel, mais ce serait mieux si elle
fonctionne sur toutes les applications.

Merci pour vos réponses et bonne fin de semaine.

MP





JB
Le #5241051
Bonsoir,


Dans un module:

Function sansAccent(chaine)
codeA = "ÉÈÊËÔéèêëàçùôûïî"
codeB = "EEEEOeeeeacuouii"
temp = chaine
For i = 1 To Len(temp)
p = InStr(codeA, Mid(temp, i, 1))
If p > 0 Then Mid(temp, i, 1) = Mid(codeB, p, 1)
Next
sansAccent = temp
End Function

=SI(sansaccent(A1)=sansaccent(B1);"ok")

JB

On 22 fév, 19:41, "cmoi"
Bonjour,

Je voudrais savoir si il existe une fonction vba toute prête pour compar er
des
chaînes de caractères sans tenir compte de la casse (majuscule ou minu scule)
ni des accents é=e, à=a, etc.

J'ai besoin de cette fonction sur Excel, mais ce serait mieux si elle
fonctionne sur toutes les applications.

Merci pour vos réponses et bonne fin de semaine.

MP


isabelle
Le #5240931
bonjour Mp,

pour les accent :

Function SansAccent(cellule As Range)
x = Array("à", "â", "ç", "è", "é", "ê", "ë", "î", "ï", "ô", "ù", "û", "À", "Â", "Ç", "È", "É", "Ê", "Ë", "Î", "Ï", "Ô", "Ù", "Û")
y = Array("a", "a", "c", "e", "e", "e", "e", "i", "i", "o", "u", "u", "A", "A", "C", "E", "E", "E", "E", "I", "I", "O", "U", "U")
SansAccent = [cellule]
For i = 0 To 23
SansAccent = Application.Substitute(SansAccent, x(i), y(i))
Next
End Function


isabelle

Bonjour,

Je voudrais savoir si il existe une fonction vba toute prête pour comparer
des
chaînes de caractères sans tenir compte de la casse (majuscule ou minuscule)
ni des accents é=e, à=a, etc.

J'ai besoin de cette fonction sur Excel, mais ce serait mieux si elle
fonctionne sur toutes les applications.

Merci pour vos réponses et bonne fin de semaine.

MP





cmoi
Le #5240831
Merci à vous deux !
La solution de JB me convient mieux car je ne travaille pas directement sur
des cellules, mais sur des variables et des champs de formulaires.

"cmoi" 47bf1766$0$882$
Bonjour,

Je voudrais savoir si il existe une fonction vba toute prête pour comparer
des
chaînes de caractères sans tenir compte de la casse (majuscule ou
minuscule)
ni des accents é=e, à=a, etc.

J'ai besoin de cette fonction sur Excel, mais ce serait mieux si elle
fonctionne sur toutes les applications.

Merci pour vos réponses et bonne fin de semaine.

MP





Publicité
Poster une réponse
Anonyme