Comparaison de deux cellules dont l'une est alphanumérique

Le
Bidou
Bonjour,

La valeur de la cellules A1 est composée de huit caractères : quatre lettres
et quatre chiffres par exemple abcd9999.
La valeur de la cellule B1 est un numéro de quatre chiffres.Je voudrais
qu'en cellule C1 un message " identique" s'affiche lorsque le numéro situé
dans la cellule B1 correspond aux quatre chiffres de la cellule B1 ( dont la
valeur est alphanumérique) et qu'un message " pas identique" s'affiche
lorsque la condition n'est pas remplie

Pack office 97
ou
Ms Office 2003

Pouvez-vous m'aider en VBA ( de préférence) ou en formule ?
Merci de votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
merguez07
Le #21623731
Tu peux mettre en C1 la formule :
=SI(CNUM(DROITE(A1;4))<>B1;"pas identique"; "identique")

Xavier




Bidou a écrit :
Bonjour,

La valeur de la cellules A1 est composée de huit caractères : quatre lettres
et quatre chiffres par exemple abcd9999.
La valeur de la cellule B1 est un numéro de quatre chiffres.Je voudrais
qu'en cellule C1 un message " identique" s'affiche lorsque le numéro situé
dans la cellule B1 correspond aux quatre chiffres de la cellule B1 ( dont la
valeur est alphanumérique) et qu'un message " pas identique" s'affiche
lorsque la condition n'est pas remplie

Pack office 97
ou
Ms Office 2003

Pouvez-vous m'aider en VBA ( de préférence) ou en formule ?
Merci de votre aide


Caetera
Le #21623721
"Bidou" 4bd3da93$0$27583$
La valeur de la cellules A1 est composée de huit caractères : quatre lettres
et quatre chiffres par exemple abcd9999.
La valeur de la cellule B1 est un numéro de quatre chiffres.Je voudrais qu'en
cellule C1 un message " identique" s'affiche lorsque le numéro situé dans la
cellule B1 correspond aux quatre chiffres de la cellule B1 ( dont la valeur
est alphanumérique) et qu'un message " pas identique" s'affiche lorsque la
condition n'est pas remplie



******************
=SI(DROITE(A1;4)*1±;"Pareil";"pas pareil")

Etc
Charabeuh
Le #21623821
Bjr,

Essayez la formule:
=SI(CNUM(DROITE(A1;4))=CNUM((B1));"Identique";"Différent")

ou la fonction VBA:
Public Function Ident(xA As Range, xB As Range) As String
Ident = "Différent"
If CInt(Right(xA.Value, 4)) = CInt((xB.Value)) Then Ident = "Identique"
End Function

#VALEUR! est retourné si au moins un argument de la formule ou fonction
n'est pas numérique.


"Bidou" a écrit :

Bonjour,

La valeur de la cellules A1 est composée de huit caractères : quatre lettres
et quatre chiffres par exemple abcd9999.
La valeur de la cellule B1 est un numéro de quatre chiffres.Je voudrais
qu'en cellule C1 un message " identique" s'affiche lorsque le numéro situé
dans la cellule B1 correspond aux quatre chiffres de la cellule B1 ( dont la
valeur est alphanumérique) et qu'un message " pas identique" s'affiche
lorsque la condition n'est pas remplie

Pack office 97
ou
Ms Office 2003

Pouvez-vous m'aider en VBA ( de préférence) ou en formule ?
Merci de votre aide


.

Bidou
Le #21625051
Merci à tous les trois .Il ne me reste plus qu'à les essayer !
Fastoche Excel avec vous !

J'aime bien les pseudo dans ce forum "charabeuh" , "merguez" ...



"Charabeuh" news:
Bjr,

Essayez la formule:
=SI(CNUM(DROITE(A1;4))=CNUM((B1));"Identique";"Différent")

ou la fonction VBA:
Public Function Ident(xA As Range, xB As Range) As String
Ident = "Différent"
If CInt(Right(xA.Value, 4)) = CInt((xB.Value)) Then Ident = "Identique"
End Function

#VALEUR! est retourné si au moins un argument de la formule ou fonction
n'est pas numérique.


"Bidou" a écrit :

Bonjour,

La valeur de la cellules A1 est composée de huit caractères : quatre
lettres
et quatre chiffres par exemple abcd9999.
La valeur de la cellule B1 est un numéro de quatre chiffres.Je voudrais
qu'en cellule C1 un message " identique" s'affiche lorsque le numéro
situé
dans la cellule B1 correspond aux quatre chiffres de la cellule B1 ( dont
la
valeur est alphanumérique) et qu'un message " pas identique" s'affiche
lorsque la condition n'est pas remplie

Pack office 97
ou
Ms Office 2003

Pouvez-vous m'aider en VBA ( de préférence) ou en formule ?
Merci de votre aide


.

Publicité
Poster une réponse
Anonyme