Comparaison

Le
Difoul56
Bonjour,

Dans une liste de noms (30.000) je voudrait connaitre le nombre de noms
identique et ou similaire.
Par exemple:

Michel dupond
dupond michel
dupond m.
m. dupond
M. m.dupont


= 5 dupond


Je ne peux pas utiliser les formiles tel que "Left" .. ne connaissant pas la
position du nom dans la cahien de caractères ni même l'orthographe
identique.

Merci pour votre aide

JP
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #18480351
Bonjour.
=NB.SI(A1:A5;"*dupond*")
Cordialement.
Daniel

Bonjour,

Dans une liste de noms (30.000) je voudrait connaitre le nombre de noms
identique et ou similaire.
Par exemple:

Michel dupond
dupond michel
dupond m.
m. dupond
M. m.dupont


= 5 dupond


Je ne peux pas utiliser les formiles tel que "Left" .. ne connaissant pas la
position du nom dans la cahien de caractères ni même l'orthographe identique.

Merci pour votre aide

JP


michdenis
Le #18481461
Voici une fonction personnalisé que tu places
dans un module standard :

Dans la cellule que tu veux obtenir le résultat
tu entres :
ÞCompte_Occurence(A1:A25;"dupont";"dupond")

Si tu voulais décompter seulement un mot, tu pourrais
aussi le faire :
ÞCompte_Occurence(A1:A25;"Expression_Cherchée")

'----------------------------------------
Function DeCompte_Occurence(Plage As Range, _
Mot1 As String, Optional Mot2 As String)

Dim Nb As Integer, Compte As Integer
Dim Texte As String, A As Integer
Dim C As Range
For Each C In Plage
Texte = C.Value
If InStr(1, Texte, Mot1, vbTextCompare) <> 0 Or _
InStr(1, Texte, Mot2, vbTextCompare) <> 0 Then
t = Split(Texte, " "): Nb = UBound(Split(Texte, " "))
For A = 0 To Nb
If LCase(Trim(t(A))) = "dupont" Or _
LCase(Trim(t(A))) = "dupond" Then
Compte = Compte + 1
End If
Next
End If
Next
DeCompte_Occurence = Compte
End Function
'----------------------------------------



"Difoul56" #
Bonjour,

Dans une liste de noms (30.000) je voudrait connaitre le nombre de noms
identique et ou similaire.
Par exemple:

Michel dupond
dupond michel
dupond m.
m. dupond
M. m.dupont


= 5 dupond


Je ne peux pas utiliser les formiles tel que "Left" .. ne connaissant pas la
position du nom dans la cahien de caractères ni même l'orthographe
identique.

Merci pour votre aide

JP
Daniel.C
Le #18481801
Oups, je ne sais pas pourquoi, avec MesNews, les "*" sont passés à la
trappe ?
Lire "*dupond*" au lieu de "dupond".
Daniel

Bonjour.
=NB.SI(A1:A5;"*dupond*")
Cordialement.
Daniel

Bonjour,

Dans une liste de noms (30.000) je voudrait connaitre le nombre de noms
identique et ou similaire.
Par exemple:

Michel dupond
dupond michel
dupond m.
m. dupond
M. m.dupont


= 5 dupond


Je ne peux pas utiliser les formiles tel que "Left" .. ne connaissant pas
la position du nom dans la cahien de caractères ni même l'orthographe
identique.

Merci pour votre aide

JP




Daniel.C
Le #18481971
Au fou !
Remplacer <<astérisque>> par le caractère astérisque.
=NB.SI(A1:A5;"<<astérisque>>dupond<<astérisque>>")

Oups, je ne sais pas pourquoi, avec MesNews, les "*" sont passés à la trappe
?
Lire "*dupond*" au lieu de "dupond".
Daniel

Bonjour.
=NB.SI(A1:A5;"*dupond*")
Cordialement.
Daniel

Bonjour,

Dans une liste de noms (30.000) je voudrait connaitre le nombre de noms
identique et ou similaire.
Par exemple:

Michel dupond
dupond michel
dupond m.
m. dupond
M. m.dupont


= 5 dupond


Je ne peux pas utiliser les formiles tel que "Left" .. ne connaissant pas
la position du nom dans la cahien de caractères ni même l'orthographe
identique.

Merci pour votre aide

JP






michdenis
Le #18481951
=NB.SI(A1:A5;"*dupond*")
***Cela décompte aussi les "dupondeau", ou les "dupondard"

Je croyais que le demandeur voulait simplement les
"Dupont" ou "Dupond" .. je peux errer, laissons au
demandeur le soin de préciser sa pensée si besoin il y a.
Difoul56
Le #18482571
Merci pour vos réponses

Dans ma liste j'ai un nombre important d'enregistrements.

Je dois compter et regrouper les enregistrements qiu sont identiques et
similaires.

Dans mon exemple je dois regrouper et compter les "dupond" parmi l'ensemble
des autres noms mais également faire la même avec l'ensemble des noms, d'où
la difficulté.

JP


"Daniel.C"
Oups, je ne sais pas pourquoi, avec MesNews, les "*" sont passés à la
trappe ?
Lire "*dupond*" au lieu de "dupond".
Daniel

Bonjour.
=NB.SI(A1:A5;"*dupond*")
Cordialement.
Daniel

Bonjour,

Dans une liste de noms (30.000) je voudrait connaitre le nombre de noms
identique et ou similaire.
Par exemple:

Michel dupond
dupond michel
dupond m.
m. dupond
M. m.dupont


= 5 dupond


Je ne peux pas utiliser les formiles tel que "Left" .. ne connaissant
pas la position du nom dans la cahien de caractères ni même
l'orthographe identique.

Merci pour votre aide

JP








Daniel.C
Le #18482531
OK, mais comment savoir si le nom est dupond ou michel ?
Daniel

Merci pour vos réponses

Dans ma liste j'ai un nombre important d'enregistrements.

Je dois compter et regrouper les enregistrements qiu sont identiques et
similaires.

Dans mon exemple je dois regrouper et compter les "dupond" parmi l'ensemble
des autres noms mais également faire la même avec l'ensemble des noms, d'où
la difficulté.

JP


"Daniel.C"
Oups, je ne sais pas pourquoi, avec MesNews, les "*" sont passés à la
trappe ?
Lire "*dupond*" au lieu de "dupond".
Daniel

Bonjour.
=NB.SI(A1:A5;"*dupond*")
Cordialement.
Daniel

Bonjour,

Dans une liste de noms (30.000) je voudrait connaitre le nombre de noms
identique et ou similaire.
Par exemple:

Michel dupond
dupond michel
dupond m.
m. dupond
M. m.dupont


= 5 dupond


Je ne peux pas utiliser les formiles tel que "Left" .. ne connaissant pas
la position du nom dans la cahien de caractères ni même l'orthographe
identique.

Merci pour votre aide

JP










Fredo P.
Le #18484031
Pas de panique , chez nous tout est correct
"Daniel.C" news:
Au fou !
Remplacer <<astérisque>> par le caractère astérisque.
=NB.SI(A1:A5;"<<astérisque>>dupond<<astérisque>>")

> Oups, je ne sais pas pourquoi, avec MesNews, les "*" sont passés à la


trappe
> ?
> Lire "*dupond*" au lieu de "dupond".
> Daniel
>
>> Bonjour.
>> =NB.SI(A1:A5;"*dupond*")
>> Cordialement.
>> Daniel
>>
>>> Bonjour,
>>>
>>> Dans une liste de noms (30.000) je voudrait connaitre le nombre de


noms
>>> identique et ou similaire.
>>> Par exemple:
>>>
>>> Michel dupond
>>> dupond michel
>>> dupond m.
>>> m. dupond
>>> M. m.dupont
>>>
>>>
>>> = 5 dupond
>>>
>>>
>>> Je ne peux pas utiliser les formiles tel que "Left" .. ne connaissant


pas
>>> la position du nom dans la cahien de caractères ni même l'orthographe
>>> identique.
>>>
>>> Merci pour votre aide
>>>
>>> JP




Publicité
Poster une réponse
Anonyme