comparer le contenu de lignes dans une feuille

Le
plex
Bonjour a tous,
Dans une feuille excel j'ai 2 tableaux avec le plus souvent un contenu
identique mais organisé différemment, je cherche a vérifier si les 2
tableaux ont bien le même contenu et que je n'ai rien oublié.
Aujourd'hui je compare chaque ligne a la mano.

Si vous avez une idée ce serait sympa

Bonne soirée

--
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
LE TROLL
Le #18534141
Bonjour,

C'est simple :

if a <> b then a not b + (0²)

--
Cordialement ;o)
-
Logiciels, romans, contacts : http://irolog.free.fr
_______________________
.
.


"plex" news:ueW%
Bonjour a tous,
Dans une feuille excel j'ai 2 tableaux avec le plus souvent un contenu
identique mais organisé différemment, je cherche a vérifier si les 2
tableaux ont bien le même contenu et que je n'ai rien oublié.
Aujourd'hui je compare chaque ligne a la mano.

Si vous avez une idée ce serait sympa

Bonne soirée

--




Merguez07
Le #18535551
un petit ci-joint serait le bienvenu pour avoir une idée de la
désorganisation

Xavier

"plex" : ueW#
Bonjour a tous,
Dans une feuille excel j'ai 2 tableaux avec le plus souvent un contenu
identique mais organisé différemment, je cherche a vérifier si les 2
tableaux ont bien le même contenu et que je n'ai rien oublié.
Aujourd'hui je compare chaque ligne a la mano.

Si vous avez une idée ce serait sympa

Bonne soirée

--




plex
Le #18535761
En faisant simple et sur 50 lignes dans la colonne a, je mets des mots; il
peut y avoir des cellules vides.
dans la colonne b je mets aussi des mots;
si dans la colonne b il y a un mot identique à la colonne a et pas forcément
à la même ligne , il faut changer de couleur les 2 mots trouvés ou
l'inverse, tout ce qui n'est pas retrouvé dans la colonne a change de
couleur.
l'idéal est que les couleurs soient différentes car si il y a 10 identiques,
j'aurai du mal a retrouver.
j'ai bien bricolé avec les formats conditionnels mais je n'avance pas.

Merci

Bonne soirée


"Merguez07" 498348c0$0$29457$
un petit ci-joint serait le bienvenu pour avoir une idée de la
désorganisation

Xavier

"plex" discussion : ueW#
Bonjour a tous,
Dans une feuille excel j'ai 2 tableaux avec le plus souvent un contenu
identique mais organisé différemment, je cherche a vérifier si les 2
tableaux ont bien le même contenu et que je n'ai rien oublié.
Aujourd'hui je compare chaque ligne a la mano.

Si vous avez une idée ce serait sympa

Bonne soirée

--






Merguez07
Le #18536191
pour mettre en couleur les doublons c'est simple
tu sélectionnes toute ta colonne A
dans la MFC tu met la formule =RECHERCHEV($A1;B:B;1;0)=$A1
tu donnes le format qui te convient

tu sélectionnes toute ta colonne B
dans la MFC tu met la formule =RECHERCHEV($B1;A:A;1;0)=$B1
tu donnes le format qui te convient

et voilà les doublons sont repérés

Par contre si tu veux que chaque doublon ait une couleur spécifique je pense
que ce sera difficile avec des MFC. Va falloir passer au VBA

Xavier



"plex" : #
En faisant simple et sur 50 lignes dans la colonne a, je mets des mots; il
peut y avoir des cellules vides.
dans la colonne b je mets aussi des mots;
si dans la colonne b il y a un mot identique à la colonne a et pas
forcément à la même ligne , il faut changer de couleur les 2 mots trouvés
ou l'inverse, tout ce qui n'est pas retrouvé dans la colonne a change de
couleur.
l'idéal est que les couleurs soient différentes car si il y a 10
identiques, j'aurai du mal a retrouver.
j'ai bien bricolé avec les formats conditionnels mais je n'avance pas.

Merci

Bonne soirée


"Merguez07" 498348c0$0$29457$
un petit ci-joint serait le bienvenu pour avoir une idée de la
désorganisation

Xavier

"plex" discussion : ueW#
Bonjour a tous,
Dans une feuille excel j'ai 2 tableaux avec le plus souvent un contenu
identique mais organisé différemment, je cherche a vérifier si les 2
tableaux ont bien le même contenu et que je n'ai rien oublié.
Aujourd'hui je compare chaque ligne a la mano.

Si vous avez une idée ce serait sympa

Bonne soirée

--










plex
Le #18543371
Oui je me doute que ce n'est pas simple, OK pour le VBA, encore faut'il
savoir le faire.
Je bricole un peu mais pas a ce niveau.

"Merguez07" 498359de$0$27521$
pour mettre en couleur les doublons c'est simple
tu sélectionnes toute ta colonne A
dans la MFC tu met la formule =RECHERCHEV($A1;B:B;1;0)=$A1
tu donnes le format qui te convient

tu sélectionnes toute ta colonne B
dans la MFC tu met la formule =RECHERCHEV($B1;A:A;1;0)=$B1
tu donnes le format qui te convient

et voilà les doublons sont repérés

Par contre si tu veux que chaque doublon ait une couleur spécifique je
pense que ce sera difficile avec des MFC. Va falloir passer au VBA

Xavier



"plex" discussion : #
En faisant simple et sur 50 lignes dans la colonne a, je mets des mots;
il peut y avoir des cellules vides.
dans la colonne b je mets aussi des mots;
si dans la colonne b il y a un mot identique à la colonne a et pas
forcément à la même ligne , il faut changer de couleur les 2 mots trouvés
ou l'inverse, tout ce qui n'est pas retrouvé dans la colonne a change de
couleur.
l'idéal est que les couleurs soient différentes car si il y a 10
identiques, j'aurai du mal a retrouver.
j'ai bien bricolé avec les formats conditionnels mais je n'avance pas.

Merci

Bonne soirée


"Merguez07" 498348c0$0$29457$
un petit ci-joint serait le bienvenu pour avoir une idée de la
désorganisation

Xavier

"plex" discussion : ueW#
Bonjour a tous,
Dans une feuille excel j'ai 2 tableaux avec le plus souvent un contenu
identique mais organisé différemment, je cherche a vérifier si les 2
tableaux ont bien le même contenu et que je n'ai rien oublié.
Aujourd'hui je compare chaque ligne a la mano.

Si vous avez une idée ce serait sympa

Bonne soirée

--












Publicité
Poster une réponse
Anonyme