comparer une date

Le
Philippe MERY
Bonjour

je n'arrive pas à creer une fonction :-((

J'ai une date par la fonction "aujourd'hui" dans B2
je désire avoir dans A3 une formule qui compare A5 à B2 et qui m'affiche
"appel" si la date de B2 est atteinte et reste vide si A5 est vide ou < à B2
je tape
=SI(ET(A5<$B$2;A5="";A5<>"");"appel";"")
mais cela ne fonctionne pas .

Cela coince ou?
merci.

--
Cordialement.
Philippe MERY
**pour m'ecrire perso**
mery-ph -serveur- ifrance.com
www.freymille.com
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #5064971
Bonsoir,
Si j'ai compris :
=si(ou(a5<$b$2;a5="");"";"appel")
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"Philippe MERY" news:47470f32$0$27379$
Bonjour

je n'arrive pas à creer une fonction :-((

J'ai une date par la fonction "aujourd'hui" dans B2
je désire avoir dans A3 une formule qui compare A5 à B2 et qui m'affiche
"appel" si la date de B2 est atteinte et reste vide si A5 est vide ou < à
B2
je tape
=SI(ET(A5<$B$2;A5="";A5<>"");"appel";"")
mais cela ne fonctionne pas ....

Cela coince ou?
merci.

--
Cordialement.
Philippe MERY
**pour m'ecrire perso**
mery-ph -serveur- ifrance.com
www.freymille.com



Jean-Marie RAMAUGÉ
Le #5064761
Bonsoir Philippe,

Oui, ça coince à plusieurs endroits :

1) Dans ta formule
=SI(ET(A5<$B$2;A5="";A5<>"");"appel";"")
et d'après ce que tu cherches à faire, A5 doit être >= et non < à B2 (1er
blocage car là, tu obtiens l'inverse de ce que tu veux).
2) 2 éléments de ta conditions ne peuvent jamais être satisfaits (A5="") ET
(A5<>""). Ou A5 est à blanc, ou A5 en renseigné par une date. Il ne peut pas
répondre aux 2 conditions à la fois.

Pour qu'elle fonctionne correctement, il faut donc inverser ton test sur la
première condition et supprimer le test de la seconde condition.
On aurait donc :
=SI(ET(A7>=$B$2;A7<>"");"appel";"").
qui revient à la solution que donne Philippe R. avec "OU"
=SI(OU(A5<$B$2;A5="");"";"appel").

Il faut toujours être attentif avec la condition ET lorsqu'elle teste une
même cellule, en l'occurence "A5" dans le cas présent.

Dans tous les cas, les 2 solutions (avec ET ou avec OU) donnent le même
résultat.

--
JM



Bonjour

je n'arrive pas à creer une fonction :-((

J'ai une date par la fonction "aujourd'hui" dans B2
je désire avoir dans A3 une formule qui compare A5 à B2 et qui m'affiche
"appel" si la date de B2 est atteinte et reste vide si A5 est vide ou < à B2
je tape
=SI(ET(A5<$B$2;A5="";A5<>"");"appel";"")
mais cela ne fonctionne pas ....

Cela coince ou?
merci.

--
Cordialement.
Philippe MERY
**pour m'ecrire perso**
mery-ph -serveur- ifrance.com
www.freymille.com





Philippe.R
Le #5064751
Bonsoir,
On notera le léger mais réel avantage du OU() dans ce cas, qui fait gagner 2
caractères : "=" et ">"
;o)))
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"Jean-Marie RAMAUGÉ" news:
Bonsoir Philippe,

Oui, ça coince à plusieurs endroits :

1) Dans ta formule
=SI(ET(A5<$B$2;A5="";A5<>"");"appel";"")
et d'après ce que tu cherches à faire, A5 doit être >= et non < à B2 (1er
blocage car là, tu obtiens l'inverse de ce que tu veux).
2) 2 éléments de ta conditions ne peuvent jamais être satisfaits (A5="")
ET
(A5<>""). Ou A5 est à blanc, ou A5 en renseigné par une date. Il ne peut
pas
répondre aux 2 conditions à la fois.

Pour qu'elle fonctionne correctement, il faut donc inverser ton test sur
la
première condition et supprimer le test de la seconde condition.
On aurait donc :
=SI(ET(A7>=$B$2;A7<>"");"appel";"").
qui revient à la solution que donne Philippe R. avec "OU"
=SI(OU(A5<$B$2;A5="");"";"appel").

Il faut toujours être attentif avec la condition ET lorsqu'elle teste une
même cellule, en l'occurence "A5" dans le cas présent.

Dans tous les cas, les 2 solutions (avec ET ou avec OU) donnent le même
résultat.

--
JM



Bonjour

je n'arrive pas à creer une fonction :-((

J'ai une date par la fonction "aujourd'hui" dans B2
je désire avoir dans A3 une formule qui compare A5 à B2 et qui m'affiche
"appel" si la date de B2 est atteinte et reste vide si A5 est vide ou < à
B2
je tape
=SI(ET(A5<$B$2;A5="";A5<>"");"appel";"")
mais cela ne fonctionne pas ....

Cela coince ou?
merci.

--
Cordialement.
Philippe MERY
**pour m'ecrire perso**
mery-ph -serveur- ifrance.com
www.freymille.com







Philippe MERY
Le #5064541
"Philippe.R"
Bonsoir,
Si j'ai compris :
=si(ou(a5<$b$2;a5="");"";"appel")


merci c'est cela
sauf > au lieu de <

@+

Philippe MERY
Publicité
Poster une réponse
Anonyme