Comparer deux dates

Le
Denys
Bonjour,

Je cherche à formuler ce qui suit:

en B1 il y a 2011/01/01 (ce pourrait être 2011/01/18 ou autre)

en B8, il y a la date qui suit celle en B1, soit 2011/01/02 en B9 2011/01/0=
3 etc..pour l'équivalent de cinq ans, soit environ 1827 lignes.

En E8 j veux avoir le nombre de jours correspondant au mois inscrit en B8, =
soit
=DAY(DATE(YEAR(B8),MONTH(B8)+1,0)), ce qui me donne 31.

Cependant, pour le premier mois je dois avoir le nombre de jours moins 1, s=
oit 30 dans ce cas-ci; donc, si le mois inscrit en B8 est le même que cel=
ui en B1, alors =DAY(DATE(YEAR(B8),MONTH(B8)+1,0))-1, sinon =DAY(DATE(Y=
EAR(B8),MONTH(B8)+1,0))

Mais comme cela peut s'étaler sur 5 ans, je dois aussi écrire, si l'ann=
ée et le mois en B8 est la même qu'en B1 alors la formule moins 1 jour,=
sinon, la formule.

Pourriez-vous éclairer ma lanterne là-dessus ?

Merci pour votre temps

Denys
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichD
Le #25738342
Bonjour,

Quelque chose comme :

=SI(ET(ANNEE(B1)=ANNEE(B8);MOIS(B8=MOIS(B8)));JOUR(DATE(ANNEE(B8);MOIS(B8)+1;0))-1;JOUR(DATE(ANNEE(B8);MOIS(B8)


MichD
---------------------------------------------------------------
Denys
Le #25738482
Bonjour Denis,

Merci beaucoup, ça me sauve beaucoup de temps !!!!

Bonne fin de journée

Denys
Publicité
Poster une réponse
Anonyme