Comparer deux dates pour afficher les RETARDS

Le
Cedber
Bonjour
J'ai un fichier Excel contenant des dates dans deux colonnes.
Une date d'exécution prévue (Colonne G) et une date de fin (colonne H)
Je souhaite comparer les dates et
Afficher Ok si la colonne H est supérieure ou égale à la colonne G ou
Afficher EN RETARD dans le cas contraire.
Avant il faut tester
sachant que la colonne H est vide dans le cas où la colonne L est différente
de EXE ou ABA.
Avec la formule
=SI(DATEDIF(H25;G25;"d");"OK";"retard") ça marche pas comme je voudrais.
En cas de retard ça affiche #NOMBRE

Merci beaucoup à celui ou celle qui m'aidera.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacquouille
Le #4481381
Bonjour
Si j'ai bien compris:
=si(G1<H1;"EN RETARD";"OK")

--
Bien amicalmement,
Vivement conseillés:
http://www.excelabo.net
http://jacxl.free.fr/mpfe/trombino.html
http://dj.joss.free.fr/netiquet.htm
http://frederic.sigonneau.free.fr/

Jacquouille.

"Cedber"
Bonjour
J'ai un fichier Excel contenant des dates dans deux colonnes.
Une date d'exécution prévue (Colonne G) et une date de fin (colonne H)
Je souhaite comparer les dates et
Afficher Ok si la colonne H est supérieure ou égale à la colonne G ou
Afficher EN RETARD dans le cas contraire.
Avant il faut tester
sachant que la colonne H est vide dans le cas où la colonne L est
différente
de EXE ou ABA.
Avec la formule
=SI(DATEDIF(H25;G25;"d");"OK";"retard") ça marche pas comme je voudrais.
En cas de retard ça affiche #NOMBRE

Merci beaucoup à celui ou celle qui m'aidera.









AV
Le #4481371
=SI(H1="";"";SI(H1-G1>=0;"ok";"retard"))

AV
Cedber
Le #4481321
Merci beaucoup, votre formule m'a beaucoup aidée.
Je l'ai un peu modifiée car je ne vous avais certainement pas tout dit.
=SI(I2= "EXE";SI(H2="";"";SI(H2-G2<=0;"ok";"retard"));"non traitée").
Ca marche comme ça : Si I2 = EXE, alors on controle que la demande a bien
été traitée dans les temps (OK ou retard), sinon on affiche "non traitée".

Vraiment, merci beaucoup pour la rapidité de la réponse.


=SI(H1="";"";SI(H1-G1>=0;"ok";"retard"))

AV





Publicité
Poster une réponse
Anonyme