Compilation noyau...

Le
Yann Cohen
Bonjour,

Pour enfin passer sur un noyau au dela du 2.6.18 et avoir les pilotes
proprios de nvidia, je me suis décidé à compiler mon noyau.

La source de la doc utilisée est
http://www.debian.org/doc/manuals/reference/ch-kernel.fr.html
§ 7.1.1

J'ai sans pb les sources.

Machine origine : debian sid, Linux ian 2.6.18-4-k7 #1 SMP Wed May 9
23:42:01 UTC 2007 i686 GNU/Linux

1er accros :
Lorsque je cherche à installer via apt-get modutils (comme conseillé)
j'ai une ribambelle de paquet à supprimer dont toutes les images du
noyau !
<--
ian:/home/yann# apt-get install modutils
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances
Lecture des informations d'état Fait
Les paquets suivants ont été installés automatiquement et ne sont plu=
s
nécessaires :
cdrecord libmpeg3-1
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Paquets suggérés :
ksymoops
Les paquets suivants seront ENLEVÉS :
bluetooth bluez-utils gspca-modules-2.6.18-4-k7 initramfs-tools
libmultisync-plugin-irmc-bluetooth linux-image-2.6-k7
linux-image-2.6.18-3-k7 linux-image-2.6.18-4-k7
linux-image-2.6.22-1-k7 mindi module-init-tools mondo
pwc-modules-2.6.18-2-k7
Les NOUVEAUX paquets suivants seront installés :
modutils
0 mis à jour, 1 nouvellement installés, 13 à enlever et 5 non mis à
jour.
Il est nécessaire de prendre 0o/242ko dans les archives.
Après dépaquetage, 157Mo d'espace disque seront libérés.
Souhaitez-vous continuer [O/n] ? n
Annulation.
>

Comme je suis prudent, je me suis passé de modutils

Mais échec de compilation sur des modules (pwc de mémoire et quelques
autres) qui demandent un fichier d'include de type "linux/config.h" (là
aussi de mémoire car sortie disparue)

Je constate que j'ai bien un paquet, que j'ai installé et que je tourne
dessus pour finir l'écriture de ce mail.
uname
Linux ian 2.6.22-yco #1 SMP PREEMPT Sun Aug 19 13:21:38 CEST 2007 i686
GNU/Linux


Il me reste encore une question comme :
- J'ai un processeur amd quelles options je dois mettre pour la création
d'un noyau dédié (j'ai sélectionné le processeur dans make menuconf=
ig) ?

Merci et Bon dimanche
(ici il pleut alors y a du temps pour compiler ;-))
Yann.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sylvain Sauvage
Le #9766931
Yann Cohen, dimanche 19 août 2007, 16:12:36 CEST

Bonjour,



’jour,

Pour enfin passer sur un noyau au dela du 2.6.18 et avoir les pilotes
proprios de nvidia, je me suis décidé à compiler mon noyau.

La source de la doc utilisée est
http://www.debian.org/doc/manuals/reference/ch-kernel.fr.html
§ 7.1.1

J'ai sans pb les sources.

Machine origine : debian sid, Linux ian 2.6.18-4-k7 #1 SMP Wed May 9
23:42:01 UTC 2007 i686 GNU/Linux

1er accros :
Lorsque je cherche à installer via apt-get modutils (comme conseill é)
j'ai une ribambelle de paquet à supprimer dont toutes les images du
noyau !



Normal, modutils ne sert qu’aux noyaux 2.4. Les 2.6 utilisent
module-init-tools.
La doc ne parle d’ailleurs que du noyau 2.4 (faudrait la mettre
à jour...).

<--------------
ian:/home/yann# apt-get install modutils
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus
nécessaires :
cdrecord libmpeg3-1
Veuillez utiliser « apt-get autoremove » pour les supprimer.
Paquets suggérés :
ksymoops
Les paquets suivants seront ENLEVÉS :
bluetooth bluez-utils gspca-modules-2.6.18-4-k7 initramfs-tools
libmultisync-plugin-irmc-bluetooth linux-image-2.6-k7
linux-image-2.6.18-3-k7 linux-image-2.6.18-4-k7
linux-image-2.6.22-1-k7 mindi module-init-tools mondo
pwc-modules-2.6.18-2-k7
Les NOUVEAUX paquets suivants seront installés :
modutils
0 mis à jour, 1 nouvellement installés, 13 à enlever et 5 non mis à
jour.
Il est nécessaire de prendre 0o/242ko dans les archives.
Après dépaquetage, 157Mo d'espace disque seront libérà ©s.
Souhaitez-vous continuer [O/n] ? n
Annulation.
--------------->

Comme je suis prudent, je me suis passé de modutils...



Bien.

Mais échec de compilation sur des modules (pwc de mémoire et qu elques
autres) qui demandent un fichier d'include de type "linux/config.h" (là  
aussi de mémoire car sortie disparue)



Sans sortie, ce n’est pas évident...
Un conseil, pour les modules externes (c.-à-d. dont les sources
ne sont pas dans le linux-source-*), il vaut mieux les compiler
lorsque l’on a démarré sur le nouveau noyau (notamment pour les
nvidia).

Je constate que j'ai bien un paquet, que j'ai installé et que je tou rne
dessus pour finir l'écriture de ce mail.
uname...
Linux ian 2.6.22-yco #1 SMP PREEMPT Sun Aug 19 13:21:38 CEST 2007 i686
GNU/Linux


Il me reste encore une question comme :
- J'ai un processeur amd quelles options je dois mettre pour la créa tion
d'un noyau dédié (j'ai sélectionné le processeur dans make menuconfig) ?



make menuconfig utilise comme valeurs par défaut celle du noyau
en cours. Donc si tu as utilisé un noyau debian pour amd, les
options devraient être les bonnes (c.-à-d. que presque tout est
découvert automatiquement). (Il suffit de choisir -k7.)

Merci et Bon dimanche...
(ici il pleut alors y a du temps pour compiler ;-))



On n’est plus dimanche mais il doit bien pleuvoir quelque part.

--
Sylvain Sauvage
Pascal Hambourg
Le #9766881
Salut,

Sylvain Sauvage a écrit :
Yann Cohen, dimanche 19 août 2007, 16:12:36 CEST

Machine origine : debian sid, Linux ian 2.6.18-4-k7 #1 SMP Wed May 9
23:42:01 UTC 2007 i686 GNU/Linux

1er accros :
Lorsque je cherche à installer via apt-get modutils (comme conseillé)
j'ai une ribambelle de paquet à supprimer dont toutes les images du
noyau !



Normal, modutils ne sert qu'aux noyaux 2.4. Les 2.6 utilisent
module-init-tools.



Ce n'est pas une raison pour entraîner la suppression tous ces paquets.
Chez moi - en sarge - modutils, module-init-tools, les noyaux 2.4 et 2.6
cohabitent pacifiquement. Il doit y avoir un problème de dépendances
dans sid...


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sylvain Sauvage
Le #9766871
Pascal Hambourg, lundi 20 août 2007, 20:28:00 CEST

Salut,

Sylvain Sauvage a écrit :
> Yann Cohen, dimanche 19 août 2007, 16:12:36 CEST
>>
>>Machine origine : debian sid, Linux ian 2.6.18-4-k7 #1 SMP Wed May 9
>>23:42:01 UTC 2007 i686 GNU/Linux
>>
>>1er accros :
>>Lorsque je cherche à installer via apt-get modutils (comme conseil lé)
>>j'ai une ribambelle de paquet à supprimer dont toutes les images du
>>noyau !
>
> Normal, modutils ne sert qu'aux noyaux 2.4. Les 2.6 utilisent
> module-init-tools.

Ce n'est pas une raison pour entraîner la suppression tous ces paque ts.
Chez moi - en sarge - modutils, module-init-tools, les noyaux 2.4 et 2.6
cohabitent pacifiquement. Il doit y avoir un problème de dépend ances
dans sid...



Oui, s/Normal/C’est pas grave/.
En fait :
— installer modutils ne fait rien enlever (seulement rétrograd er
module-init-tools vers la version stable) ;
— il n’y a plus de noyau 2.4 en Sid (d’où un module-init-tools
incompatible).

Il doit donc plutôt y avoir un problème de dépendances chez
Yann :o).

--
Sylvain Sauvage
Publicité
Poster une réponse
Anonyme