compiler gvim

Le
eric
bonjour

j ai un eeepc et un autre portable pour le travail avec une mandriva

j'ai le meme probleme
j'ai recupere le code de gvim 7.1, je compile et la il me reponds : pas
de ncurses et pas de GUI detecte

or j ai gtk2, j'ai rajoue gtk1.4 et gtk 1.4 dev

et toujours rien

j ai recupere un vim gtk par apt_get et il marche super bien, alors
pourquoi moi j'arrive pas a le générer ???

merci a vous !

@+
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
oLaFKeWL
Le #1916622
bonjour

j ai un eeepc et un autre portable pour le travail avec une mandriva

j'ai le meme probleme
j'ai recupere le code de gvim 7.1, je compile et la il me reponds : pas
de ncurses et pas de GUI detecte

or j ai gtk2, j'ai rajoue gtk1.4 et gtk 1.4 dev

et toujours rien

j ai recupere un vim gtk par apt_get et il marche super bien, alors
pourquoi moi j'arrive pas a le générer ???

merci a vous !

@+


Pour ncurses, il te faut probablement le package libncurses5-dev, la
meme pour GTK.
Tu peux coller le msg d'erreur complet lors du ./configure ?

Mais simplement, pourquoi t'obstiner à compiler si c'est disponible en
package ?

Thierry B.
Le #1916619
--{ eric a plopé ceci: }--

j'ai recupere le code de gvim 7.1, je compile et la il me reponds : pas
de ncurses et pas de GUI detecte

or j ai gtk2, j'ai rajoue gtk1.4 et gtk 1.4 dev

Et ncurses ?


et toujours rien

"Toujours rien" n'étant pas un message d'erreur exploitable,

tu es invité à repasser en deuxième semaine.


--
Il y a des bégonias dans la cheminée de Marcel.
Je répète, il y a des bégonias dans la cheminée de Marcel.
--{ fr.misc.divers }--

eric
Le #1916617
bonjour

j ai un eeepc et un autre portable pour le travail avec une mandriva

j'ai le meme probleme
j'ai recupere le code de gvim 7.1, je compile et la il me reponds :
pas de ncurses et pas de GUI detecte

or j ai gtk2, j'ai rajoue gtk1.4 et gtk 1.4 dev

et toujours rien

j ai recupere un vim gtk par apt_get et il marche super bien, alors
pourquoi moi j'arrive pas a le générer ???

merci a vous !

@+


Pour ncurses, il te faut probablement le package libncurses5-dev, la
meme pour GTK.
Tu peux coller le msg d'erreur complet lors du ./configure ?

Mais simplement, pourquoi t'obstiner à compiler si c'est disponible en
package ?


et bien simplement pour pouvoir faire évoluer mes logiciels...
par exemple le package est de la 7.0, j'ai le code de la 7.1

J'admet toutefois que c'est plus par soucis d'indépendance qu'autre
chose ... Autant sous windows j'aiem bien ne rien avoir à faire (pour
moi window est un système conçu pour normaliser toute procédure),
autant sous linux j'aime bien contrôler ce que je fais :)


Ben lors du ./config, il écrit juste GUI not found, et à la fin
qu'aucune librairie temrinale n'a été trouvée...

mais bon tu confirme bien qu'il me faut les -dev, il va falloir que je
trouve pourquoi une fois installées, gvim ne les trouve pas à la
configuration !

cordialement


Kevin Denis
Le #1916616
On 2008-02-23, eric
j ai un eeepc et un autre portable pour le travail avec une mandriva
j'ai le meme probleme
j'ai recupere le code de gvim 7.1, je compile et la il me reponds : pas
de ncurses et pas de GUI detecte
^^^^^^^
La.


or j ai gtk2, j'ai rajoue gtk1.4


pourquoi gtk1.4 ?

et gtk 1.4 dev

et pas de ncurses-dev? pas de gtk2-dev?


et toujours rien

j ai recupere un vim gtk par apt_get et il marche super bien, alors
pourquoi moi j'arrive pas a le générer ???

parcequ'il te faut plus de choses pour compiler un programme que pour

l'utiliser.
--
Kevin

eric
Le #1916613
bonjour

j'ai recupere le code de gvim 7.1, je compile et la il me reponds : pas
de ncurses et pas de GUI detecte
^^^^^^^
La.



vi je sais or j'ai bien le package ncurses et meme le ncurses-dev


or j ai gtk2, j'ai rajoue gtk1.4


pourquoi gtk1.4 ?


dans la documentation, il semble que gvim soitplus experimental sur le
gtk2 que sur le gtk.
ensite sur mon pc, le gtk2 n'a pas été detecté alors que toutes les
dépendances semblent y etre selon apt-get


et gtk 1.4 dev

et pas de ncurses-dev? pas de gtk2-dev?



ncurses-dev si si
gtk2-dev, j'ai pas trouvé celui là dans les packages mandriva en effet


parcequ'il te faut plus de choses pour compiler un programme que pour
l'utiliser.


euh ça je sais ;)
mais normalement vim est un code qui utilise assez peu de dépendance
par rapport a bcp d'autres et j'ai toujours réussi à le compiler sur
toutes mes anciennes distrib... or depuis les nouvelles, j'ai des
problèmes avec :)

cordialement


Publicité
Poster une réponse
Anonyme