comprendre le problème avant de soumettre un rapport de bug

Le
Angus Frinc
Bonsoir,

en substance, mon problème est quand je m'identifie via gdm, mes panels
clignotent très rapidement avant de disparaître. Je peux lancer un
terminal en créant un lanceur sur le bureau (donc nautilus fonctionne)
et d'autre applications, mais pas epiphany, ni iceweasel.

j'ai les messages suivant :
~/.xsession-error :
gnome-panel: symbol lookup error: /usr/lib/libxml2.so.2: undefined symbol: gzopen64
terminal :
epiphany-browser: symbol lookup error: /usr/lib/libxml2.so.2: undefined symbol: gzopen64
et pour iceweasel un segfault

Pour obtenir se problème, voici ma façon de procéder :
- installer une lenny amd64 (avec gnome)
- installer les paquets propices pour faire fonctionner cette machine avec
ldap+nfs pour la gestion des utilisateurs et configurer le tout
(modules pam compris)

Si je lance un utilisateur locale avant l'installation de tout ces
paquets ldap : pas de problèmes.
le même utilisateur locale après configuration ldap/pam : plantage au
même titre que le distant.

Si je fais la même installation en i386 et non amd64, pas de problèmes.
(installation rigoureusement identique grâce à preseed et puppet, donc
je ne pense pas que ce soit un problème de configuration)

Ensuite, si je /etc/init.d/gdm stop,
alors root, mon utilisateur locale, ou mon distant peuvent lancer un
startx sans problème une fois identifié dans la console !!!

Par contre, je ne peux plus lancer gdm, j'ai le droit à :
/var/log/auth.log :
pam_nologin(gdm:auth): cannot determine username
/var/log/daemon :
gdm: WARNING: Impossible d'identifier l'utilisateur


Les questions sont :
- ça vous parle ? des pistes pour me sortir de cette galère ?
- sur quoi faire un rapport de bug s'il y a raison de le faire ?
libxml2, libpam-ldap, libnss-ldapd

Merci de m'avoir lu,
pour votre compation,
d'avance pour votre aide

--
afrinc

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Angus Frinc
Le #19085411
Bonjour,

mon problème est résolu, et pas besoin de faire de rapport de bug,
c'était une mauvaise configuration de ma part.

je me répond suite à un échange sur la liste anglophone (thank you
Sven).

Le 08/avr - 19:39, Angus Frinc a écrit :
en substance, mon problème est quand je m'identifie via gdm, mes panels
clignotent très rapidement avant de disparaître. Je peux lancer un
terminal en créant un lanceur sur le bureau (donc nautilus fonctionne)
et d'autre applications, mais pas epiphany, ni iceweasel.

j'ai les messages suivant :
~/.xsession-error :
gnome-panel: symbol lookup error: /usr/lib/libxml2.so.2: undefined symbol: gzopen64
terminal :
epiphany-browser: symbol lookup error: /usr/lib/libxml2.so.2: undefined symbol: gzopen64
et pour iceweasel un segfault



on m'a demandé ce que donnait ldd sur /usr/lib/libxml2.so.2
et on m'a suggéré une zlib annexe à Debian,

en effet, c'était le cas, une zlib d'un logiciel installé dans opt. Un
soft installé seulement pour amd64 et non i386, c'est pourquoi le "bug"
ne se reproduisait pas dans une installe en i386.

Désolé pour le bruit.

Bonne journée à vous !

--
afrinc

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme