Comptage

Le
oliver
Bonjour,
dans une colonne A2:A50 j'ai des dates ex: du 1/01/2008 au 31/01/2008 avec
des doublons
avec SOMMEPROD(1/NB.SI(A2:A50;A2:A50)) j'obtiens bien 31
dans la colonne B2:B50 j'ai 5 chiffres différents 40,41,42,43,44
avec NB.SI(B2:B50;40) j'obtiens bien de le nombre de fois ou le chiffre est
dans la colonne.
Comment combiner les deux formules pour trouver le nombre de jours (colonne
A2:A50) correspondant au nombre de chiffre (Colonne B2:B50)
1/01/2008 40
2/01/2008 41
2/01/2008 41
2/01/2008 41
3/01/2008 42
3/01/2008 42
3/01/2008 42
3/01/2008 40
3/01/2008 41
4/01/2008 41
4/01/2008 40
nombre de jour pour 40 : 3
nombre de jour pour 41: 3
nombre de jour pour 42: 1
Merci pour l'aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #5159151
Bonsoir.
=SOMMEPROD(SI(NB.SI(A1:A11;A1:A11)>0;1;0)*(B1:B11@))
Cordialement.
Daniel
"oliver" 47adec14$0$23603$
Bonjour,
dans une colonne A2:A50 j'ai des dates ex: du 1/01/2008 au 31/01/2008 avec
des doublons
avec SOMMEPROD(1/NB.SI(A2:A50;A2:A50)) j'obtiens bien 31
dans la colonne B2:B50 j'ai 5 chiffres différents 40,41,42,43,44
avec NB.SI(B2:B50;40) j'obtiens bien de le nombre de fois ou le chiffre
est dans la colonne.
Comment combiner les deux formules pour trouver le nombre de jours
(colonne A2:A50) correspondant au nombre de chiffre (Colonne B2:B50)
1/01/2008 40
2/01/2008 41
2/01/2008 41
2/01/2008 41
3/01/2008 42
3/01/2008 42
3/01/2008 42
3/01/2008 40
3/01/2008 41
4/01/2008 41
4/01/2008 40
nombre de jour pour 40 : 3
nombre de jour pour 41: 3
nombre de jour pour 42: 1
Merci pour l'aide








Daniel.C
Le #5159141
Non, dommage, trop facile.
Daniel
"Daniel.C"
Bonsoir.
=SOMMEPROD(SI(NB.SI(A1:A11;A1:A11)>0;1;0)*(B1:B11@))
Cordialement.
Daniel
"oliver" 47adec14$0$23603$
Bonjour,
dans une colonne A2:A50 j'ai des dates ex: du 1/01/2008 au 31/01/2008
avec des doublons
avec SOMMEPROD(1/NB.SI(A2:A50;A2:A50)) j'obtiens bien 31
dans la colonne B2:B50 j'ai 5 chiffres différents 40,41,42,43,44
avec NB.SI(B2:B50;40) j'obtiens bien de le nombre de fois ou le chiffre
est dans la colonne.
Comment combiner les deux formules pour trouver le nombre de jours
(colonne A2:A50) correspondant au nombre de chiffre (Colonne B2:B50)
1/01/2008 40
2/01/2008 41
2/01/2008 41
2/01/2008 41
3/01/2008 42
3/01/2008 42
3/01/2008 42
3/01/2008 40
3/01/2008 41
4/01/2008 41
4/01/2008 40
nombre de jour pour 40 : 3
nombre de jour pour 41: 3
nombre de jour pour 42: 1
Merci pour l'aide












AV
Le #5159041
Salut,

Matricielle (valider par ctrl+maj+entrée)

=NB(1/FREQUENCE(SI(B2:B50@;A2:A50;"");A2:A50))

AV
Publicité
Poster une réponse
Anonyme