Compte([...]), mais si pas d'enregistrement

Le
Loïc V.
Bonjour!

J'ai un état dans lequel il y a aussi un sous-état.
Je désire "compter" tous les enregistrements dans l'état et dans ce sous-état.

Génial! J'y suis arrivé.

Mais le gros snif, c'est que lorsque l'état (détail) ou sous-état (mis en
entête de groupe) n'a pas de valeur, il m'indique "Erreur" dans la zone de
texte.

J'ai pourtant utilisé la fonction Nz, mais rien n'y fait.

Ce qui est assez drôle vu que dans le sous-état, le zéro apparaît bien. si
il y a un enregistrement dans l'état (détail), il lui suffit de faire 1+0=1,
et bien non, il ne veut pas. Pourquoi ?

Merci beaucoup et infiniment.

Loïc
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
3stone
Le #17482321
Salut,

"Loïc V."
| J'ai un état dans lequel il y a aussi un sous-état.
| Je désire "compter" tous les enregistrements dans l'état et dans ce sous-état.
|
| Génial! J'y suis arrivé.

Bravo ;-)


| Mais le gros snif, c'est que lorsque l'état (détail) ou sous-état (mis en
| entête de groupe) n'a pas de valeur, il m'indique "Erreur" dans la zone de
| texte.
|
| J'ai pourtant utilisé la fonction Nz, mais rien n'y fait.
|
| Ce qui est assez drôle vu que dans le sous-état, le zéro apparaît bien. si
| il y a un enregistrement dans l'état (détail), il lui suffit de faire 1+0=1,
| et bien non, il ne veut pas. Pourquoi ?


Ceci devrait t'aider :
http://www.3stone.be/access/faq.php?lng=fr&pgI6

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
Loïc V.
Le #17482621
Je suis EBAHI!!!!!!!!!!
Tu es génial, 3stone!!!!
Merci infiniment!!!!!

Loïc



"3stone" a écrit :

Salut,

"Loïc V."
| J'ai un état dans lequel il y a aussi un sous-état.
| Je désire "compter" tous les enregistrements dans l'état et dans ce sous-état.
|
| Génial! J'y suis arrivé.

Bravo ;-)


| Mais le gros snif, c'est que lorsque l'état (détail) ou sous-état (mis en
| entête de groupe) n'a pas de valeur, il m'indique "Erreur" dans la zone de
| texte.
|
| J'ai pourtant utilisé la fonction Nz, mais rien n'y fait.
|
| Ce qui est assez drôle vu que dans le sous-état, le zéro apparaît bien. si
| il y a un enregistrement dans l'état (détail), il lui suffit de faire 1+0=1,
| et bien non, il ne veut pas. Pourquoi ?


Ceci devrait t'aider :
http://www.3stone.be/access/faq.php?lng=fr&pgI6

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)




Publicité
Poster une réponse
Anonyme