Compter avec 2 critéres

Le
Cyrille
Bonjour à tous et merci d'avance
J'aimerai compter le nombre de fois ou je trouve le critére "2007" dans une
colonne et "10" pour octobre par exemple dans une autre. Le résultat doit me
donner le nombre de fois ou les 2 critéres 2007 et 10 sont en meme temps.
Je dois faire autant de fois des formules que j'ai d'année et de mois (sans
faire des tableaux croisées)
Merci d'avance
Cyrille
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
francois.forcet
Le #5148201
On 4 fév, 09:28, "Cyrille"
Bonjour à tous et merci d'avance
J'aimerai compter le nombre de fois ou je trouve le critére "2007" dans une
colonne et "10" pour octobre par exemple dans une autre. Le résultat doi t me
donner le nombre de fois ou les 2 critéres 2007 et 10 sont en meme temps .
Je dois faire autant de fois des formules que j'ai d'année et de mois (s ans
faire des tableaux croisées)
Merci d'avance
Cyrille


Salut Cyrille
Peux tu préciser comment se présentent les données sur ces 2 colonnes
Une solution VBA est possible t'interresse t'elle ???

Merci pour tes réponses

Daniel.C
Le #5148191
Bonjour.
Avec les années en colonne A et les mois en colonne B :
=SOMMEPROD((A1:A20 07)*(B1:B20))
Cordialement.
Daniel
"Cyrille"
Bonjour à tous et merci d'avance
J'aimerai compter le nombre de fois ou je trouve le critére "2007" dans
une colonne et "10" pour octobre par exemple dans une autre. Le résultat
doit me donner le nombre de fois ou les 2 critéres 2007 et 10 sont en meme
temps.
Je dois faire autant de fois des formules que j'ai d'année et de mois
(sans faire des tableaux croisées)
Merci d'avance
Cyrille


Cyrille
Le #5148181
1ere colonne; une liste d'année en chiffre (2007,2007,2008...) et 2eme
colonne des mois (1,1,1,2,2,3,11,10,12...)
j'ai besoin de formules parce que je dois afficher les résultats dans un
tableau récapitulatif par mois

Merci d'avance

:
On 4 fév, 09:28, "Cyrille"
Bonjour à tous et merci d'avance
J'aimerai compter le nombre de fois ou je trouve le critére "2007" dans
une
colonne et "10" pour octobre par exemple dans une autre. Le résultat doit
me
donner le nombre de fois ou les 2 critéres 2007 et 10 sont en meme temps.
Je dois faire autant de fois des formules que j'ai d'année et de mois
(sans
faire des tableaux croisées)
Merci d'avance
Cyrille


Salut Cyrille
Peux tu préciser comment se présentent les données sur ces 2 colonnes
Une solution VBA est possible t'interresse t'elle ???

Merci pour tes réponses



Cyrille
Le #5148171
Merci également pour cette aide précieuse

Ca marche parfaitement mais pourquoi le principe est de multiplier les
matrices??

"Daniel.C" discussion :
Bonjour.
Avec les années en colonne A et les mois en colonne B :
=SOMMEPROD((A1:A20 07)*(B1:B20))
Cordialement.
Daniel
"Cyrille"
Bonjour à tous et merci d'avance
J'aimerai compter le nombre de fois ou je trouve le critére "2007" dans
une colonne et "10" pour octobre par exemple dans une autre. Le résultat
doit me donner le nombre de fois ou les 2 critéres 2007 et 10 sont en
meme temps.
Je dois faire autant de fois des formules que j'ai d'année et de mois
(sans faire des tableaux croisées)
Merci d'avance
Cyrille






Daniel.C
Le #5148161
(A1:A20 07) renvoie une matrice de valeurs VRAI ou FAUX (1 ou 0); il en va
de même pour (B1:B20). Seules les lignes ayant 2007 et 10 renvoient 1
pour l'année et 1 pour le mois; donc 1*1=1, dans les autres cas, on obtient
1*0=0 ou 0*0=0. La fonction SOMMEPROD fait la somme de ces valeurs, qui
correspond au nombre de 1, donc au nombre demandé.
Daniel
"Cyrille"
Merci également pour cette aide précieuse

Ca marche parfaitement mais pourquoi le principe est de multiplier les
matrices??

"Daniel.C" discussion :
Bonjour.
Avec les années en colonne A et les mois en colonne B :
=SOMMEPROD((A1:A20 07)*(B1:B20))
Cordialement.
Daniel
"Cyrille"
Bonjour à tous et merci d'avance
J'aimerai compter le nombre de fois ou je trouve le critére "2007" dans
une colonne et "10" pour octobre par exemple dans une autre. Le résultat
doit me donner le nombre de fois ou les 2 critéres 2007 et 10 sont en
meme temps.
Je dois faire autant de fois des formules que j'ai d'année et de mois
(sans faire des tableaux croisées)
Merci d'avance
Cyrille








Cyrille
Le #5148131
Merci beaucoup pour ces réponses
Bonne journée

"Daniel.C" discussion :
(A1:A20 07) renvoie une matrice de valeurs VRAI ou FAUX (1 ou 0); il en
va de même pour (B1:B20). Seules les lignes ayant 2007 et 10 renvoient
1 pour l'année et 1 pour le mois; donc 1*1=1, dans les autres cas, on
obtient 1*0=0 ou 0*0=0. La fonction SOMMEPROD fait la somme de ces
valeurs, qui correspond au nombre de 1, donc au nombre demandé.
Daniel
"Cyrille"
Merci également pour cette aide précieuse

Ca marche parfaitement mais pourquoi le principe est de multiplier les
matrices??

"Daniel.C" discussion :
Bonjour.
Avec les années en colonne A et les mois en colonne B :
=SOMMEPROD((A1:A20 07)*(B1:B20))
Cordialement.
Daniel
"Cyrille"
Bonjour à tous et merci d'avance
J'aimerai compter le nombre de fois ou je trouve le critére "2007" dans
une colonne et "10" pour octobre par exemple dans une autre. Le
résultat doit me donner le nombre de fois ou les 2 critéres 2007 et 10
sont en meme temps.
Je dois faire autant de fois des formules que j'ai d'année et de mois
(sans faire des tableaux croisées)
Merci d'avance
Cyrille












Pounet95
Le #5148071
Bonjour,
Juste pour me lever d'un doute ( assimilation abusive à des anciennes (très)
notions d'algèbre de Boole ? )
est-ce que le signe * ne signifirait pas ET alors que le + signifierait OU
????

Merci de me préciser
Pounet95

"Daniel.C" news:
(A1:A20 07) renvoie une matrice de valeurs VRAI ou FAUX (1 ou 0); il en
va de même pour (B1:B20). Seules les lignes ayant 2007 et 10 renvoient
1 pour l'année et 1 pour le mois; donc 1*1=1, dans les autres cas, on
obtient 1*0=0 ou 0*0=0. La fonction SOMMEPROD fait la somme de ces
valeurs, qui correspond au nombre de 1, donc au nombre demandé.
Daniel
"Cyrille"
Merci également pour cette aide précieuse

Ca marche parfaitement mais pourquoi le principe est de multiplier les
matrices??

"Daniel.C" discussion :
Bonjour.
Avec les années en colonne A et les mois en colonne B :
=SOMMEPROD((A1:A20 07)*(B1:B20))
Cordialement.
Daniel
"Cyrille"
Bonjour à tous et merci d'avance
J'aimerai compter le nombre de fois ou je trouve le critére "2007" dans
une colonne et "10" pour octobre par exemple dans une autre. Le
résultat doit me donner le nombre de fois ou les 2 critéres 2007 et 10
sont en meme temps.
Je dois faire autant de fois des formules que j'ai d'année et de mois
(sans faire des tableaux croisées)
Merci d'avance
Cyrille












Trirème
Le #5147661
Bonsoir Pounet,
Effectivement tu as raison. D'ailleurs les tables de vérité de l'opérateur 'ET'
et de la multiplication donnent la même chose :

ET| 0 | 1
--+---+---
0 | 0 | 0
--+---+---
1 | 0 | 1

x | 0 | 1
--+---+---
0 | 0 | 0
--+---+---
1 | 0 | 1

Mêmes choses avec 'OU' et l'addition
OU| 0 | 1
--+---+---
0 | 0 | 1
--+---+---
1 | 1 | 1

+ | 0 | 1
--+---+---
0 | 0 | 1
--+---+---
1 | 1 | 2 càd différent de 0

Cordialement,
Trirème

Bonjour,
Juste pour me lever d'un doute ( assimilation abusive à des anciennes
(très) notions d'algèbre de Boole ? )
est-ce que le signe * ne signifirait pas ET alors que le + signifierait
OU ????

Merci de me préciser
Pounet95

"Daniel.C" news:
(A1:A20 07) renvoie une matrice de valeurs VRAI ou FAUX (1 ou 0); il
en va de même pour (B1:B20). Seules les lignes ayant 2007 et 10
renvoient 1 pour l'année et 1 pour le mois; donc 1*1=1, dans les
autres cas, on obtient 1*0=0 ou 0*0=0. La fonction SOMMEPROD fait la
somme de ces valeurs, qui correspond au nombre de 1, donc au nombre
demandé.
Daniel
"Cyrille"
Merci également pour cette aide précieuse

Ca marche parfaitement mais pourquoi le principe est de multiplier
les matrices??

"Daniel.C" de discussion :
Bonjour.
Avec les années en colonne A et les mois en colonne B :
=SOMMEPROD((A1:A20 07)*(B1:B20))
Cordialement.
Daniel
"Cyrille"
Bonjour à tous et merci d'avance
J'aimerai compter le nombre de fois ou je trouve le critére "2007"
dans une colonne et "10" pour octobre par exemple dans une autre.
Le résultat doit me donner le nombre de fois ou les 2 critéres 2007
et 10 sont en meme temps.
Je dois faire autant de fois des formules que j'ai d'année et de
mois (sans faire des tableaux croisées)
Merci d'avance
Cyrille















Jacquouille
Le #5283701
Voilà, mon bon Cyrille.
Si tu avais payé ta cotisation à la SPA (SommeProd Académie), tu aurais eu
le dépannage gratuit, avé les explications en sus. -)

--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Cyrille"
Merci beaucoup pour ces réponses
Bonne journée

"Daniel.C" discussion :
(A1:A20 07) renvoie une matrice de valeurs VRAI ou FAUX (1 ou 0); il en
va de même pour (B1:B20). Seules les lignes ayant 2007 et 10 renvoient
1 pour l'année et 1 pour le mois; donc 1*1=1, dans les autres cas, on
obtient 1*0=0 ou 0*0=0. La fonction SOMMEPROD fait la somme de ces
valeurs, qui correspond au nombre de 1, donc au nombre demandé.
Daniel
"Cyrille"
Merci également pour cette aide précieuse

Ca marche parfaitement mais pourquoi le principe est de multiplier les
matrices??

"Daniel.C" discussion :
Bonjour.
Avec les années en colonne A et les mois en colonne B :
=SOMMEPROD((A1:A20 07)*(B1:B20))
Cordialement.
Daniel
"Cyrille"
Bonjour à tous et merci d'avance
J'aimerai compter le nombre de fois ou je trouve le critére "2007"
dans une colonne et "10" pour octobre par exemple dans une autre. Le
résultat doit me donner le nombre de fois ou les 2 critéres 2007 et 10
sont en meme temps.
Je dois faire autant de fois des formules que j'ai d'année et de mois
(sans faire des tableaux croisées)
Merci d'avance
Cyrille














Pounet95
Le #5283391
Bonjour et merci pour la réponse.
Juste un peu étonné par le 2 , perso j'aurais encore mis 1 car 1 OU 1 = 1
( circuits en parallèles ? )
1 ------o_o--------!
!-------- le courant ( ou fluide passe )
1 ------o_o--------!

Pounet95

"Trirème" news:Oeyy%
Bonsoir Pounet,
Effectivement tu as raison. D'ailleurs les tables de vérité de l'opérateur
'ET' et de la multiplication donnent la même chose :

ET| 0 | 1
--+---+---
0 | 0 | 0
--+---+---
1 | 0 | 1

x | 0 | 1
--+---+---
0 | 0 | 0
--+---+---
1 | 0 | 1

Mêmes choses avec 'OU' et l'addition
OU| 0 | 1
--+---+---
0 | 0 | 1
--+---+---
1 | 1 | 1

+ | 0 | 1
--+---+---
0 | 0 | 1
--+---+---
1 | 1 | 2 càd différent de 0

Cordialement,
Trirème

Bonjour,
Juste pour me lever d'un doute ( assimilation abusive à des anciennes
(très) notions d'algèbre de Boole ? )
est-ce que le signe * ne signifirait pas ET alors que le + signifierait
OU ????

Merci de me préciser
Pounet95

"Daniel.C" news:
(A1:A20 07) renvoie une matrice de valeurs VRAI ou FAUX (1 ou 0); il
en va de même pour (B1:B20). Seules les lignes ayant 2007 et 10
renvoient 1 pour l'année et 1 pour le mois; donc 1*1=1, dans les autres
cas, on obtient 1*0=0 ou 0*0=0. La fonction SOMMEPROD fait la somme de
ces valeurs, qui correspond au nombre de 1, donc au nombre demandé.
Daniel
"Cyrille"
Merci également pour cette aide précieuse

Ca marche parfaitement mais pourquoi le principe est de multiplier les
matrices??

"Daniel.C" de discussion :
Bonjour.
Avec les années en colonne A et les mois en colonne B :
=SOMMEPROD((A1:A20 07)*(B1:B20))
Cordialement.
Daniel
"Cyrille"
Bonjour à tous et merci d'avance
J'aimerai compter le nombre de fois ou je trouve le critére "2007"
dans une colonne et "10" pour octobre par exemple dans une autre. Le
résultat doit me donner le nombre de fois ou les 2 critéres 2007 et
10 sont en meme temps.
Je dois faire autant de fois des formules que j'ai d'année et de mois
(sans faire des tableaux croisées)
Merci d'avance
Cyrille

















Publicité
Poster une réponse
Anonyme