Compter les lignes à partir de plusieurs critères

Le
gegebar
Bonjour,

j'ai un tableau de 7 colonnes et de 4000 lignes environ.
chaque ligne représente un tirage du loto.

Je voudrais connaître le nombre de ligne qui ont 2 ou 3 . ou 6
numéros en commun. Pour un numero en commun j'utilise NB.SI.

la difficulté que je rencontre est que chaque chiffre, le 1 par exemple,
n'est pas toujours dans la même colonne.

Merci d'avance pour votre aide

gegebar
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichDenis
Le #6779181
Si chaque ligne représente un tirage de loto,
chaque chiffre sur cette ligne est unique
En conséquence, le nombre de fois qu'apparaît
le chiffre "x" dans l'ensemble de la plage représente
en même temps le nombre de ligne (ou tirage) ou le
chiffre "x" est sorti.

Une formule simple devrait te donner le résultat :
Exemple : =Nb.Si(A1:G4000;2) 'pour trouver le nombre
de lignes ou d'occurrence où le chiffre 2 est sorti. Et tu
appliques cette formule pour chacun des chiffres qui
t'intéresse.



"gegebar"
Bonjour,

j'ai un tableau de 7 colonnes et de 4000 lignes environ.
chaque ligne représente un tirage du loto.

Je voudrais connaître le nombre de ligne qui ont 2 ou 3 .... ou 6
numéros en commun. Pour un numero en commun j'utilise NB.SI.

la difficulté que je rencontre est que chaque chiffre, le 1 par exemple,
n'est pas toujours dans la même colonne.

Merci d'avance pour votre aide

gegebar
gegebar
Le #6780001
Merci MichDenis, mais cette solution je la connais et je le dis dans ma
question.
Ce que je veux c'est compter les lignes où il y a 2 numeros communs,
puis 3 numeros communs, etc ...
La difficulté c'est qu'un numéro donné peut être dans plusieurs colonnes.

gegebar

Si chaque ligne représente un tirage de loto,
chaque chiffre sur cette ligne est unique
En conséquence, le nombre de fois qu'apparaît
le chiffre "x" dans l'ensemble de la plage représente
en même temps le nombre de ligne (ou tirage) ou le
chiffre "x" est sorti.

Une formule simple devrait te donner le résultat :
Exemple : =Nb.Si(A1:G4000;2) 'pour trouver le nombre
de lignes ou d'occurrence où le chiffre 2 est sorti. Et tu
appliques cette formule pour chacun des chiffres qui
t'intéresse.



"gegebar"
Bonjour,

j'ai un tableau de 7 colonnes et de 4000 lignes environ.
chaque ligne représente un tirage du loto.

Je voudrais connaître le nombre de ligne qui ont 2 ou 3 .... ou 6
numéros en commun. Pour un numero en commun j'utilise NB.SI.

la difficulté que je rencontre est que chaque chiffre, le 1 par exemple,
n'est pas toujours dans la même colonne.

Merci d'avance pour votre aide

gegebar




gegebar
Le #6779991
Merci MichDenis, mais cette solution je la connais et je le dis dans ma
question.
Ce que je veux c'est compter les lignes où il y a 2 numeros communs,
puis 3 numeros communs, etc ...
La difficulté c'est qu'un numéro donné peut être dans plusieurs colonnes.

gegebar

Si chaque ligne représente un tirage de loto,
chaque chiffre sur cette ligne est unique
En conséquence, le nombre de fois qu'apparaît
le chiffre "x" dans l'ensemble de la plage représente
en même temps le nombre de ligne (ou tirage) ou le
chiffre "x" est sorti.

Une formule simple devrait te donner le résultat :
Exemple : =Nb.Si(A1:G4000;2) 'pour trouver le nombre
de lignes ou d'occurrence où le chiffre 2 est sorti. Et tu
appliques cette formule pour chacun des chiffres qui
t'intéresse.



"gegebar"
Bonjour,

j'ai un tableau de 7 colonnes et de 4000 lignes environ.
chaque ligne représente un tirage du loto.

Je voudrais connaître le nombre de ligne qui ont 2 ou 3 .... ou 6
numéros en commun. Pour un numero en commun j'utilise NB.SI.

la difficulté que je rencontre est que chaque chiffre, le 1 par exemple,
n'est pas toujours dans la même colonne.

Merci d'avance pour votre aide

gegebar




MichDenis
Le #6781731
Avec une formule... il doit y en avoir des meilleures... si quelqu'un a le temps ?

Tu ajoutes une colonne en H avec la formule suivante : ¢&B2&C2&D2&E2&F2&G2

Et pour effectuer ton calcul sur le nombre de lignes contenant 2 et 3, tu appliques
la formule suivante:
=SOMMEPROD((NBCAR(H1:H4000)-NBCAR(SUBSTITUE(SUBSTITUE(H1:H4000;3;);2;))=2)*1)

Si tu veux te passer de la colonne intermédiaire, tu pourrais utiliser cette
formule matricielle en adaptant la plage de cellules selon ton application
Validation matricielle Ctrl + Maj + Enter
=SOMME(SI((NBCAR(A2:A4&B2:B4&C2:C4&D2:D4&E2:E4&F2:F4&G2:G4)-NBCAR(SUBSTITUE(SUBSTITUE(A2:A4&B2:B4&C2:C4&D2:D4&E2:E4&F2:F4&G2:G4;3;);2;))=2);1))


Et si tu veux visualiser toutes les lignes qui ont le chiffre 2 et 3 en commun

A ) Tu ajoutes (si ce n'est déjà fait) une colonne adjacente à ton tableau avec la formule suivante
:
¢&B2&C2&D2&E2&F2&G2
B ) Si absent, tu ajoutes une étiquette à chaque colonne de ton tableau

C ) Tu crées une zone de critère pour l'éventuel filtre élaboré
Exemple : H1 : tu laisses totalement vide
H2 : =NBCAR(H1:H4000)-NBCAR(SUBSTITUE(SUBSTITUE(H1:H4000;3;);2;))=2
Tu insères la formule suivante en H2, lorsque tu exécuteras le filtre
seules les lignes qui ont le chiffre 2 et 3 s'afficheront.
et tu peux toujours faire afficher le résultat "Nombre de lignes"
en utilisant la fonction sous.total() comme ceci : =SOUS.TOTAL(3;A:A)-1
le moins 1 (-1) c'est pour enlever la ligne d'étiquette.

Amuse toi bien !

P.S.- Si tu trouves la prochaine combinaison gagnante, tu me prends un billet et
tu me fais parvenir le "gros lot"... je te paierai alors la billet ;-)))





"gegebar"
Merci MichDenis, mais cette solution je la connais et je le dis dans ma
question.
Ce que je veux c'est compter les lignes où il y a 2 numeros communs,
puis 3 numeros communs, etc ...
La difficulté c'est qu'un numéro donné peut être dans plusieurs colonnes.

gegebar

Si chaque ligne représente un tirage de loto,
chaque chiffre sur cette ligne est unique
En conséquence, le nombre de fois qu'apparaît
le chiffre "x" dans l'ensemble de la plage représente
en même temps le nombre de ligne (ou tirage) ou le
chiffre "x" est sorti.

Une formule simple devrait te donner le résultat :
Exemple : =Nb.Si(A1:G4000;2) 'pour trouver le nombre
de lignes ou d'occurrence où le chiffre 2 est sorti. Et tu
appliques cette formule pour chacun des chiffres qui
t'intéresse.



"gegebar"
Bonjour,

j'ai un tableau de 7 colonnes et de 4000 lignes environ.
chaque ligne représente un tirage du loto.

Je voudrais connaître le nombre de ligne qui ont 2 ou 3 .... ou 6
numéros en commun. Pour un numero en commun j'utilise NB.SI.

la difficulté que je rencontre est que chaque chiffre, le 1 par exemple,
n'est pas toujours dans la même colonne.

Merci d'avance pour votre aide

gegebar




MichDenis
Le #6782541
Et pour terminer, suppose que tu utilises une plage de critères pour
entrer les nombres dont tu désires valider leur occurrence dans
un même tirage et en dénombrer le nombre de lignes.

Soit une plage de critère : K1:K5
Dans la plage K1:K5, tu entres les numéros que tu désires (un par cellule)
tu peux entrer 1 seul numéro et laisser le reste de la plage vacante ou
un numéro différent par cellule.

Tu peux utiliser cette formule pour te donner le nombre de lignes dont les chiffres
saisis en K1:K5 apparaissent à chacun des tirages. Il te reste qu'à adapter la
plage de cellules si différentes de A1:G4000....

=SOMME(SI((NBCAR(A1:A4000&B1:B4000&C1:C4000&D1:D4000&E1:E4000&F1:F4000&G1:G4000)-NBCAR(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(A1:A4000&B1:B4000&C1:C4000&D1:D4000&E1:E4000&F1:F4000&G1:G4000;K2;);K1;);K3;);K4;);K5;))=SOMME(NBCAR(K1:K5)));1))

Cela prend quelques instants à excel pour extraire le résultat ... mais si tu dois travailler sur
cette feuille,
passe en mode de calcul sur ordre ....

Sous la version Excel 2003, le maximum de fonction "Substitue" que je peux imbriquer est 5.
à vois sous excel 2007.
gegebar
Le #6783491
Merci MichDenis, pour toutes ces explications. J'essaye cela ce soir et
je te tiens au courant.
gegebar

Et pour terminer, suppose que tu utilises une plage de critères pour
entrer les nombres dont tu désires valider leur occurrence dans
un même tirage et en dénombrer le nombre de lignes.

Soit une plage de critère : K1:K5
Dans la plage K1:K5, tu entres les numéros que tu désires (un par cellule)
tu peux entrer 1 seul numéro et laisser le reste de la plage vacante ou
un numéro différent par cellule.

Tu peux utiliser cette formule pour te donner le nombre de lignes dont les chiffres
saisis en K1:K5 apparaissent à chacun des tirages. Il te reste qu'à adapter la
plage de cellules si différentes de A1:G4000....

=SOMME(SI((NBCAR(A1:A4000&B1:B4000&C1:C4000&D1:D4000&E1:E4000&F1:F4000&G1:G4000)-NBCAR(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(A1:A4000&B1:B4000&C1:C4000&D1:D4000&E1:E4000&F1:F4000&G1:G4000;K2;);K1;);K3;);K4;);K5;))=SOMME(NBCAR(K1:K5)));1))

Cela prend quelques instants à excel pour extraire le résultat ... mais si tu dois travailler sur
cette feuille,
passe en mode de calcul sur ordre ....

Sous la version Excel 2003, le maximum de fonction "Substitue" que je peux imbriquer est 5.
à vois sous excel 2007.




gegebar
Le #6783941
je viens de faire un essai.
avec nbcar, ça ne donne pas de bons résultats: si je choisis le 1 comme
critère, la formule prend en compte toutes les cellules qui contiennent
1 en tant que texte, ainsi tous les 11,21,31, etc sont comptabilisés. Ce
qui n'est pas le but recherché.
Continuons nos recherches
a+

Merci MichDenis, pour toutes ces explications. J'essaye cela ce soir et
je te tiens au courant.
gegebar

Et pour terminer, suppose que tu utilises une plage de critères pour
entrer les nombres dont tu désires valider leur occurrence dans
un même tirage et en dénombrer le nombre de lignes.

Soit une plage de critère : K1:K5
Dans la plage K1:K5, tu entres les numéros que tu désires (un par
cellule)
tu peux entrer 1 seul numéro et laisser le reste de la plage vacante ou
un numéro différent par cellule.

Tu peux utiliser cette formule pour te donner le nombre de lignes dont
les chiffres
saisis en K1:K5 apparaissent à chacun des tirages. Il te reste qu'à
adapter la
plage de cellules si différentes de A1:G4000....

=SOMME(SI((NBCAR(A1:A4000&B1:B4000&C1:C4000&D1:D4000&E1:E4000&F1:F4000&G1:G4000)-NBCAR(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(A1:A4000&B1:B4000&C1:C4000&D1:D4000&E1:E4000&F1:F4000&G1:G4000;K2;);K1;);K3;);K4;);K5;))=SOMME(NBCAR(K1:K5)));1))


Cela prend quelques instants à excel pour extraire le résultat ...
mais si tu dois travailler sur cette feuille,
passe en mode de calcul sur ordre ....

Sous la version Excel 2003, le maximum de fonction "Substitue" que je
peux imbriquer est 5.
à vois sous excel 2007.






MichDenis
Le #6792731
Effectivement, mes tests étaient de toutes évidence trop sommaires !

J'ai vu que tu avais relancé ce message dans un autre fil ...
Serait-ce que M. est pressé ?

Je joins un fichier exemple susceptible de t'intéresser.
J'ai adapté une des formules de Laurent Longre que tu as
publiée dans ton autre message.

Avec un soupçon de travail, tu devrais être en mesure de saisir
comment cela fonctionne.

http://cjoint.com/?ggtsLEG4f7




"gegebar" %
je viens de faire un essai.
avec nbcar, ça ne donne pas de bons résultats: si je choisis le 1 comme
critère, la formule prend en compte toutes les cellules qui contiennent
1 en tant que texte, ainsi tous les 11,21,31, etc sont comptabilisés. Ce
qui n'est pas le but recherché.
Continuons nos recherches
a+

Merci MichDenis, pour toutes ces explications. J'essaye cela ce soir et
je te tiens au courant.
gegebar

Et pour terminer, suppose que tu utilises une plage de critères pour
entrer les nombres dont tu désires valider leur occurrence dans
un même tirage et en dénombrer le nombre de lignes.

Soit une plage de critère : K1:K5
Dans la plage K1:K5, tu entres les numéros que tu désires (un par
cellule)
tu peux entrer 1 seul numéro et laisser le reste de la plage vacante ou
un numéro différent par cellule.

Tu peux utiliser cette formule pour te donner le nombre de lignes dont
les chiffres
saisis en K1:K5 apparaissent à chacun des tirages. Il te reste qu'à
adapter la
plage de cellules si différentes de A1:G4000....

=SOMME(SI((NBCAR(A1:A4000&B1:B4000&C1:C4000&D1:D4000&E1:E4000&F1:F4000&G1:G4000)-NBCAR(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(A1:A4000&B1:B4000&C1:C4000&D1:D4000&E1:E4000&F1:F4000&G1:G4000;K2;);K1;);K3;);K4;);K5;))=SOMME(NBCAR(K1:K5)));1))


Cela prend quelques instants à excel pour extraire le résultat ...
mais si tu dois travailler sur cette feuille,
passe en mode de calcul sur ordre ....

Sous la version Excel 2003, le maximum de fonction "Substitue" que je
peux imbriquer est 5.
à vois sous excel 2007.






Modeste
Le #6793771
Bonsour® gegebar avec ferveur ;o))) vous nous disiez :

j'ai un tableau de 7 colonnes et de 4000 lignes environ.
chaque ligne représente un tirage du loto.

Je voudrais connaître le nombre de ligne qui ont 2 ou 3 .... ou 6
numéros en commun. Pour un numero en commun j'utilise NB.SI.

la difficulté que je rencontre est que chaque chiffre, le 1 par
exemple, n'est pas toujours dans la même colonne.

Merci d'avance pour votre aide


http://cjoint.com/?ggvzgDaZPL

voir également :
http://excelabo.net/excel/compteclic.php?nom=gdybpr-lotos



--
--
@+
;o)))

gegebar
Le #6796041
Merci MichDenis

Ca marche impeccablement bien
c'est la fonction N que je ne connaissais pas (1 seule lettre, trop
courte peût-etre !)
je l'avais prise pour la variable N qui existe aussi dans la formule.

Merci encore

gegebar

Effectivement, mes tests étaient de toutes évidence trop sommaires !

J'ai vu que tu avais relancé ce message dans un autre fil ...
Serait-ce que M. est pressé ?

Je joins un fichier exemple susceptible de t'intéresser.
J'ai adapté une des formules de Laurent Longre que tu as
publiée dans ton autre message.

Avec un soupçon de travail, tu devrais être en mesure de saisir
comment cela fonctionne.

http://cjoint.com/?ggtsLEG4f7




"gegebar" %
je viens de faire un essai.
avec nbcar, ça ne donne pas de bons résultats: si je choisis le 1 comme
critère, la formule prend en compte toutes les cellules qui contiennent
1 en tant que texte, ainsi tous les 11,21,31, etc sont comptabilisés. Ce
qui n'est pas le but recherché.
Continuons nos recherches
a+

Merci MichDenis, pour toutes ces explications. J'essaye cela ce soir et
je te tiens au courant.
gegebar

Et pour terminer, suppose que tu utilises une plage de critères pour
entrer les nombres dont tu désires valider leur occurrence dans
un même tirage et en dénombrer le nombre de lignes.

Soit une plage de critère : K1:K5
Dans la plage K1:K5, tu entres les numéros que tu désires (un par
cellule)
tu peux entrer 1 seul numéro et laisser le reste de la plage vacante ou
un numéro différent par cellule.

Tu peux utiliser cette formule pour te donner le nombre de lignes dont
les chiffres
saisis en K1:K5 apparaissent à chacun des tirages. Il te reste qu'à
adapter la
plage de cellules si différentes de A1:G4000....

=SOMME(SI((NBCAR(A1:A4000&B1:B4000&C1:C4000&D1:D4000&E1:E4000&F1:F4000&G1:G4000)-NBCAR(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(SUBSTITUE(A1:A4000&B1:B4000&C1:C4000&D1:D4000&E1:E4000&F1:F4000&G1:G4000;K2;);K1;);K3;);K4;);K5;))=SOMME(NBCAR(K1:K5)));1))


Cela prend quelques instants à excel pour extraire le résultat ...
mais si tu dois travailler sur cette feuille,
passe en mode de calcul sur ordre ....

Sous la version Excel 2003, le maximum de fonction "Substitue" que je
peux imbriquer est 5.
à vois sous excel 2007.










Publicité
Poster une réponse
Anonyme