Compter la longueur maxi d'un champ

Le
Salut à tous,

J'ai une feuille excel de 28000 lignes et sur la colonne A je souhaite
balayer les 28000 lignes avec 2 objectifs :
- savoir quelle est la longueur MAXIMUM du contenu, 28000 lignes confondues
en balayant de A1 à A28000
- si possible en plus, avoir le détail = 125 enregistrements font 8 de long,
854 font 9 de long, etc mais ça c'est la question subsidiaire ;-)

Petite précision : je suis plus à l'aise avec les fonctions d'Excel qu'avec
le visual basic !

Merci
@+
Fred
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
lSteph
Le #5278051
Bonjour Fred

Peux tu préciser ta question.
la longueur en quoi?
- si possible en plus, avoir le détail = 125 enregistrements font 8 de long,
font 8 quoi?

8colonnes 8Metres 8 caractères 8beaujolais le temps de les compter?

--
lSteph


On 12 fév, 17:11,
Salut à tous,

J'ai une feuille excel de 28000 lignes et sur la colonne A je souhaite
balayer les 28000 lignes avec 2 objectifs :
- savoir quelle est la longueur MAXIMUM du contenu, 28000 lignes confondue s
en balayant de A1 à A28000
- si possible en plus, avoir le détail = 125 enregistrements font 8 de long,
854 font 9 de long, etc... mais ça c'est la question subsidiaire ;-)

Petite précision : je suis plus à l'aise avec les fonctions d'Excel qu 'avec
le visual basic !

Merci
@+
Fred


JB
Le #5278041
Bonjour,

=MAX(NBCAR(Champ))
Valider avec Maj+Ctrl+entrée

=SOMMEPROD(--(NBCAR(Champ)=8))

JB

On 12 fév, 17:11,
Salut à tous,

J'ai une feuille excel de 28000 lignes et sur la colonne A je souhaite
balayer les 28000 lignes avec 2 objectifs :
- savoir quelle est la longueur MAXIMUM du contenu, 28000 lignes confondue s
en balayant de A1 à A28000
- si possible en plus, avoir le détail = 125 enregistrements font 8 de long,
854 font 9 de long, etc... mais ça c'est la question subsidiaire  ;-)

Petite précision : je suis plus à l'aise avec les fonctions d'Excel qu 'avec
le visual basic !

Merci
@+
Fred


Ellimac
Le #5278001
Bonsoir,

En B1 :
=Max(A1)
à recopier jusqu'en B28000
Ailleurs : =Max(B:B)
Puis en colonne D à partir de D1 : faire une série de 1 à la valeur renoyée
par =Max(B:B)
De E1 à Ex où x correspond à la dernière ligne de la colonne D +1
=Frequence(B:B;D1:Dx-1)
Formule à valider par Ctrl Shift Entrée (matricielle)

Camille


47b1c51d$0$868$
Salut à tous,

J'ai une feuille excel de 28000 lignes et sur la colonne A je souhaite
balayer les 28000 lignes avec 2 objectifs :
- savoir quelle est la longueur MAXIMUM du contenu, 28000 lignes
confondues en balayant de A1 à A28000
- si possible en plus, avoir le détail = 125 enregistrements font 8 de
long, 854 font 9 de long, etc... mais ça c'est la question subsidiaire
;-)

Petite précision : je suis plus à l'aise avec les fonctions d'Excel
qu'avec le visual basic !

Merci
@+
Fred





Publicité
Poster une réponse
Anonyme