Compter le nombre de 1

Le
Ceno
Re-Bonjour à tous,

Je voudrais dans un cellule avoir le résultat d'une formule qui compte
le nombre de 1 dans ma première colonne, sachant que j'ai des 1, des
2, des 3 qu'il y en a plusieurs de chaque.

Par avance merci.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Misange
Le #5285761
Re-Bonjour à tous,

Je voudrais dans un cellule avoir le résultat d'une formule qui compte
le nombre de 1 dans ma première colonne, sachant que j'ai des 1, des
2, des 3...... qu'il y en a plusieurs de chaque.

Par avance merci.
bonjour

=nb.si(A1:A200;1)

--
Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Tatanka
Le #5285641
Bonjour Ceno,

Pour faire suite à la réponse de Misange.
Si une cellule peut contenir des nombres tels que :
1
121
1134
1
12
4316
...
la formule de Misange ne comptera que les celllules contenant exclusivement 1.
Par contre, celle-ci :
=SOMME(NBCAR(A1:A500)-NBCAR(SUBSTITUE(A1:A500;1;"")))
( à valider par Ctrl+Maj+Entrée )
te renverra le nombre total de1 apparaissant dans la plage A1:A500..
Malheureusement ma formule devient d'une lenteur extrême si le nombre de
lignes de la première colonne est « grand ».

Serge


"Ceno" Re-Bonjour à tous,

Je voudrais dans un cellule avoir le résultat d'une formule qui compte
le nombre de 1 dans ma première colonne, sachant que j'ai des 1, des
2, des 3...... qu'il y en a plusieurs de chaque.

Par avance merci.
Tatanka
Le #5285611
Malheureusement ma formule devient d'une lenteur extrême si le nombre de
lignes de la première colonne est « grand ».
Et génère une erreur si tu entres :

=SOMME(NBCAR(A:A)-NBCAR(SUBSTITUE(A:A;1;"")))
( à valider par Ctrl+Maj+Entrée )
Pas sûr de mon coup, mais je crois que les formules matricielles
n'aiment pas qu'on leur donne une colonne entière à traiter ?

Serge


"Tatanka"
Bonjour Ceno,

Pour faire suite à la réponse de Misange.
Si une cellule peut contenir des nombres tels que :
1
121
1134
1
12
4316
...
la formule de Misange ne comptera que les celllules contenant exclusivement 1.
Par contre, celle-ci :
=SOMME(NBCAR(A1:A500)-NBCAR(SUBSTITUE(A1:A500;1;"")))
( à valider par Ctrl+Maj+Entrée )
te renverra le nombre total de1 apparaissant dans la plage A1:A500..
Malheureusement ma formule devient d'une lenteur extrême si le nombre de
lignes de la première colonne est « grand ».

Serge


"Ceno"
Re-Bonjour à tous,

Je voudrais dans un cellule avoir le résultat d'une formule qui compte
le nombre de 1 dans ma première colonne, sachant que j'ai des 1, des
2, des 3...... qu'il y en a plusieurs de chaque.

Par avance merci.



Publicité
Poster une réponse
Anonyme