compter le nombre de cellules vides

Le
laurent.daures
Bonjour à toustes,
je n'arrive pas à me dépêtrer d'un problème que j'aimerais résoudre par une
formule faisant appel uniquement à des fonctions intégrées du genre NB.SI ou
SOMMEPROD, mais je n'y arrive pas.
Je sais résoudre ceci par une fonction personnalisée qui va rechercher les
cellules vides d'une ligne et ajouter 1 au compteur total. Mais cela
alourdit considérablement le fichier, qui rame lorsque la fonction
recalcule.

Donc, voici le problèmùe
Ligne 1 des cellules contenant des nombres correspondant au numéro de la
semaine, parfois un jour, (le dimanche) reste vide
ligne 2, des cellules remplies ou vides (absence ou présence).

Je voudrais que ma formule compte le nombre de cellules vides ligne 2 mais
uniquement celles dont la ligne 1 a une valeur inscrite. Total de jours de
présence pour résumer.

ligne 1 31 31 31 31 31 32 32 32 32 32 32 33 33 33 33 33 33
ligne 2 ca ca ca ca ca ca ca


ici, vous voyez qu'il y a 10 jours qui correspondent au critère, ligne 1
remplie, ligne 2 vide.
entre 31 et 32, il n'y a rien, entre 32 et 33 idem, donc on ne compte pas la
cellule ligne 2.

Voilà chers amis, un problème en apparence simple, mais qui me fatigue, et
vous savez qu'avec la chaleur qu'il fait par chez moi, on transpire vite. Ca
perturbe mes siestes.

En espérant une réponse qui apaisera mon angoisse,
bonne journée à tous et bonnes vacances
Amicalement
Siesting Hoax
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichDenis
Le #19865891
Bonjour Laurent,

Suggestion :
=SOMMEPROD(ESTNUM(A1:R1)*ESTVIDE(A2:R2))

| ici, vous voyez qu'il y a 10 jours qui correspondent
| au critère, ligne 1 remplie, ligne 2 vide.

***On ne voit pas la même chose, ou je ne suis pas encore
totolement réveillé. ;-)


ligne 1 31 31 31 31 31 32 32 32 32 32 32 33 33 33 33 33 33
ligne 2 ca ca ca ca ca ca ca

ici, vous voyez qu'il y a 10 jours qui correspondent au critère, ligne 1
remplie, ligne 2 vide.
entre 31 et 32, il n'y a rien, entre 32 et 33 idem, donc on ne compte pas la
cellule ligne 2.

Voilà chers amis, un problème en apparence simple, mais qui me fatigue, et
vous savez qu'avec la chaleur qu'il fait par chez moi, on transpire vite. Ca
perturbe mes siestes.

En espérant une réponse qui apaisera mon angoisse,
bonne journée à tous et bonnes vacances
Amicalement
Siesting Hoax
laurent.daures
Le #19865961
c'est exactement ça,
j'oubliais d'utiliser les fonction ESTNUM() ESTVIDE() en cherchant des
solutions tarabiscotées et inefficaces.

Merci Denis, toujours aussi performant, et le MPFE d'une qualité inégalable.

Amicalement
Siesting Hoax

"MichDenis" %
Bonjour Laurent,

Suggestion :
=SOMMEPROD(ESTNUM(A1:R1)*ESTVIDE(A2:R2))

| ici, vous voyez qu'il y a 10 jours qui correspondent
| au critère, ligne 1 remplie, ligne 2 vide.

***On ne voit pas la même chose, ou je ne suis pas encore
totolement réveillé. ;-)


ligne 1 31 31 31 31 31 32 32 32 32 32 32 33 33 33 33 33 33
ligne 2 ca ca ca ca ca ca ca

ici, vous voyez qu'il y a 10 jours qui correspondent au critère, ligne 1
remplie, ligne 2 vide.
entre 31 et 32, il n'y a rien, entre 32 et 33 idem, donc on ne compte pas
la
cellule ligne 2.

Voilà chers amis, un problème en apparence simple, mais qui me fatigue, et
vous savez qu'avec la chaleur qu'il fait par chez moi, on transpire vite.
Ca
perturbe mes siestes.

En espérant une réponse qui apaisera mon angoisse,
bonne journée à tous et bonnes vacances
Amicalement
Siesting Hoax



FS
Le #19915571
Bonsoir Laurent,

Autre approche possible (si je n'oublie rien) :

=NBVAL(A1:S1)-NBVAL(A2:S2)

FS
--
Frédéric SIGONNEAU
Modules et modèles pour Excel :
http://frederic.sigonneau.free.fr/

laurent.daures a écrit :
Bonjour à toustes,
je n'arrive pas à me dépêtrer d'un problème que j'aimerais résoudre par une
formule faisant appel uniquement à des fonctions intégrées du genre NB.SI ou
SOMMEPROD, mais je n'y arrive pas.
Je sais résoudre ceci par une fonction personnalisée qui va rechercher les
cellules vides d'une ligne et ajouter 1 au compteur total. Mais cela
alourdit considérablement le fichier, qui rame lorsque la fonction
recalcule.

Donc, voici le problèmùe
Ligne 1 des cellules contenant des nombres correspondant au numéro de la
semaine, parfois un jour, (le dimanche) reste vide
ligne 2, des cellules remplies ou vides (absence ou présence).

Je voudrais que ma formule compte le nombre de cellules vides ligne 2 mais
uniquement celles dont la ligne 1 a une valeur inscrite. Total de jours de
présence pour résumer.

ligne 1 31 31 31 31 31 32 32 32 32 32 32 33 33 33 33 33 33
ligne 2 ca ca ca ca ca ca ca


ici, vous voyez qu'il y a 10 jours qui correspondent au critère, ligne 1
remplie, ligne 2 vide.
entre 31 et 32, il n'y a rien, entre 32 et 33 idem, donc on ne compte pas la
cellule ligne 2.

Voilà chers amis, un problème en apparence simple, mais qui me fatigue, et
vous savez qu'avec la chaleur qu'il fait par chez moi, on transpire vite. Ca
perturbe mes siestes.

En espérant une réponse qui apaisera mon angoisse,
bonne journée à tous et bonnes vacances
Amicalement
Siesting Hoax







Publicité
Poster une réponse
Anonyme