Compter le nombre de pommes selon critère du mois

Le
Guido
Bonsoir à vous tous,

en colonne A, j'ai des pommes, des poires, des mandarines, etc
en colonne B, j'ai des dates (chacune différentes, selon le jour de la
cueillette)

comment compter le nombre de fois qu'une cellule contient le même mot,
mais uniquement selon le mois qui lui est connexe. par exemple :
combien de fois "Pomme" est inscrit pour le mois de "janvier" ?

merci de votre réponse
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michdenis
Le #21703021
Bonjour,

Les données débutant sur la ligne 2, ligne 1 réservée aux étiquettes de colonnes
Pour le mois de mai = 5 pour cinquième mois de l'année
Cette fonction ne tient pas compte de l'année seulement du mois

=SOMMEPROD((A2:A200="Pomme")*(MOIS(B2:B200)=5))

Pour tenir compte de l'année :
=SOMMEPROD((A2:A200="Pomme")*(MOIS(B2:B200)=5)*(ANNEE(B2:B200) 10))




"Guido"
Bonsoir à vous tous,

en colonne A, j'ai des pommes, des poires, des mandarines, etc...
en colonne B, j'ai des dates (chacune différentes, selon le jour de la
cueillette)

comment compter le nombre de fois qu'une cellule contient le même mot,
mais uniquement selon le mois qui lui est connexe. par exemple :
combien de fois "Pomme" est inscrit pour le mois de "janvier" ?

merci de votre réponse
Guido
Le #21703501
Merci MIchdenis

Cela marche au poil du tonnerre.

bonne soirée à toi

On 6 mai, 20:50, "michdenis"
Bonjour,

Les données débutant sur la ligne 2, ligne 1 réservée aux étiqu ettes de colonnes
Pour le mois de mai  = 5 pour cinquième mois de l'année
Cette fonction ne tient pas compte de l'année seulement du mois

=SOMMEPROD((A2:A200="Pomme")*(MOIS(B2:B200)=5))

Pour tenir compte de l'année :
=SOMMEPROD((A2:A200="Pomme")*(MOIS(B2:B200)=5)*(ANNEE(B2:B200) 10))

"Guido"
Bonsoir à vous tous,

en colonne A, j'ai des pommes, des poires, des mandarines, etc...
en colonne B, j'ai des dates (chacune différentes, selon le jour de la
cueillette)

comment compter le nombre de fois qu'une cellule contient le même mot,
mais uniquement selon le mois qui lui est connexe. par exemple :
combien de fois "Pomme" est inscrit pour le mois de "janvier"  ?

merci de votre réponse
Guido
Le #21793031
Bonjour Michdenis, Bonjour à vous tous,

J'ai un soucis avec la formule mentionnée plus haut.

Il s'agit donc de compter uniquement les pommes, si la cellule
comporte une date. Si la cellule avec la date est vide, il ne faut pas
compter les pommes.

merci de votre aide.





On 6 mai, 21:30, Guido
Merci MIchdenis

Cela marche au poil du tonnerre.

bonne soirée à toi

On 6 mai, 20:50, "michdenis"


> Bonjour,

> Les données débutant sur la ligne 2, ligne 1 réservée aux éti quettes de colonnes
> Pour le mois de mai  = 5 pour cinquième mois de l'année
> Cette fonction ne tient pas compte de l'année seulement du mois

> =SOMMEPROD((A2:A200="Pomme")*(MOIS(B2:B200)=5))

> Pour tenir compte de l'année :
> =SOMMEPROD((A2:A200="Pomme")*(MOIS(B2:B200)=5)*(ANNEE(B2:B200)= 2010))

> "Guido" >
> Bonsoir à vous tous,

> en colonne A, j'ai des pommes, des poires, des mandarines, etc...
> en colonne B, j'ai des dates (chacune différentes, selon le jour de l a
> cueillette)

> comment compter le nombre de fois qu'une cellule contient le même mot ,
> mais uniquement selon le mois qui lui est connexe. par exemple :
> combien de fois "Pomme" est inscrit pour le mois de "janvier"  ?

> merci de votre réponse- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -
Daniel.C
Le #21794721
Bonjour.
=SOMMEPROD((A1:A30="pomme")*(MOIS(B1:B30)=1)*(ANNEE(B1:B30) 10)*(B1:B30<>""))
Daniel

Bonjour Michdenis, Bonjour à vous tous,

J'ai un soucis avec la formule mentionnée plus haut.

Il s'agit donc de compter uniquement les pommes, si la cellule
comporte une date. Si la cellule avec la date est vide, il ne faut pas
compter les pommes.

merci de votre aide.





On 6 mai, 21:30, Guido
Merci MIchdenis

Cela marche au poil du tonnerre.

bonne soirée à toi

On 6 mai, 20:50, "michdenis"


Bonjour,



Les données débutant sur la ligne 2, ligne 1 réservée aux étiquettes de
colonnes Pour le mois de mai  = 5 pour cinquième mois de l'année
Cette fonction ne tient pas compte de l'année seulement du mois
=SOMMEPROD((A2:A200="Pomme")*(MOIS(B2:B200)=5))
Pour tenir compte de l'année :
=SOMMEPROD((A2:A200="Pomme")*(MOIS(B2:B200)=5)*(ANNEE(B2:B200) 10))
"Guido" discussion :

Bonsoir à vous tous,



en colonne A, j'ai des pommes, des poires, des mandarines, etc...
en colonne B, j'ai des dates (chacune différentes, selon le jour de la
cueillette)



comment compter le nombre de fois qu'une cellule contient le même mot,
mais uniquement selon le mois qui lui est connexe. par exemple :
combien de fois "Pomme" est inscrit pour le mois de "janvier"  ?
merci de votre réponse- Masquer le texte des messages précédents -



- Afficher le texte des messages précédents -
Guido
Le #21804921
Bonjour Daniel

merci pour l'info. C'est au poil.

Bon weekend



On 7 mai, 15:57, Daniel.C
Bonjour.
=SOMMEPROD((A1:A30="pomme")*(MOIS(B1:B30)=1)*(ANNEE(B1:B30) 10) *(B1:B30<>""))
Daniel

> Bonjour Michdenis, Bonjour à vous tous,

> J'ai un soucis avec la formule mentionnée plus haut.

> Il s'agit donc de compter uniquement les pommes, si la cellule
> comporte une date. Si la cellule avec la date est vide, il ne faut pas
> compter les pommes.

> merci de votre aide.

> On 6 mai, 21:30, Guido >> Merci MIchdenis

>> Cela marche au poil du tonnerre.

>> bonne soirée à toi

>> On 6 mai, 20:50, "michdenis"
>>> Bonjour,

>>> Les données débutant sur la ligne 2, ligne 1 réservée aux é tiquettes de
>>> colonnes Pour le mois de mai  = 5 pour cinquième mois de l'ann ée
>>> Cette fonction ne tient pas compte de l'année seulement du mois
>>> =SOMMEPROD((A2:A200="Pomme")*(MOIS(B2:B200)=5))
>>> Pour tenir compte de l'année :
>>> =SOMMEPROD((A2:A200="Pomme")*(MOIS(B2:B200)=5)*(ANNEE(B2:B200) 10))
>>> "Guido" >>> discussion :
>>>
>>> Bonsoir à vous tous,

>>> en colonne A, j'ai des pommes, des poires, des mandarines, etc...
>>> en colonne B, j'ai des dates (chacune différentes, selon le jour de la
>>> cueillette)

>>> comment compter le nombre de fois qu'une cellule contient le même m ot,
>>> mais uniquement selon le mois qui lui est connexe. par exemple :
>>> combien de fois "Pomme" est inscrit pour le mois de "janvier"  ?
>>> merci de votre réponse- Masquer le texte des messages précédent s -

>> - Afficher le texte des messages précédents -
Publicité
Poster une réponse
Anonyme