compter des valeurs dates uniques

Le
Michel
Bonjour à tous


j'aimerait compter dans une colonne le nombre de date différentes, en
l'occurence ici 4 dates (21-22-11-12)

Un grand merci de vos idées

Mike

exemples
21.10.2003
21.10.2003
22.10.2003
22.10.2003
22.10.2003
22.10.2003
22.10.2003
11.12.2003
12.01.2004
12.01.2004
12.01.2004
12.01.2004
12.01.2004

--
Ceci est une signature automatique de MesNews.
Site : http://www.mesnews.net
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #5047791
Bonjour,

=SOMMEPROD(1/(NB.SI(A1:A13;A1:A13)))
Ou plage nommée
=SOMMEPROD(1/(NB.SI(plage;plage)))
--
Salutations
JJ


"Michel"
Bonjour à tous


j'aimerait compter dans une colonne le nombre de date différentes, en
l'occurence ici 4 dates (21-22-11-12)

Un grand merci de vos idées

Mike

exemples
21.10.2003
21.10.2003
22.10.2003
22.10.2003
22.10.2003
22.10.2003
22.10.2003
11.12.2003
12.01.2004
12.01.2004
12.01.2004
12.01.2004
12.01.2004

--
Ceci est une signature automatique de MesNews.
Site : http://www.mesnews.net




Mike
Le #5047031
Bonjour,

Superbe, mais puis-je comprendre pourquoi cette division en répetant 2
fois la plage ???

Un grand merci

Mike
Bonjour,

=SOMMEPROD(1/(NB.SI(A1:A13;A1:A13)))
Ou plage nommée
=SOMMEPROD(1/(NB.SI(plage;plage)))
--
Salutations
JJ


"Michel"
Bonjour à tous


j'aimerait compter dans une colonne le nombre de date différentes, en
l'occurence ici 4 dates (21-22-11-12)

Un grand merci de vos idées

Mike

exemples
21.10.2003
21.10.2003
22.10.2003
22.10.2003
22.10.2003
22.10.2003
22.10.2003
11.12.2003
12.01.2004
12.01.2004
12.01.2004
12.01.2004
12.01.2004

-- Ceci est une signature automatique de MesNews.
Site : http://www.mesnews.net






Jacky
Le #5046971
Re....

Dans ton exemple :
Rappel:==>Nb.si(plage;critère)
NB.SI(A1:A13;A1:A13) ou =(NB.SI(plage;plage)))
Matricielle dans cette formule, retourne:
{2;2;5;5;5;5;5;1;5;5;5;5;5}
Mathématiquement on calcule l'inverse
1/(NB.SI(plage;plage)), ce qui donne
{0,5;0,5;0,2;0,2;0,2;0,2;0,2;1;0,2;0,2;0,2;0,2;0,2}
La somme de cette matrice (le boulot de SommeProd)
0,5+0,5+0,2+0,2+0,2+0,2+0,2+1+0,2+0,2+0,2+0,2+0,2
Donne 4, le résultat escompté
--
Salutations
JJ


"Mike"
Bonjour,

Superbe, mais puis-je comprendre pourquoi cette division en répetant 2
fois la plage ???

Un grand merci

Mike
Bonjour,

=SOMMEPROD(1/(NB.SI(A1:A13;A1:A13)))
Ou plage nommée
=SOMMEPROD(1/(NB.SI(plage;plage)))
--
Salutations
JJ


"Michel"
Bonjour à tous


j'aimerait compter dans une colonne le nombre de date différentes, en
l'occurence ici 4 dates (21-22-11-12)

Un grand merci de vos idées

Mike

exemples
21.10.2003
21.10.2003
22.10.2003
22.10.2003
22.10.2003
22.10.2003
22.10.2003
11.12.2003
12.01.2004
12.01.2004
12.01.2004
12.01.2004
12.01.2004

-- Ceci est une signature automatique de MesNews.
Site : http://www.mesnews.net










Publicité
Poster une réponse
Anonyme