Compter les valeurs uniques (sans doublon) d'une liste filtrée

Le
Sundow
Bonjour,

Je cherche à ramener en tête en A1 le nombre de valeurs uniques d'une
liste.

A cet effet j'ai trouvé les formules suivantes qui fonctionnent très
bien :

=SOMME(SI(FREQUENCE(A4:A12,A3:A12)>0,1))

ou

=SOMMEPROD(1/NB.SI(A4:A12;A3:A12))

Malheureusement aucune de ces deux formules ne sont sensibles au fait
que l'on filtre la liste.

Je cherche donc une formule ou fonction VBA qui permettrait de ramener
en A1 le nombre de valeurs uniques après filtrage (flèche de filtre
positionnée en A3).

Si quelqu'un à une idée, je le remercie par avance pour son aide.

S.
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #24043071
bonjour,

la liste est filtrée sur quel colonne et sur quel critère ?

--
isabelle
CFrofro
Le #24044841
On 7 déc, 15:22, Sundow
Bonjour,

Je cherche à ramener en tête en A1 le nombre de valeurs uniques d'une
liste.

A cet effet j'ai trouvé les formules suivantes qui fonctionnent très
bien :

=SOMME(SI(FREQUENCE(A4:A12,A3:A12)>0,1))

ou

=SOMMEPROD(1/NB.SI(A4:A12;A3:A12))

Malheureusement aucune de ces deux formules ne sont sensibles au fait
que l'on filtre la liste.

Je cherche donc une formule ou fonction VBA qui permettrait de ramener
en A1 le nombre de valeurs uniques après filtrage (flèche de filtre
positionnée en A3).

Si quelqu'un à une idée, je le remercie par avance pour son aide.

S.



La bonne formule est =SOMME(SI(FREQUENCE(A3:A12,A3:A12)>0,1))
On applique la fonction sur toute la zone comparée à elle même (A3
partout et pas a3 et A4).
Mais ça ne règle pas ton problème de filtre.
CFrofro
Jacquouille
Le #24045981
Bonjour Isabelle
As-tu reçu mon courriel en bal perso?
Si c'est non, peux-tu me contacter en perso, svp ?
merci et bonne fin de journée

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"isabelle" a écrit dans le message de groupe de discussion :
jboap2$2ve$

bonjour,

la liste est filtrée sur quel colonne et sur quel critère ?

--
isabelle
Sundow
Le #24048991
Bonjour Isabelle,
Merci pour ta réponse.
Je n'étais pas là hier et ne peux te répondre qu'aujourd'hui.
J'essaye de mettre en classeur en cijoint mais le site ne réponds
plus ?? En auriez-vous un autre à me conseiller ?
Voilà donc le problème en détail.
J'ai une table qui enregistre les heures d'arrivée et de départ de
personnes et qui calcule le temps travaillé.
Les étiquettes de la base sont les suivantes :

A : Mois (le mois est ramené depuis la date)
B: No (correspond au numéro de ligne+3 car la base commence en linge
3)
C : Nom Prénom (à saisir)
D : Date (à saisir)
E: Heure de début (à saisir)
F: Heure de fin (à saisir)
G: Total heures (calculé)

Le filtre est fait sur la colonne A (il s'agit d'un outil visant à
établir des salaires mensuels) et le nom de la personne (colonne C).
Je souhaiterais en D1 ramener le nombre de jours travaillés sachant
qu'il peut y avoir jusqu'à 3 enregistrements pour une personne et pour
une date donnée si la personne a travaillé le matin de 9 à 12:00 et
l'après midi de 14:00 à 18:00 et le soir de 21:00 à 0:00.
D'où la nécessité d'avoir une formule qui décompte les valeurs
uniques.
Merci d'avance si tu as une idée sur la chose.
Bien cordialement et bonne journée.
S.
Maude Este
Le #24049121
Bonsour®

"Sundow" a écrit
J'essaye de mettre en classeur en cijoint mais le site ne réponds
plus ?? En auriez-vous un autre à me conseiller ?

http://goo.gl/syyFO
isabelle
Le #24049731
bonjour Sundow,

je pense que la fonction SOMMEPROD est ce qu'il faut.
si tu as mis le critère Date en A1 et le critère Nom en C1

=SOMMEPROD((A3:A5000¡)*(C3:C5000Á))


--
isabelle



Le 2011-12-09 04:23, Sundow a écrit :

Bonjour Isabelle,
Merci pour ta réponse.
Je n'étais pas là hier et ne peux te répondre qu'aujourd'hui.
J'essaye de mettre en classeur en cijoint mais le site ne réponds
plus ?? En auriez-vous un autre à me conseiller ?
Voilà donc le problème en détail.
J'ai une table qui enregistre les heures d'arrivée et de départ de
personnes et qui calcule le temps travaillé.
Les étiquettes de la base sont les suivantes :

A : Mois (le mois est ramené depuis la date)
B: No (correspond au numéro de ligne+3 car la base commence en linge
3)
C : Nom Prénom (à saisir)
D : Date (à saisir)
E: Heure de début (à saisir)
F: Heure de fin (à saisir)
G: Total heures (calculé)

Le filtre est fait sur la colonne A (il s'agit d'un outil visant à
établir des salaires mensuels) et le nom de la personne (colonne C).
Je souhaiterais en D1 ramener le nombre de jours travaillés sachant
qu'il peut y avoir jusqu'à 3 enregistrements pour une personne et pour
une date donnée si la personne a travaillé le matin de 9 à 12:00 et
l'après midi de 14:00 à 18:00 et le soir de 21:00 à 0:00.
D'où la nécessité d'avoir une formule qui décompte les valeurs
uniques.
Merci d'avance si tu as une idée sur la chose.
Bien cordialement et bonne journée.
S.
Sundow
Le #24049721
Bonjour Maude Este,

Merci pour ce site mais ça ne fonctionne pas non plus.

http://goo.gl/syyFO

S.
Maude Este
Le #24049971
Bonsour®

"Sundow" a écrit
Merci pour ce site mais ça ne fonctionne pas non plus.
http://goo.gl/syyFO



??????
Sundow
Le #24050221
Bonjour Isabelle,

Merci beaucoup pour la proposition, mais non malheureusement cela ne
fonctionne pas.

Voilà un lien image (c'est tout ce que j'ai trouvé) pour mieux
comprendre : http://up-master.com/data/comptageJours_0.jpg

Le but est de placer en D1 cellule rouge une formule qui dénombre les
valeurs uniques de la colonne/plage D4:D5000 (sachant que la plage en
question a été filtrée et que l'on veut dénombrer les valeur unique s
filtrées)

2 filtres ont été fait sur la base originale, un sur les mois (colonne
A) pour isoler le mois de novembre et l'autre sur le Nom Prénom
(colonne D) pour isoler l'individu A.

Voilà, merci d'avance pour ta/vos suggestion(s).

S.



On 9 déc, 14:21, isabelle
bonjour Sundow,

je pense que la fonction SOMMEPROD est ce qu'il faut.
si tu as mis le critère Date en A1 et le critère Nom en C1

=SOMMEPROD((A3:A5000¡)*(C3:C5000Á))

--
isabelle

Le 2011-12-09 04:23, Sundow a écrit :





> Bonjour Isabelle,
> Merci pour ta réponse.
> Je n'étais pas là hier et ne peux te répondre qu'aujourd'hui.
> J'essaye de mettre en classeur en cijoint mais le site ne réponds
> plus ?? En auriez-vous un autre à me conseiller ?
> Voilà donc le problème en détail.
> J'ai une table qui enregistre les heures d'arrivée et de départ de
> personnes et qui calcule le temps travaillé.
> Les étiquettes de la base sont les suivantes :

> A : Mois (le mois est ramené depuis la date)
> B: No (correspond au numéro de ligne+3 car la base commence en linge
> 3)
> C : Nom Prénom (à saisir)
> D : Date (à saisir)
> E: Heure de début (à saisir)
> F: Heure de fin (à saisir)
> G: Total heures (calculé)

> Le filtre est fait sur la colonne A (il s'agit d'un outil visant à
> établir des salaires mensuels) et le nom de la personne (colonne C).
> Je souhaiterais en D1 ramener le nombre de jours travaillés sachant
> qu'il peut y avoir jusqu'à 3 enregistrements pour une personne et pou r
> une date donnée si la personne a travaillé le matin de 9 à 12:00 et
> l'après midi de 14:00 à 18:00 et le soir de 21:00 à 0:00.
> D'où la nécessité d'avoir une formule qui décompte les valeurs
> uniques.
> Merci d'avance si tu as une idée sur la chose.
> Bien cordialement et bonne journée.
> S.- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -
Sundow
Le #24050061
Bonjoir,


Ben que je suive le lien en cliquant dessus ou en le copiant dans la
barre d'adresse de mon Explorer j'ai une redirection qui se fait sur
la page de log de hotmail.

Pour ci-joint je tombe sur une page blanche.

Voilà voilà - Sundow

On 9 déc, 15:43, "Maude Este"
Bonsour®

"Sundow"  a écrit

> Merci pour ce site mais ça ne fonctionne pas non plus.
>http://goo.gl/syyFO

??????
Publicité
Poster une réponse
Anonyme