Condition imbriquée

Le
Dominique
Bonsoir le forum

mon niveau excel est dépassé par une formule de SI imbriqué; quelqu'un
peut il m aider?

si(AA15=1;
si(Y15-(Y15*$B$4/100)>$B$10;H15/100*$B$10;X15-(X15*$B$4/100)

si(AA15=0;
si(Y15>$B$10;H15/100*$B$10;X15)

j'explique AA15 ne peut avoir que la valeur 0 ou 1

si AA15 =1 et que Y15-(Y15*$B$4/100)>$B$10 alors H15/100*B10 mais si
AA15=1 et que Y15-(Y15*$B$4/100)<$B$10 alors X15-(X15*$B$4/100)

mais si AA15=0 et que Y15>$B$10 alors H15/100*$B$10 mais si AA15=0 et
que Y15<$B$10 alors X15

tout ceci avec arrondi (..;0)
et
esterreur (;"0";)

voila pas facile j ai du mal
merci d'avance
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Corona
Le #19984511
Bonjour Dominique,
=SI(AA15=1;SI(Y15-(Y15*$B$4/100) > $B$10; H15/100 * $B$10;
X15-(X15*$B$4/100));SI(Y15>$B$10;H15/100*$B$10;X15))
ou (puisqu'AA15 ne peux valoir que 1 ou 0)
=SI(AA15;SI(Y15-(Y15*$B$4/100) > $B$10; H15/100 * $B$10;
X15-(X15*$B$4/100));SI(Y15>$B$10;H15/100*$B$10;X15))
Il y a peut-être moyen de faire plus court
Bonne journée
Philippe Tulliez

Dominique a écrit :
Bonsoir le forum

mon niveau excel est dépassé par une formule de SI imbriqué; quelqu'un
peut il m aider?

si(AA15=1;
si(Y15-(Y15*$B$4/100)>$B$10;H15/100*$B$10;X15-(X15*$B$4/100)

si(AA15=0;
si(Y15>$B$10;H15/100*$B$10;X15)

j'explique AA15 ne peut avoir que la valeur 0 ou 1

si AA15 =1 et que Y15-(Y15*$B$4/100)>$B$10 alors H15/100*B10 mais si
AA15=1 et que Y15-(Y15*$B$4/100)<$B$10 alors X15-(X15*$B$4/100)

mais si AA15=0 et que Y15>$B$10 alors H15/100*$B$10 mais si AA15=0 et
que Y15<$B$10 alors X15

tout ceci avec arrondi (..;0)
et
esterreur (...;"0";...)

voila pas facile j ai du mal
merci d'avance


Corona
Le #19984611
Désolé, mal lu ta question
Ma réponse n'est pas correcte
Corona a écrit :
Bonjour Dominique,
=SI(AA15=1;SI(Y15-(Y15*$B$4/100) > $B$10; H15/100 * $B$10;
X15-(X15*$B$4/100));SI(Y15>$B$10;H15/100*$B$10;X15))
ou (puisqu'AA15 ne peux valoir que 1 ou 0)
=SI(AA15;SI(Y15-(Y15*$B$4/100) > $B$10; H15/100 * $B$10;
X15-(X15*$B$4/100));SI(Y15>$B$10;H15/100*$B$10;X15))
Il y a peut-être moyen de faire plus court
Bonne journée
Philippe Tulliez

Dominique a écrit :
Bonsoir le forum

mon niveau excel est dépassé par une formule de SI imbriqué; quelqu'un
peut il m aider?

si(AA15=1;
si(Y15-(Y15*$B$4/100)>$B$10;H15/100*$B$10;X15-(X15*$B$4/100)

si(AA15=0;
si(Y15>$B$10;H15/100*$B$10;X15)

j'explique AA15 ne peut avoir que la valeur 0 ou 1

si AA15 =1 et que Y15-(Y15*$B$4/100)>$B$10 alors H15/100*B10 mais si
AA15=1 et que Y15-(Y15*$B$4/100)<$B$10 alors X15-(X15*$B$4/100)

mais si AA15=0 et que Y15>$B$10 alors H15/100*$B$10 mais si AA15=0 et
que Y15<$B$10 alors X15

tout ceci avec arrondi (..;0)
et
esterreur (...;"0";...)

voila pas facile j ai du mal
merci d'avance




MichDenis
Le #19985111
Bonjour Dominique :

Et si tu essayais ceci :
(pas testé)
=SI(ET(AA15=1;Y15-(Y15*$B$4/100)>$B$10);H15/100*B10;SI(ET(AA15=1;Y15-(Y15*$B$4/100)<$B$10);X15-(X15*$B$4/100);SI(Y15>$B$10;H15/100*$B$10;SI(Y15<$B$10;X15))))

Il y a aussi ceci :

=SI(ET(AA15=1;Y15-(Y15*$B$4/100)>$B$10);H15/100*B10;SI(ET(AA15=1;Y15-(Y15*$B$4/100)<$B$10);X15-(X15*$B$4/100);SI(ET(AA15=0;Y15>$B$10);H15/100*$B$10;SI(ET(AA15=0;Y15<$B$10);
X15;""))))



"Dominique" #
Bonsoir le forum

mon niveau excel est dépassé par une formule de SI imbriqué; quelqu'un
peut il m aider?

si(AA15=1;
si(Y15-(Y15*$B$4/100)>$B$10;H15/100*$B$10;X15-(X15*$B$4/100)

si(AA15=0;
si(Y15>$B$10;H15/100*$B$10;X15)

j'explique AA15 ne peut avoir que la valeur 0 ou 1

si AA15 =1 et que Y15-(Y15*$B$4/100)>$B$10 alors H15/100*B10 mais si
AA15=1 et que Y15-(Y15*$B$4/100)<$B$10 alors X15-(X15*$B$4/100)

mais si AA15=0 et que Y15>$B$10 alors H15/100*$B$10 mais si AA15=0 et
que Y15<$B$10 alors X15

tout ceci avec arrondi (..;0)
et
esterreur (...;"0";...)

voila pas facile j ai du mal
merci d'avance
MichDenis
Le #19986221
Pour tenir compte de la gestion d'erreur et de l'arrondi de la réponse :

=ARRONDI(SI(ESTERREUR(SI(ET(AA15=1;Y15-(Y15*$B$4/100)>$B$10);H15/100*B10;SI(ET(AA15=1;Y15-(Y15*$B$4/100)<$B$10);X15-(X15*$B$4/100);SI(ET(AA15=0;Y15>$B$10);H15/100*$B$10;SI(ET(AA15=0;Y15<$B$10);
X15;0)))));0;SI(ET(AA15=1;Y15-(Y15*$B$4/100)>$B$10);H15/100*B10;SI(ET(AA15=1;Y15-(Y15*$B$4/100)<$B$10);X15-(X15*$B$4/100);SI(ET(AA15=0;Y15>$B$10);H15/100*$B$10;SI(ET(AA15=0;Y15<$B$10);
X15;0)))));0)



"MichDenis"
Bonjour Dominique :

Et si tu essayais ceci :
(pas testé)
=SI(ET(AA15=1;Y15-(Y15*$B$4/100)>$B$10);H15/100*B10;SI(ET(AA15=1;Y15-(Y15*$B$4/100)<$B$10);X15-(X15*$B$4/100);SI(Y15>$B$10;H15/100*$B$10;SI(Y15<$B$10;X15))))

Il y a aussi ceci :

=SI(ET(AA15=1;Y15-(Y15*$B$4/100)>$B$10);H15/100*B10;SI(ET(AA15=1;Y15-(Y15*$B$4/100)<$B$10);X15-(X15*$B$4/100);SI(ET(AA15=0;Y15>$B$10);H15/100*$B$10;SI(ET(AA15=0;Y15<$B$10);
X15;""))))



"Dominique" #
Bonsoir le forum

mon niveau excel est dépassé par une formule de SI imbriqué; quelqu'un
peut il m aider?

si(AA15=1;
si(Y15-(Y15*$B$4/100)>$B$10;H15/100*$B$10;X15-(X15*$B$4/100)

si(AA15=0;
si(Y15>$B$10;H15/100*$B$10;X15)

j'explique AA15 ne peut avoir que la valeur 0 ou 1

si AA15 =1 et que Y15-(Y15*$B$4/100)>$B$10 alors H15/100*B10 mais si
AA15=1 et que Y15-(Y15*$B$4/100)<$B$10 alors X15-(X15*$B$4/100)

mais si AA15=0 et que Y15>$B$10 alors H15/100*$B$10 mais si AA15=0 et
que Y15<$B$10 alors X15

tout ceci avec arrondi (..;0)
et
esterreur (...;"0";...)

voila pas facile j ai du mal
merci d'avance
Sam
Le #19988711
Bonjour,
sauf erreur de ma part, en utilisant le fait que AA15 = 0 ou 1, on pourrait
simplifier ainsi :
=SI(Y15-AA15*Y15*$B$4/100>$B$10 ;H15/100*B10;X15-AA15*X15*$B$4/100)
il faut ensuite rajouter l'arrondi et le Esterreur
Cordialement
Michel dit "Sam"

"Dominique" %
Bonsoir le forum

mon niveau excel est dépassé par une formule de SI imbriqué; quelqu'un
peut il m aider?

si(AA15=1;
si(Y15-(Y15*$B$4/100)>$B$10;H15/100*$B$10;X15-(X15*$B$4/100)

si(AA15=0;
si(Y15>$B$10;H15/100*$B$10;X15)

j'explique AA15 ne peut avoir que la valeur 0 ou 1

si AA15 =1 et que Y15-(Y15*$B$4/100)>$B$10 alors H15/100*B10 mais si
AA15=1 et que Y15-(Y15*$B$4/100)<$B$10 alors X15-(X15*$B$4/100)

mais si AA15=0 et que Y15>$B$10 alors H15/100*$B$10 mais si AA15=0 et que
Y15<$B$10 alors X15

tout ceci avec arrondi (..;0)
et
esterreur (...;"0";...)

voila pas facile j ai du mal
merci d'avance


Dominique
Le #19988831
bonjour
excusez moi je ne pouvez consulter mes news aujourd'hui voila ce que
j'ai fait en prenant la fonction choisir et ca marche
=SI(ESTERREUR(CHOISIR(AA15+1;
SI(Y15>$B$10;ARRONDI(H15/100*$B$10;0);ARRONDI(X15;0));
SI(Y15-(Y15*$B$4/100)>$B$10;ARRONDI(H15/100*$B$10;0);ARRONDI(X15-(X15*$B$4/100);0))));"oups";CHOISIR(AA15+1;
SI(Y15>$B$10;ARRONDI(H15/100*$B$10;0);ARRONDI(X15;0));
SI(Y15-(Y15*$B$4/100)>$B$10;ARRONDI(H15/100*$B$10;0);ARRONDI(X15-(X15*$B$4/100);0))))
merci pour vos nombreux conseils
Sam
Le #19989451
Bonjour,
en tenant compte de l'arrondi et du test d'erreur, ça pourrait donner :
=ARRONDI(SI(ESTERREUR(AA15*Y15*B4*B10*H15*X15);"oups";SI(Y15-AA15*Y15*$B$4/100>$B$10;H15/100*B10;X15-AA15*X15*$B$4/100));0)

Cordialement
Michel dit "Sam"

"Sam" 4a94162c$0$23486$
Bonjour,
sauf erreur de ma part, en utilisant le fait que AA15 = 0 ou 1, on
pourrait simplifier ainsi :
=SI(Y15-AA15*Y15*$B$4/100>$B$10 ;H15/100*B10;X15-AA15*X15*$B$4/100)
il faut ensuite rajouter l'arrondi et le Esterreur
Cordialement
Michel dit "Sam"

"Dominique" %
Bonsoir le forum

mon niveau excel est dépassé par une formule de SI imbriqué; quelqu'un
peut il m aider?

si(AA15=1;
si(Y15-(Y15*$B$4/100)>$B$10;H15/100*$B$10;X15-(X15*$B$4/100)

si(AA15=0;
si(Y15>$B$10;H15/100*$B$10;X15)

j'explique AA15 ne peut avoir que la valeur 0 ou 1

si AA15 =1 et que Y15-(Y15*$B$4/100)>$B$10 alors H15/100*B10 mais si
AA15=1 et que Y15-(Y15*$B$4/100)<$B$10 alors X15-(X15*$B$4/100)

mais si AA15=0 et que Y15>$B$10 alors H15/100*$B$10 mais si AA15=0 et
que Y15<$B$10 alors X15

tout ceci avec arrondi (..;0)
et
esterreur (...;"0";...)

voila pas facile j ai du mal
merci d'avance






Sam
Le #19989511
ou plutôt
=SI(ESTNUM(AA15*Y15*B4*B10*H15*X15);ARRONDI(SI(Y15-AA15*Y15*$B$4/100>$B$10;H15/100*B10;X15-AA15*X15*$B$4/100);0);"oups")
Cordialement
Michel dit "Sam"

"Sam" 4a943337$0$12627$

Bonjour,
en tenant compte de l'arrondi et du test d'erreur, ça pourrait donner :
=ARRONDI(SI(ESTERREUR(AA15*Y15*B4*B10*H15*X15);"oups";SI(Y15-AA15*Y15*$B$4/100>$B$10;H15/100*B10;X15-AA15*X15*$B$4/100));0)

Cordialement
Michel dit "Sam"

"Sam" 4a94162c$0$23486$
Bonjour,
sauf erreur de ma part, en utilisant le fait que AA15 = 0 ou 1, on
pourrait simplifier ainsi :
=SI(Y15-AA15*Y15*$B$4/100>$B$10 ;H15/100*B10;X15-AA15*X15*$B$4/100)
il faut ensuite rajouter l'arrondi et le Esterreur
Cordialement
Michel dit "Sam"

"Dominique" %
Bonsoir le forum

mon niveau excel est dépassé par une formule de SI imbriqué; quelqu'un
peut il m aider?

si(AA15=1;
si(Y15-(Y15*$B$4/100)>$B$10;H15/100*$B$10;X15-(X15*$B$4/100)

si(AA15=0;
si(Y15>$B$10;H15/100*$B$10;X15)

j'explique AA15 ne peut avoir que la valeur 0 ou 1

si AA15 =1 et que Y15-(Y15*$B$4/100)>$B$10 alors H15/100*B10 mais si
AA15=1 et que Y15-(Y15*$B$4/100)<$B$10 alors X15-(X15*$B$4/100)

mais si AA15=0 et que Y15>$B$10 alors H15/100*$B$10 mais si AA15=0 et
que Y15<$B$10 alors X15

tout ceci avec arrondi (..;0)
et
esterreur (...;"0";...)

voila pas facile j ai du mal
merci d'avance










Sam
Le #19989581
Bonjour,
avec cette formule, j'ai mis du texte en B4, B10, X15, Y15, et Excel me dit
que tout va bien
Cordialement
Michel dit "Sam"

"Dominique" %

bonjour
excusez moi je ne pouvez consulter mes news aujourd'hui voila ce que j'ai
fait en prenant la fonction choisir et ca marche
=SI(ESTERREUR(CHOISIR(AA15+1;
SI(Y15>$B$10;ARRONDI(H15/100*$B$10;0);ARRONDI(X15;0));
SI(Y15-(Y15*$B$4/100)>$B$10;ARRONDI(H15/100*$B$10;0);ARRONDI(X15-(X15*$B$4/100);0))));"oups";CHOISIR(AA15+1;
SI(Y15>$B$10;ARRONDI(H15/100*$B$10;0);ARRONDI(X15;0));
SI(Y15-(Y15*$B$4/100)>$B$10;ARRONDI(H15/100*$B$10;0);ARRONDI(X15-(X15*$B$4/100);0))))
merci pour vos nombreux conseils


Dominique
Le #19989741
que de possibilité merci a tous
Publicité
Poster une réponse
Anonyme