condition qui ne teste rien

Le
Circé
Hello tout le monde ! ;)

Une question de curiosité
Je récupère un classeur avec des formules SI qui m'étonnent sans
doute parce que je n'ai jamais fait comme ça : un SI sans critère
clair.

Exemple :

=SI('Base'!&B10;valeur_si_vrai;valeur_si_faux)


D'après mes tests, je comprends que le critère est une cellule qui
contient du numérique et qui n'est pas 0.
Est-ce que c'est bien ça ?
Est-ce que c'est "officiel" comme critère ?

Merci pour vos lumières.

m@rina
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
FdeCourt
Le #20663601
Salut,

Cela va tester si la cellule est égale à 0 (faux) ou 1 (vrai (ou
supérieure à 1)), ou si elle est égal à VRAI ou FAUX.

Cordialement,

F.
jero
Le #20663731
Salut,
En fait il faut savoir que VRAI signifie (pour la plupart des logiciels et
des langages de programmaation) différent de zéro.
Donc, la syntaxe est correcte.
Fais le test suivant :
en A1, tu écris 10
en A2, rien
en B1, tu écris : =SI(A1;"Bravo";"Perdu")
tu recopie en B2 (ça donne : =SI(A2;"Bravo";"Perdu")
regarde les résultats : en B1=>Bravo et en B2 =>perdu
Ok ?
A+

"Circé"
Hello tout le monde ! ;)

Une question de curiosité...
Je récupère un classeur avec des formules SI qui m'étonnent... sans doute
parce que je n'ai jamais fait comme ça : un SI sans critère clair.

Exemple :

=SI('Base'!&B10;valeur_si_vrai;valeur_si_faux)


D'après mes tests, je comprends que le critère est une cellule qui
contient du numérique et qui n'est pas 0.
Est-ce que c'est bien ça ?
Est-ce que c'est "officiel" comme critère ?

Merci pour vos lumières.






Circé
Le #20664011
OK ! ;)
Merci à tous les deux...

Circé
http://faqword.com

Dans son message précédent, jero a écrit :
Salut,
En fait il faut savoir que VRAI signifie (pour la plupart des logiciels et
des langages de programmaation) différent de zéro.
Donc, la syntaxe est correcte.
Fais le test suivant :
en A1, tu écris 10
en A2, rien
en B1, tu écris : =SI(A1;"Bravo";"Perdu")
tu recopie en B2 (ça donne : =SI(A2;"Bravo";"Perdu")
regarde les résultats : en B1=>Bravo et en B2 =>perdu
Ok ?
A+

"Circé"
Hello tout le monde ! ;)

Une question de curiosité...
Je récupère un classeur avec des formules SI qui m'étonnent... sans doute
parce que je n'ai jamais fait comme ça : un SI sans critère clair.

Exemple :

=SI('Base'!&B10;valeur_si_vrai;valeur_si_faux)


D'après mes tests, je comprends que le critère est une cellule qui contient
du numérique et qui n'est pas 0.
Est-ce que c'est bien ça ?
Est-ce que c'est "officiel" comme critère ?

Merci pour vos lumières.








Publicité
Poster une réponse
Anonyme