Conditions multiples

Le
Michel B
Bonjour a toutes et à tous,

je dois compter les enregistrements correspondant à plusieurs critéres : A =
N ou X et Age 

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

cela fonctionne impec.

Mais il faut que je ne compte que les enregistrements comportant A = N ou X
et Z= X et Age +18
j'ai modifié comme cela :

=SOMMEPROD((((ET(Licenciés!A2:A3000="N")+(Licenciés!Z2:Z3000="X"))+((ET(Licenciés!A2:A3000="X")+(Licenciés!Z2:Z3000="X"))))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

et

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(((Licenciés!Z2:Z3000="X")*OU(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))))

les résultats sont faux, je debute en VBA, une petite explication serait la
bien venue.

D'avance merci
Michel
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #16686381
Bonjour.
=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z="X"))
En remplaçant Z par la plage voulue.
Cordialement.
Daniel
"Michel B" 48bbb0eb$0$11228$
Bonjour a toutes et à tous,

je dois compter les enregistrements correspondant à plusieurs critéres : A
= N ou X et Age 

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

cela fonctionne impec.

Mais il faut que je ne compte que les enregistrements comportant A = N ou
X et Z= X et Age +18
j'ai modifié comme cela :

=SOMMEPROD((((ET(Licenciés!A2:A3000="N")+(Licenciés!Z2:Z3000="X"))+((ET(Licenciés!A2:A3000="X")+(Licenciés!Z2:Z3000="X"))))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

et

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(((Licenciés!Z2:Z3000="X")*OU(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))))

les résultats sont faux, je debute en VBA, une petite explication serait
la bien venue.

D'avance merci
Michel





zimou
Le #16688631
Bonjour,
si tu as Excel 2007 utilises la fonction "=sommesiens()"
amicalement

"Michel B" discussion : 48bbb0eb$0$11228$
Bonjour a toutes et à tous,

je dois compter les enregistrements correspondant à plusieurs critéres : A
= N ou X et Age 

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

cela fonctionne impec.

Mais il faut que je ne compte que les enregistrements comportant A = N ou
X et Z= X et Age +18
j'ai modifié comme cela :

=SOMMEPROD((((ET(Licenciés!A2:A3000="N")+(Licenciés!Z2:Z3000="X"))+((ET(Licenciés!A2:A3000="X")+(Licenciés!Z2:Z3000="X"))))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

et

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(((Licenciés!Z2:Z3000="X")*OU(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))))

les résultats sont faux, je debute en VBA, une petite explication serait
la bien venue.

D'avance merci
Michel





Michel B
Le #16689751
Bonsoir

la formule :

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z2:Z3000="X"))


sur ce tableau la formule devrais trouvé 2 enregistrements pratiquant
Inscrit N ou X de plus de 18 ans.
Je reçois un message d'erreur : #VALEUR


A
F
Z

Inscrit
Date_Naissance
Pratiquant

X
31/01/1999
X

X
09/02/1943
X

X
17/11/1957


N
02/09/2001
X

N
12/07/2002
X

N
05/08/1947


N
01/10/1965
X




Je ne suis pas sous excel 2007
D'avance merci pour le coup de main

Michel


"Daniel.C"
Bonjour.
=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z="X"))
En remplaçant Z par la plage voulue.
Cordialement.
Daniel
"Michel B" 48bbb0eb$0$11228$
Bonjour a toutes et à tous,

je dois compter les enregistrements correspondant à plusieurs critéres :
A = N ou X et Age 

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

cela fonctionne impec.

Mais il faut que je ne compte que les enregistrements comportant A = N ou
X et Z= X et Age +18
j'ai modifié comme cela :

=SOMMEPROD((((ET(Licenciés!A2:A3000="N")+(Licenciés!Z2:Z3000="X"))+((ET(Licenciés!A2:A3000="X")+(Licenciés!Z2:Z3000="X"))))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

et

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(((Licenciés!Z2:Z3000="X")*OU(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))))

les résultats sont faux, je debute en VBA, une petite explication serait
la bien venue.

D'avance merci
Michel









Misange
Le #16690381
Bonjour

La formule fonctionne tout à fait chez moi et avec ton exemple elle
renvoie 2 comme attendu. MAIS : j'avais copié collé tes données et
obtenu le même résultat que toi : #VALEUR!. Il a fallu que je les
resaisisse pour que cela marche : dates pas reconnues comme telles (un
grand classique du copié collé) et plus bizarrement X et N pas reconnus
comme des lettres. Regarde si ça fait pareil dans ton classeur et dis nous.

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Michel B a écrit :
Bonsoir

la formule :

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z2:Z3000="X"))


sur ce tableau la formule devrais trouvé 2 enregistrements pratiquant
Inscrit N ou X de plus de 18 ans.
Je reçois un message d'erreur : #VALEUR


A
F
Z

Inscrit
Date_Naissance
Pratiquant

X
31/01/1999
X

X
09/02/1943
X

X
17/11/1957


N
02/09/2001
X

N
12/07/2002
X

N
05/08/1947


N
01/10/1965
X




Je ne suis pas sous excel 2007
D'avance merci pour le coup de main

Michel


"Daniel.C"
Bonjour.
=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z="X"))
En remplaçant Z par la plage voulue.
Cordialement.
Daniel
"Michel B" 48bbb0eb$0$11228$
Bonjour a toutes et à tous,

je dois compter les enregistrements correspondant à plusieurs critéres :
A = N ou X et Age 

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

cela fonctionne impec.

Mais il faut que je ne compte que les enregistrements comportant A = N ou
X et Z= X et Age +18
j'ai modifié comme cela :

=SOMMEPROD((((ET(Licenciés!A2:A3000="N")+(Licenciés!Z2:Z3000="X"))+((ET(Licenciés!A2:A3000="X")+(Licenciés!Z2:Z3000="X"))))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

et

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(((Licenciés!Z2:Z3000="X")*OU(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))))

les résultats sont faux, je debute en VBA, une petite explication serait
la bien venue.

D'avance merci
Michel












Michel B
Le #16690641
Oups, le tableau n'était pas passé !

la formule :

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z2:Z3000="X"))


sur ce tableau la formule devrais trouvé 2 enregistrements pratiquant
Inscrit N ou X de plus de 18 ans.
Je reçois un message d'erreur : #VALEUR


A F Z
Inscrit Date_Naissance Pratiquant

X 31/01/1999 X
X 09/02/1943 X
X 17/11/1957
N 02/09/2001 X
N 12/07/2002 X
N 01/10/1965 X

Je ne suis pas sous excel 2007
D'avance merci pour le coup de main

Michel

"Michel B" 48bc095f$0$17347$
Bonsoir

la formule :

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z2:Z3000="X"))


sur ce tableau la formule devrais trouvé 2 enregistrements pratiquant
Inscrit N ou X de plus de 18 ans.
Je reçois un message d'erreur : #VALEUR


A
F
Z

Inscrit
Date_Naissance
Pratiquant

X
31/01/1999
X

X
09/02/1943
X

X
17/11/1957


N
02/09/2001
X

N
12/07/2002
X

N
05/08/1947


N
01/10/1965
X




Je ne suis pas sous excel 2007
D'avance merci pour le coup de main

Michel


"Daniel.C"
Bonjour.
=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z="X"))
En remplaçant Z par la plage voulue.
Cordialement.
Daniel
"Michel B" 48bbb0eb$0$11228$
Bonjour a toutes et à tous,

je dois compter les enregistrements correspondant à plusieurs critéres :
A = N ou X et Age 

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

cela fonctionne impec.

Mais il faut que je ne compte que les enregistrements comportant A = N
ou X et Z= X et Age +18
j'ai modifié comme cela :

=SOMMEPROD((((ET(Licenciés!A2:A3000="N")+(Licenciés!Z2:Z3000="X"))+((ET(Licenciés!A2:A3000="X")+(Licenciés!Z2:Z3000="X"))))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

et

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(((Licenciés!Z2:Z3000="X")*OU(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))))

les résultats sont faux, je debute en VBA, une petite explication serait
la bien venue.

D'avance merci
Michel













Michel B
Le #16690621
Bonsoir,

la formule :
=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z2:Z3000="X"))

A F Z
Inscrit Date_Naissance Pratiquant

X 31/01/1999 X
X 09/02/1943 X
X 17/11/1957
N 02/09/2001 X
N 12/07/2002 X
N 01/10/1965 X


renvoie toujours l'erreur

Il s'agit d'import Access, les colonnes A et Z sont au format "Standard" et
F au format "Date".
Tout fonctionnait bien tant que je n'avais pas besoin de la colonne Z
Comme en plus je ne connais pas trés bien la rédaction des formules, je suis
paumé.

Encore merci pour l'aide

Michel


"Misange"
Bonjour

La formule fonctionne tout à fait chez moi et avec ton exemple elle
renvoie 2 comme attendu. MAIS : j'avais copié collé tes données et obtenu
le même résultat que toi : #VALEUR!. Il a fallu que je les resaisisse pour
que cela marche : dates pas reconnues comme telles (un grand classique du
copié collé) et plus bizarrement X et N pas reconnus comme des lettres.
Regarde si ça fait pareil dans ton classeur et dis nous.

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Michel B a écrit :
Bonsoir

la formule :

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z2:Z3000="X"))


sur ce tableau la formule devrais trouvé 2 enregistrements pratiquant
Inscrit N ou X de plus de 18 ans.
Je reçois un message d'erreur : #VALEUR


A
F
Z

Inscrit
Date_Naissance
Pratiquant

X
31/01/1999
X

X
09/02/1943
X

X
17/11/1957


N
02/09/2001
X

N
12/07/2002
X

N
05/08/1947


N
01/10/1965
X




Je ne suis pas sous excel 2007
D'avance merci pour le coup de main

Michel


"Daniel.C"
Bonjour.
=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z="X"))
En remplaçant Z par la plage voulue.
Cordialement.
Daniel
"Michel B" 48bbb0eb$0$11228$
Bonjour a toutes et à tous,

je dois compter les enregistrements correspondant à plusieurs critéres
: A = N ou X et Age 

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

cela fonctionne impec.

Mais il faut que je ne compte que les enregistrements comportant A = N
ou X et Z= X et Age +18
j'ai modifié comme cela :

=SOMMEPROD((((ET(Licenciés!A2:A3000="N")+(Licenciés!Z2:Z3000="X"))+((ET(Licenciés!A2:A3000="X")+(Licenciés!Z2:Z3000="X"))))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

et

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(((Licenciés!Z2:Z3000="X")*OU(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))))

les résultats sont faux, je debute en VBA, une petite explication
serait la bien venue.

D'avance merci
Michel













Misange
Le #16690611
voir ma réponse :-)

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Michel B a écrit :
Oups, le tableau n'était pas passé !

la formule :

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z2:Z3000="X"))


sur ce tableau la formule devrais trouvé 2 enregistrements pratiquant
Inscrit N ou X de plus de 18 ans.
Je reçois un message d'erreur : #VALEUR


A F Z
Inscrit Date_Naissance Pratiquant

X 31/01/1999 X
X 09/02/1943 X
X 17/11/1957
N 02/09/2001 X
N 12/07/2002 X
N 01/10/1965 X

Je ne suis pas sous excel 2007
D'avance merci pour le coup de main

Michel

"Michel B" 48bc095f$0$17347$
Bonsoir

la formule :

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z2:Z3000="X"))


sur ce tableau la formule devrais trouvé 2 enregistrements pratiquant
Inscrit N ou X de plus de 18 ans.
Je reçois un message d'erreur : #VALEUR


A
F
Z

Inscrit
Date_Naissance
Pratiquant

X
31/01/1999
X

X
09/02/1943
X

X
17/11/1957


N
02/09/2001
X

N
12/07/2002
X

N
05/08/1947


N
01/10/1965
X




Je ne suis pas sous excel 2007
D'avance merci pour le coup de main

Michel


"Daniel.C"
Bonjour.
=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z="X"))
En remplaçant Z par la plage voulue.
Cordialement.
Daniel
"Michel B" 48bbb0eb$0$11228$
Bonjour a toutes et à tous,

je dois compter les enregistrements correspondant à plusieurs critéres :
A = N ou X et Age 

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

cela fonctionne impec.

Mais il faut que je ne compte que les enregistrements comportant A = N
ou X et Z= X et Age +18
j'ai modifié comme cela :

=SOMMEPROD((((ET(Licenciés!A2:A3000="N")+(Licenciés!Z2:Z3000="X"))+((ET(Licenciés!A2:A3000="X")+(Licenciés!Z2:Z3000="X"))))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

et

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(((Licenciés!Z2:Z3000="X")*OU(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))))

les résultats sont faux, je debute en VBA, une petite explication serait
la bien venue.

D'avance merci
Michel















Michel B
Le #16691111
Ca y est, cela fonctionne

Je n'avais pas indiqué la feuille concerné pour la colonne Z.

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z2:Z3000="X"))

deviens

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Licenciés!Z2:Z3000="X"))

Maintenant cela marche impec

Encore un grand merci.
Michel




"Misange" %
voir ma réponse :-)

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Michel B a écrit :
Oups, le tableau n'était pas passé !

la formule :

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z2:Z3000="X"))


sur ce tableau la formule devrais trouvé 2 enregistrements pratiquant
Inscrit N ou X de plus de 18 ans.
Je reçois un message d'erreur : #VALEUR


A F Z
Inscrit Date_Naissance Pratiquant

X 31/01/1999 X
X 09/02/1943 X
X 17/11/1957
N 02/09/2001 X
N 12/07/2002 X
N 01/10/1965 X

Je ne suis pas sous excel 2007
D'avance merci pour le coup de main

Michel

"Michel B" 48bc095f$0$17347$
Bonsoir

la formule :

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z2:Z3000="X"))


sur ce tableau la formule devrais trouvé 2 enregistrements pratiquant
Inscrit N ou X de plus de 18 ans.
Je reçois un message d'erreur : #VALEUR


A
F
Z

Inscrit
Date_Naissance
Pratiquant

X
31/01/1999
X

X
09/02/1943
X

X
17/11/1957


N
02/09/2001
X

N
12/07/2002
X

N
05/08/1947


N
01/10/1965
X




Je ne suis pas sous excel 2007
D'avance merci pour le coup de main

Michel


"Daniel.C"
Bonjour.
=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z="X"))
En remplaçant Z par la plage voulue.
Cordialement.
Daniel
"Michel B" 48bbb0eb$0$11228$
Bonjour a toutes et à tous,

je dois compter les enregistrements correspondant à plusieurs critéres
: A = N ou X et Age 

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

cela fonctionne impec.

Mais il faut que je ne compte que les enregistrements comportant A = N
ou X et Z= X et Age +18
j'ai modifié comme cela :

=SOMMEPROD((((ET(Licenciés!A2:A3000="N")+(Licenciés!Z2:Z3000="X"))+((ET(Licenciés!A2:A3000="X")+(Licenciés!Z2:Z3000="X"))))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

et

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(((Licenciés!Z2:Z3000="X")*OU(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))))

les résultats sont faux, je debute en VBA, une petite explication
serait la bien venue.

D'avance merci
Michel
















Misange
Le #16691091
regarde le classeur avec tes données :
http://cjoint.com/?jbsHp6ofXC

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Michel B a écrit :
Bonsoir,

la formule :
=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z2:Z3000="X"))

A F Z
Inscrit Date_Naissance Pratiquant

X 31/01/1999 X
X 09/02/1943 X
X 17/11/1957
N 02/09/2001 X
N 12/07/2002 X
N 01/10/1965 X


renvoie toujours l'erreur

Il s'agit d'import Access, les colonnes A et Z sont au format "Standard" et
F au format "Date".
Tout fonctionnait bien tant que je n'avais pas besoin de la colonne Z
Comme en plus je ne connais pas trés bien la rédaction des formules, je suis
paumé.

Encore merci pour l'aide

Michel


"Misange"
Bonjour

La formule fonctionne tout à fait chez moi et avec ton exemple elle
renvoie 2 comme attendu. MAIS : j'avais copié collé tes données et obtenu
le même résultat que toi : #VALEUR!. Il a fallu que je les resaisisse pour
que cela marche : dates pas reconnues comme telles (un grand classique du
copié collé) et plus bizarrement X et N pas reconnus comme des lettres.
Regarde si ça fait pareil dans ton classeur et dis nous.

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Michel B a écrit :
Bonsoir

la formule :

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z2:Z3000="X"))


sur ce tableau la formule devrais trouvé 2 enregistrements pratiquant
Inscrit N ou X de plus de 18 ans.
Je reçois un message d'erreur : #VALEUR


A
F
Z

Inscrit
Date_Naissance
Pratiquant

X
31/01/1999
X

X
09/02/1943
X

X
17/11/1957


N
02/09/2001
X

N
12/07/2002
X

N
05/08/1947


N
01/10/1965
X




Je ne suis pas sous excel 2007
D'avance merci pour le coup de main

Michel


"Daniel.C"
Bonjour.
=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z="X"))
En remplaçant Z par la plage voulue.
Cordialement.
Daniel
"Michel B" 48bbb0eb$0$11228$
Bonjour a toutes et à tous,

je dois compter les enregistrements correspondant à plusieurs critéres
: A = N ou X et Age 

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

cela fonctionne impec.

Mais il faut que je ne compte que les enregistrements comportant A = N
ou X et Z= X et Age +18
j'ai modifié comme cela :

=SOMMEPROD((((ET(Licenciés!A2:A3000="N")+(Licenciés!Z2:Z3000="X"))+((ET(Licenciés!A2:A3000="X")+(Licenciés!Z2:Z3000="X"))))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

et

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(((Licenciés!Z2:Z3000="X")*OU(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))))

les résultats sont faux, je debute en VBA, une petite explication
serait la bien venue.

D'avance merci
Michel














Sam
Le #16691341
Bonjour,
je trouve qu''il y a une ( en trop derrière le sommeprod et une ) en trop
derrière le 1
et le *1 est il bien utile ?

Cordialement
Michel dit "Sam"

"Michel B" 48bc1a1f$0$6912$
Ca y est, cela fonctionne

Je n'avais pas indiqué la feuille concerné pour la colonne Z.

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z2:Z3000="X"))

deviens

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Licenciés!Z2:Z3000="X"))

Maintenant cela marche impec

Encore un grand merci.
Michel




"Misange" %
voir ma réponse :-)

Misange migrateuse
XlWiki : Participez à un travail collaboratif sur excel !
http://xlwiki.free.fr/wiki
http://www.excelabo.net

Michel B a écrit :
Oups, le tableau n'était pas passé !

la formule :

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z2:Z3000="X"))


sur ce tableau la formule devrais trouvé 2 enregistrements pratiquant
Inscrit N ou X de plus de 18 ans.
Je reçois un message d'erreur : #VALEUR


A F Z
Inscrit Date_Naissance Pratiquant

X 31/01/1999 X
X 09/02/1943 X
X 17/11/1957
N 02/09/2001 X
N 12/07/2002 X
N 01/10/1965 X

Je ne suis pas sous excel 2007
D'avance merci pour le coup de main

Michel

"Michel B" 48bc095f$0$17347$
Bonsoir

la formule :

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z2:Z3000="X"))


sur ce tableau la formule devrais trouvé 2 enregistrements pratiquant
Inscrit N ou X de plus de 18 ans.
Je reçois un message d'erreur : #VALEUR


A
F
Z

Inscrit
Date_Naissance
Pratiquant

X
31/01/1999
X

X
09/02/1943
X

X
17/11/1957


N
02/09/2001
X

N
12/07/2002
X

N
05/08/1947


N
01/10/1965
X




Je ne suis pas sous excel 2007
D'avance merci pour le coup de main

Michel


"Daniel.C"
Bonjour.
=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1)*(Z="X"))
En remplaçant Z par la plage voulue.
Cordialement.
Daniel
"Michel B" 48bbb0eb$0$11228$
Bonjour a toutes et à tous,

je dois compter les enregistrements correspondant à plusieurs
critéres : A = N ou X et Age 

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

cela fonctionne impec.

Mais il faut que je ne compte que les enregistrements comportant A =
N ou X et Z= X et Age +18
j'ai modifié comme cela :

=SOMMEPROD((((ET(Licenciés!A2:A3000="N")+(Licenciés!Z2:Z3000="X"))+((ET(Licenciés!A2:A3000="X")+(Licenciés!Z2:Z3000="X"))))*(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))

et

=SOMMEPROD((((Licenciés!A2:A3000="N")+(Licenciés!A2:A3000="X"))*(((Licenciés!Z2:Z3000="X")*OU(DATEDIF(Licenciés!F2:F3000;MAINTENANT();"Y")>)*1))))

les résultats sont faux, je debute en VBA, une petite explication
serait la bien venue.

D'avance merci
Michel



















Publicité
Poster une réponse
Anonyme