config' simplissime de nginx

Le
Jean-Marc
--Signature=_Sun__12_May_2013_14_38_38_+0200_bYtBIzhXJvPemwNB
Content-Type: text/plain; charset=ISO-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Salut la liste,

J'aimerai installer un petit serveur web sur mon board ARM.
J'ai pensé à nginx.
J'ai donc installé nginx.
Mais la config' semble vide.
Et quand je démarre via <service nginx start>, j'ai un message me disant =
que le port 80 est déjà utilisé.

En fait, nginx semble se bloquer lui-même.
Je démarre <service nginx start> qui m'affiche :
[.] Starting nginx: nginxnginx: [emerg] bind() to [::]:80 failed (98: Ad=
dress already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] still could not bind()

Et pendant le démarrage, je tape <lsof -i:80> qui m'affiche :
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
nginx 4342 root 6u IPv4 6332 0t0 TCP *:http (LISTEN)

Une fois le démarrage foiré, nginx ne tourne pas et lsof ne me sort plu=
s rien.


Je me suis alors tourné vers tasksel et j'ai installé un web-server.
Mais malgré le fait que nginx était déjà installé, apt m'a quand =
même installé apache.
Là, pas de soucis, la page "It Works" était dispo.

Un remove + autoremove plus loin, je me retrouve au même point.

La doc' du wiki Debian ne donne pas plus que la liste de fonctions dispos d=
ans les différents paquets (nginx-light, full, extra).

Et le wiki de nginx est parfois indisponible, parfois trop fouillé.
Pas de quick start, en fait.

Des idées ? Suggestions ?

--
Jean-Marc <jean-marc@6jf.be>

--Signature=_Sun__12_May_2013_14_38_38_+0200_bYtBIzhXJvPemwNB
Content-Type: application/pgp-signature

--BEGIN PGP SIGNATURE--
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCAAGBQJRj41OAAoJEECwQOvthjrRm0sQAJUHVevD1hfrKoIwNJ8f+yVf
UXlCVfYUWaGyH7Qb7US+vyau/yJiN6C02bgDEXXGScvnjzDkpZu0HypaPFXrRwFy
opXbSXe1L8cb5FFnWm4TIlxXyDy3brODS3S5n8I5TlHDoKF/l7Nh3j18X+m3K3Pz
hgCWfDJG0u/b2M9OU2Hfb/lOahir4J9U9A8jYwaAglE7byV49YPmpT9BXqNhAi09
K0uLr0pezXV4Nl1wR+BCxqqHV95hHPlP2XACJUJckeLR8+YwKUWCuuvH1wiFdW3e
iRpTaRzKs1UzemwkpSnX2LR8pyBZuQMdeyXEj/Sc31z+dy1Hm2i6wvS2DxBCKutg
4R/6JE64p/wePfbnmT/ClSWR2YINsRo/7rJhbexMeXOItDzkQjbP0avyn1Gr26hN
wbACNV8xK6+sEGveSLiLUTkEAGH4shnWIMNXAG1Rp+HzTzJ16ZkkqjpPPDwQ3nTZ
9LKtdLD0IOf/v+7DdrO2JAIAJI7baI5QSSHCcjYRMyz6sFalP3/sloBqdkLDpo8N
dSEIVmtmfWrXtp5R7spxRoLfAR6p6RHL+lZ5fwO9pbRJaeqiRDfVuv6G7nkqMUTy
BGKyjfj+xmNMK882I/zt+lmxPBOFNb0sS1AQWTahDpfV+5b8lqV5wUbSzxNvaYQg
Gp+OhtpdnoLFSXPgTaSA
¹L7
--END PGP SIGNATURE--

--Signature=_Sun__12_May_2013_14_38_38_+0200_bYtBIzhXJvPemwNB--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20130512143838.bc9142c9fa58cc000beeb621@6jf.be
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Adrien Poupin
Le #25399982
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enig74352B330FE0E5066F4B396C
Content-Type: multipart/alternative;
boundary="------------040600080603090804050807"

This is a multi-part message in MIME format.
--------------040600080603090804050807
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Salut,
Je pense que tu as déjà un serveur de démarré. Du coup :
# service apache2 stop
# update-rc.d -f apache2 remove
# service nginx start
# update-rc.d -f nginx defaults

Si ce n'est pas apache qui est démarré, c'est peut-être httpd (donc même
chose en replaçant apache2 par httpd).
Normalement ça devrait déjà te faire avancer :-)

Tu veux faire tourner du php sur ton nginx ?

Adrien.


Le 12/05/2013 14:38, Jean-Marc a écrit :
Salut la liste,

J'aimerai installer un petit serveur web sur mon board ARM.
J'ai pensé à nginx.
J'ai donc installé nginx.
Mais la config' semble vide.
Et quand je démarre via <service nginx start>, j'ai un message me dis ant que le port 80 est déjà utilisé.

En fait, nginx semble se bloquer lui-même.
Je démarre <service nginx start> qui m'affiche :
[....] Starting nginx: nginxnginx: [emerg] bind() to [::]:80 failed (98 : Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] still could not bind()

Et pendant le démarrage, je tape <lsof -i:80> qui m'affiche :
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
nginx 4342 root 6u IPv4 6332 0t0 TCP *:http (LISTEN)

Une fois le démarrage foiré, nginx ne tourne pas et lsof ne me sort plus rien.


Je me suis alors tourné vers tasksel et j'ai installé un web-server .
Mais malgré le fait que nginx était déjà installé, apt m'a qu and même installé apache.
Là, pas de soucis, la page "It Works" était dispo.

Un remove + autoremove plus loin, je me retrouve au même point.

La doc' du wiki Debian ne donne pas plus que la liste de fonctions disp os dans les différents paquets (nginx-light, full, extra).

Et le wiki de nginx est parfois indisponible, parfois trop fouillé.
Pas de quick start, en fait.

Des idées ? Suggestions ?





--
Adrien Poupin - Creasixtine
* 14 88 73 / port. 06 76 18 32 36*
-------------------------------------------

--------------040600080603090804050807
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

<html>
<head>
<meta content="text/html; charset=ISO-8859-1"
http-equiv="Content-Type">
</head>
<body bgcolor="#FFFFFF" text="#000000">
Salut,<br>
Je pense que tu as d&eacute;j&agrave; un serveur de d&eacute;marr&eac ute;. Du coup :<br>
<tt># service apache2 stop<br>
# update-rc.d -f apache2 remove<br>
# service nginx start<br>
# update-rc.d -f nginx defaults<br>
</tt><br>
Si ce n'est pas apache qui est d&eacute;marr&eacute;, c'est peut-&eci rc;tre httpd (donc
m&ecirc;me chose en repla&ccedil;ant apache2 par httpd).<br>
Normalement &ccedil;a devrait d&eacute;j&agrave; te faire avancer :-) <br>
<br>
Tu veux faire tourner du php sur ton nginx ?<br>
<br>
Adrien.<br>
<br>
<br>
Le 12/05/2013 14:38, Jean-Marc a &eacute;crit&nbsp;:
<blockquote
cite="mid:"
type="cite">
<pre wrap="">Salut la liste,

J'aimerai installer un petit serveur web sur mon board ARM.
J'ai pens&eacute; &agrave; nginx.
J'ai donc install&eacute; nginx.
Mais la config' semble vide.
Et quand je d&eacute;marre via &lt;service nginx start&gt;, j'ai un messa ge me disant que le port 80 est d&eacute;j&agrave; utilis&eacute;.

En fait, nginx semble se bloquer lui-m&ecirc;me.
Je d&eacute;marre &lt;service nginx start&gt; qui m'affiche :
[....] Starting nginx: nginxnginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] still could not bind()

Et pendant le d&eacute;marrage, je tape &lt;lsof -i:80&gt; qui m'affiche :
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
nginx 4342 root 6u IPv4 6332 0t0 TCP *:http (LISTEN)

Une fois le d&eacute;marrage foir&eacute;, nginx ne tourne pas et lsof ne me sort plus rien.


Je me suis alors tourn&eacute; vers tasksel et j'ai install&eacute; un we b-server.
Mais malgr&eacute; le fait que nginx &eacute;tait d&eacute;j&agrave; inst all&eacute;, apt m'a quand m&ecirc;me install&eacute; apache.
L&agrave;, pas de soucis, la page "It Works" &eacute;tait dispo.

Un remove + autoremove plus loin, je me retrouve au m&ecirc;me point.

La doc' du wiki Debian ne donne pas plus que la liste de fonctions dispos dans les diff&eacute;rents paquets (nginx-light, full, extra).

Et le wiki de nginx est parfois indisponible, parfois trop fouill&eacute; .
Pas de quick start, en fait.

Des id&eacute;es ? Suggestions ?

</pre>
</blockquote>
<br>
<br>
<div class="moz-signature">-- <br>
Adrien Poupin - Creasixtine<br>
/ fixe. 09 54 14 88 73 / port. 06 76 18 32 36</strong><br>
-------------------------------------------</div>
</body>
</html>

--------------040600080603090804050807--

--------------enig74352B330FE0E5066F4B396C
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJRj47YAAoJEN2mnsXFeEtwICoIAN+FvqGzFvTQaMUkWWDUOqug
UENpJdHw9Ud0PN2u1UffjwsPjVHZ4Dzxwx7d+llXO3R2fWKiROLF7QS7n1Yp90mw
PNLzxDS9iPX0tv7ptmuxvyBU4dJVvsUJafwcTVr7zPA9T+nKy7kO2yratIamdw5X
6g1jqJzw7+dkh/ZB398SocIgr+lB6cfkaZHMGy/u5QxNcBW1X/I3vHZv48P8UZ/c
lB0CPL9JyfW0J1omUavtcKkTgp6p4BaULX5Ax+oa0Y/wJ9D6jeFwNV3fNm+oKhcm
oRC8X9/r89GDOQU6QkzgrrQkPRxsQC0Xj+bXwPWY/+9RP7Ld5URc56+P6HTALsE =6JN3
-----END PGP SIGNATURE-----

--------------enig74352B330FE0E5066F4B396C--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Marc
Le #25400032
--Signature=_Sun__12_May_2013_15_02_59_+0200_ao7KSju8ro4U.vhf
Content-Type: text/plain; charset=ISO-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Sun, 12 May 2013 14:45:12 +0200
Adrien Poupin
Salut,
Je pense que tu as déjà un serveur de démarré. Du coup :
# service apache2 stop
# update-rc.d -f apache2 remove
# service nginx start
# update-rc.d -f nginx defaults

Si ce n'est pas apache qui est démarré, c'est peut-être httpd (donc même
chose en replaçant apache2 par httpd).
Normalement ça devrait déjà te faire avancer :-)



httpd:
Installé : (aucun)
Candidat : (aucun)
Table de version :
apache2:
Installé : (aucun)
Candidat : 2.2.22-13
Table de version :
2.2.22-13 0
500 http://ftp.be.debian.org/debian/ testing/main armhf Packages

Et ni lsof ni netstat ne montre un process écoutant sur le port 80.

Tu veux faire tourner du php sur ton nginx ?



Peut-être.


Adrien.


Le 12/05/2013 14:38, Jean-Marc a écrit :
> Salut la liste,
>
> J'aimerai installer un petit serveur web sur mon board ARM.
> J'ai pensé à nginx.
> J'ai donc installé nginx.
> Mais la config' semble vide.
> Et quand je démarre via <service nginx start>, j'ai un message me dis ant que le port 80 est déjà utilisé.
>
> En fait, nginx semble se bloquer lui-même.
> Je démarre <service nginx start> qui m'affiche :
> [....] Starting nginx: nginxnginx: [emerg] bind() to [::]:80 failed (98 : Address already in use)
> nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
> nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
> nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
> nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
> nginx: [emerg] still could not bind()
>
> Et pendant le démarrage, je tape <lsof -i:80> qui m'affiche :
> COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
> nginx 4342 root 6u IPv4 6332 0t0 TCP *:http (LISTEN)
>
> Une fois le démarrage foiré, nginx ne tourne pas et lsof ne me sort plus rien.
>
>
> Je me suis alors tourné vers tasksel et j'ai installé un web-server.
> Mais malgré le fait que nginx était déjà installé, apt m'a qu and même installé apache.
> Là, pas de soucis, la page "It Works" était dispo.
>
> Un remove + autoremove plus loin, je me retrouve au même point.
>
> La doc' du wiki Debian ne donne pas plus que la liste de fonctions disp os dans les différents paquets (nginx-light, full, extra).
>
> Et le wiki de nginx est parfois indisponible, parfois trop fouillé.
> Pas de quick start, en fait.
>
> Des idées ? Suggestions ?
>


--
Adrien Poupin - Creasixtine
* 14 88 73 / port. 06 76 18 32 36*
-------------------------------------------




--
Jean-Marc
--Signature=_Sun__12_May_2013_15_02_59_+0200_ao7KSju8ro4U.vhf
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCAAGBQJRj5MDAAoJEECwQOvthjrRnaUP/A3piwHY0j1apzAyNHvHvzyF
nf0LMYNeAjLH70gPJ5XKgIrcnF3paMQVgyEx8ytawj1aZagcGD0+mbqoXR6zIGc1
kVoLMphGbMig/spwLnVet+bu/vESVEy1cmr+PzDVtZsWFI5eORTMGJKjsnCDYWho
C2JnnuArvw9hwU5VsQmTmBj79+EWx499VFkqMS7vYSygqkuO9s624egiR5shYkJ5
zlf3oRjD0r6i17YRYRoWXcmYYdgwe0DJUnXDQ3jp74nsxACOLN5s1VIZoYaj1TKn
Qn7u4ZvH9kswU31h2e9rIjs3cQq92oiKpZ1llsvv3wLjdub0VOpyv3MdiYKPWmVL
AoqtdWjqYZdJBXvK1kxg5a+akYmo10dyC6bnB5yp2qoBZBk1GU8dmeXxbbppoVP5
hgsTcJD2nyOkw6c/pqTWsfUwa6NHr8iS5Yhyyqnkb2nBvS39+1pG3zqGmShl+EC0
8sjU50m/uB+MhmxKii549qS7e25GHmCjVyxuAStHnxLRvVpT8jh3hCjH7jg3rqpw
JqknXu1oVH6L4uqOJY2jwMPjtnpEfFc5MYLsY9vB2j0LUbBzyIpHH24aVc6drkTq
TELpoFVSW1FocER9W1rDJaVJtQjgx4Gqk0GirVCZR3SxLzS2+em6/VVe/P2pQ+Om
CJoDlvrik9oSpKQpqLyc
=hzFr
-----END PGP SIGNATURE-----

--Signature=_Sun__12_May_2013_15_02_59_+0200_ao7KSju8ro4U.vhf--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bzzz
Le #25400072
On Sun, 12 May 2013 14:38:38 +0200
Jean-Marc
J'aimerai installer un petit nginx web sur mon board ARM.



netstat -pna|grep ngi

--
Ben dit : je valide j'ai perdu du gras, la balance a parlé
Ben dit : Mhhh je me disais bien que le timeout des regards des femelles
était plus long ces derniers temps

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Marc
Le #25400132
--Signature=_Sun__12_May_2013_15_39_40_+0200_11MfiQ4V.roX6sO.
Content-Type: text/plain; charset=ISO-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Sun, 12 May 2013 15:15:24 +0200
Bzzz
netstat -pna|grep ngi



Hélas, si un process nginx ou tout autre était en train de tourner et d 'écouter sur le port 80, j'en serai ravis. Mais ce n'est pa le cas.

Seul nginx lui-même quand j'essaie de la démarrer écoute sur ce port.
Et cela semble le bloquer puisqu'il affiche des erreurs avant de s'arrête r.
Et puis, plus rien ne bloque ce port.

--
Jean-Marc
--Signature=_Sun__12_May_2013_15_39_40_+0200_11MfiQ4V.roX6sO.
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCAAGBQJRj5ucAAoJEECwQOvthjrRDywP/25N5Zyiy6350saXg2/SERqh
1ZBHuwVEX4h0sITxE8L/mOKNp8qg1uh/zrOZiuxHkNpTYUEE5tfofcU1O1+L5on5
T5abStJL+RzG9jq7Vc1p/C6XRwBZGI5MgtC9hQLmGIs25Jnab7yxOgJ//pw6L0n9
QOFvlehuUTv/lPaDoYG2YrQGPPsMK56Af6RiZvR1lXiACgdf0x2CC8eru5PV7Ct9
tf0ieadrAnDR527VOAsZX5nBkOVbgqZbH+Xhpjld88rh9fxsa/Wc0lB7WfVNWxyh
pHiBxod0uvJA2SIK1hdgjZ7ol4ShjNmXS7dEUW5DeJaELd3uOipFmrk9pn+TzWL1
Rsnx3vmoXAy4dKDQFcIiqgycUE1A6YIoTPMYNfMZsMWuPoGCuIlxSxVi4loXqWUO
qIWb0WmgBbkoCNn0SVmIMG3G/F7jo0SaatU5TBSEQV/TlDlFioNfOlkmYGTSF8nU
4Fk5QGMMXWh68dGz+mX3ReZhOV5c12pZLUnXGd6uNFyvq75PujQfk0PW1wkruBFT
8eprA0oKLdpYd3r1HLJGSWApMTEsO7050gm3WPqG8zZ28V49VyrgmZ6LCORTXqsM
biLS//TdMFxWeuiPVeWlJzmyLo9HB6L5wWpCVRxS41p1JUwIDh7fqIehUqMpUcqM
lL9es1vThmnOa3kL7HVK
=z92A
-----END PGP SIGNATURE-----

--Signature=_Sun__12_May_2013_15_39_40_+0200_11MfiQ4V.roX6sO.--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Bzzz
Le #25400382
On Sun, 12 May 2013 15:39:40 +0200
Jean-Marc
Seul nginx lui-même quand j'essaie de la démarrer écoute s ur ce port.
Et cela semble le bloquer puisqu'il affiche des erreurs avant de
s'arrêter. Et puis, plus rien ne bloque ce port.



tail /var/log/nginx/error.log

telnet localhost (ou micro.domain) 80

devrait renvoyer (si nginx est actif sur le port 80):
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
<html>
<head><title>400 Bad Request</title></head>
<body bgcolor="white">
<center><h1>400 Bad Request</h1></center>
<hr><center>nginx</center>
</body>
</html>
Connection closed by foreign host.
lors du CTRL-D pour sortir du telnet.

--
This sentence does in fact not have the property it claims not to have.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Marc
Le #25400482
--Signature=_Sun__12_May_2013_18_25_32_+0200_6hx787RIDoOsUa6t
Content-Type: text/plain; charset=ISO-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

un peu de suivi concernant ce problème.

On Sun, 12 May 2013 15:39:40 +0200
Jean-Marc

Hélas, si un process nginx ou tout autre était en train de tourner et d'écouter sur le port 80, j'en serai ravis. Mais ce n'est pa le cas.

Seul nginx lui-même quand j'essaie de la démarrer écoute sur ce por t.
Et cela semble le bloquer puisqu'il affiche des erreurs avant de s'arrê ter.
Et puis, plus rien ne bloque ce port.




Le soucis vient du fichier de config' sites-enabled/default qui spécifie les directives listen suivantes :
listen 80;
listen [::]:80 default_server;

Or, suivant la doc' nginx (http://wiki.nginx.org/HttpCoreModule#listen),
" When you enable the address [::]:80, binding port 80 using IPv6, in the l isten directive, in Linux, by default, the IPv4 port 80 is also enabled. Me aning that nginx listens for both IPv4 and IPv6 incoming traffic. Therefore if you erroneously specify also a IPv4 address you'll get an already bind address error when reloading nginx configuration. "

En clair, si nginx écoute sur le port 80 en IPv6, il le fera aussi par d éfaut sur le port 80 IPv4. Et spécifier les deux conduit à une erreu r au chargement.

Et si je supprime la directive "liste 80;", nginx démarre.

La séparation IPv4 et v6 est possible via sysctl net.ipv6.bindv6only mais la valeur par défaut indique de ne pas séparer l'IPv4 et v6.

Donc, la config' livrée avec nginx ne fonctionne pas.

Bugreport ?

--
Jean-Marc
--Signature=_Sun__12_May_2013_18_25_32_+0200_6hx787RIDoOsUa6t
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCAAGBQJRj8J8AAoJEECwQOvthjrRyM0QALg679FmdJforF+wiSBzRUbZ
jK7M7qfgOmTFIsc9Si56Z/g0DX09ynFG+QZUwBmQI1gM66j2bx5mMZVwRsbQrvYv
DikbZgASWWCDm3eJaP7t4tP/A1xnoqrroR5Ks947dF8uuLWqTrvYpY1cv/P769ps
p5pvDjI47jt0fDh0ahRgB39jJY+M6PbA3ql4ctivJQnuPqLGsVAFA7ksKkIPXjCa
w+5Lm8vjUWDh/jZcoCWbMUHnnBJwJkbpxJqJNYBoLveeKKAhWHqE8PQxSBhk/Nb8
2B+MPBmX7jRAcpoEA8VdoA7S5jbOx37j8D87FR9Aq9ehXxd5TNwcvyuZvITryIZn
+2sFUMyl3KuwRq0efnQnxhUEdSwLEbH7NOfK8/1srRZKS0kYve1pURRHN2u5lGkp
Ksw7Kp6Qz3ubIHqx9Dx32kB9V4eHxycv24J7SNgU0uZJHidL+kRDwHdYx+qVmVlW
bBIoTJ71NOBEbXPr9fs6veTzM/FREwyN+k8UDAYvXtO6XFzGdYj+RI6LmctaVbbC
XrTmw6WU/uF4Ga6Ka10A4V3CvLTFlfL8e/HCmI26NAR1dIMP5HNrpVzkQPaZCblO
I7ZyUDz0yQnY5bTeuCN5el/vDiuJ8fC/Kn51TvmzeChe1acU1uO4oPhaoJ0osgGY
WZSomfNo+IK2FNPBovBn
ºjW
-----END PGP SIGNATURE-----

--Signature=_Sun__12_May_2013_18_25_32_+0200_6hx787RIDoOsUa6t--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Marc
Le #25400552
--Signature=_Sun__12_May_2013_18_30_02_+0200_0K2QkNcpJ9FJpgbS
Content-Type: text/plain; charset=ISO-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Sun, 12 May 2013 17:44:28 +0200
Bzzz
Salut Bzzz,

On Sun, 12 May 2013 15:39:40 +0200
Jean-Marc
> Seul nginx lui-même quand j'essaie de la démarrer écoute sur ce p ort.
> Et cela semble le bloquer puisqu'il affiche des erreurs avant de
> s'arrêter. Et puis, plus rien ne bloque ce port.

tail /var/log/nginx/error.log



Me donne les mêmes erreurs que celles affichées à l'écran lors du d émarrage.


telnet localhost (ou micro.domain) 80




Et rien n'écoute. Je viens aussi de poster un autre mail avec la cause d u problème et le pourquoi nginx ne démarre pas avec la config' fournie par le paquet.

Merci pour tes réponses et le suivi de mon problème.

--
Jean-Marc
--Signature=_Sun__12_May_2013_18_30_02_+0200_0K2QkNcpJ9FJpgbS
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCAAGBQJRj8OKAAoJEECwQOvthjrRcSEP/0gm9e6QlKNs0C890EcF5rn6
9OYuuktvKnoTEcoTNvVB9CMwpV5gJCruu/N2qXZLrgdYrJBQaXV3P1WGUPTaIXbt
/eb4IfR4DQWBVJYa+ht15FyqyIqXtciyq4YsUD6wmjAjQnIflLr5aJ6kup+Kzsum
Z5kTlQzQswGERkU1jzD4rhn+TH5hKOEEChLqnyq5Me5Z2lDnF8ixFuLkgTSJO8PV
ROp80loKJn87dGo8EdPAgL0FwJOiUGf+eSiRO2o3FMEfxvMjxaDsysgsqKs5KUKQ
r0JyjhWwDV2TmOvbQ2dR/xY0qrG/CwOhodnClGRLJs9ShYJc+8319BtPRjHHKt4n
jNHf/shsXTrFO8dC5d8Md4BMmBHgxPhQs9OB87Pir7cHFXEd4wXN6Hv2xjvCITte
b53rVMj2HLoBC1+u+USAEGMLwfLieAQCkdz7Z9lbPDuXwfQQTBiDIPE9cnzUfvVK
mT898Xszh8ulou5HCfhgUmlz+5B3L66y1juO9p86uWMj7bo5kTezoR4hBIPSJ8RC
AcBeb8jSmyLyecIpB8swIemelyEthiU0jRin4JWY2s9Qw9lNqLeV9dfhJW0EISpp
ILqOmD64rBdvzOVdvWZjHmHBEtlGKX10qaODQP9dNblacZb5UCOvUj//McUmxL28
PcvFv6tc08aGiqYxKN5P
=Ki4t
-----END PGP SIGNATURE-----

--Signature=_Sun__12_May_2013_18_30_02_+0200_0K2QkNcpJ9FJpgbS--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Adrien Poupin
Le #25401052
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enigAF85A7E9E2D7C8E80170C020
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Le 12/05/2013 18:25, Jean-Marc a écrit :
un peu de suivi concernant ce problème.

On Sun, 12 May 2013 15:39:40 +0200
Jean-Marc
Hélas, si un process nginx ou tout autre était en train de tourner et d'écouter sur le port 80, j'en serai ravis. Mais ce n'est pa le ca s.

Seul nginx lui-même quand j'essaie de la démarrer écoute sur ce port.
Et cela semble le bloquer puisqu'il affiche des erreurs avant de s'arr êter.
Et puis, plus rien ne bloque ce port.



Le soucis vient du fichier de config' sites-enabled/default qui spéci fie les directives listen suivantes :
listen 80;
listen [::]:80 default_server;

Or, suivant la doc' nginx (http://wiki.nginx.org/HttpCoreModule#listen) ,
" When you enable the address [::]:80, binding port 80 using IPv6, in t he listen directive, in Linux, by default, the IPv4 port 80 is also enabl ed. Meaning that nginx listens for both IPv4 and IPv6 incoming traffic. T herefore if you erroneously specify also a IPv4 address you'll get an alr eady bind address error when reloading nginx configuration. "

En clair, si nginx écoute sur le port 80 en IPv6, il le fera aussi pa r défaut sur le port 80 IPv4. Et spécifier les deux conduit à une erreur au chargement.

Et si je supprime la directive "liste 80;", nginx démarre.

La séparation IPv4 et v6 est possible via sysctl net.ipv6.bindv6only mais la valeur par défaut indique de ne pas séparer l'IPv4 et v6.

Donc, la config' livrée avec nginx ne fonctionne pas.

Bugreport ?



Au temps pour moi, ce matin je t'ai dit des bêtises.
Par contre j'ai chez moi :
#listen 80; ## listen for ipv4; this line is default and implie d
#listen [::]:80 default_server ipv6only=on; ## listen for ipv 6
C'est la configuration par défaut, et ce faisant tu peux écouter sur du
ipv6 seul. Normalement c'est bon ! Ça répond à ton souci ?

--
Adrien
-------------------------------------------


--------------enigAF85A7E9E2D7C8E80170C020
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJRj+4vAAoJEN2mnsXFeEtwCMgIAIyonpWscJOjpyptQcMAZiKU
f0Zlj6YX2PrBRRjUG/xZP7vxvVGfBzA1Zwi4BuzeaOkVwd4UBFxfTqZpJLHSE1+c
M3oTnv/XTef4lLDrdKgilTdHm7nAs1pVQcTiWUL3Gofgd4qChOzSOMyAhaDWcGGW
HHV060JKza4r6dug4AVcqtkMDAQzgeIqKHOeAkQHBkhiWvIbD9U1kmfh318gE3cr
D7fJLcOTkLi1+qWD+T4sRM8GUbZL6F8igyoEj8kgs3Ug2bKg86RKumUnkXtJbnLh
jwn+iPrfMBXZyXJpw1uwwE8q8rOswtl7XvWwlpIZ63TZQXRWa92OSHBifKUn4xM =sC6k
-----END PGP SIGNATURE-----

--------------enigAF85A7E9E2D7C8E80170C020--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Marc
Le #25401372
--Signature=_Mon__13_May_2013_00_05_41_+0200_N_5r11mWVre+qZNv
Content-Type: text/plain; charset=ISO-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On Sun, 12 May 2013 21:31:59 +0200
Adrien Poupin
Salut Adrien,


Par contre j'ai chez moi :
#listen 80; ## listen for ipv4; this line is default and implied
#listen [::]:80 default_server ipv6only=on; ## listen for ipv6
C'est la configuration par défaut, et ce faisant tu peux écouter sur du
ipv6 seul. Normalement c'est bon ! Ça répond à ton souci ?



Comme dans ta config', j'ai préféré séparer l'IPv4 et l'IPv6 avec l 'option ipv6only=on;
Après cette modif, cela fonctionne.

Et pas besoin de rapporter de bug, c'est déjà fait :
http://bugs.debian.org/cgi-bin/bugreport.cgi?bugp7110


--
Adrien




--
Jean-Marc
--Signature=_Mon__13_May_2013_00_05_41_+0200_N_5r11mWVre+qZNv
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCAAGBQJRkBI1AAoJEECwQOvthjrRChUQAIcRxUtxYnGQhdE8xTRFnqNB
3QXD0VqIMn5XF7lo5QY8cc9KcFeWXxyoLcLgxF77UBApbLaxvSMFBH3oZ9OwtzZz
XOxC13IuoYw3H/j2ijKV5Dj9lx+Glxn/y7dtDil1xPjPTUH5ILdrU+4AbRNb5cEp
FuwH6QdBh703gbuZhyIan2zWEOV8/uEzTaO+i34M0dkwupQO3lh4iBurSYusMslg
0MnZbJ1V8AU3ImFKvSeAwW3j7aAjuErEvpSdBpV/j9zNo8EhFV2ar+G379nSx3Xw
WKiO+/4S73nQJRvOmNbd+87yu1JDy4/lstPNOnddWPHfhEjKkekHg86Muqh/VD8y
eYMhUuX82ntMPb6HsYlpz9lD0bK+tWVR38UBifjkMcs1tDZJBnvvsF1ZxbERHRkK
nHie7oBySI4C/Pbeq5QK1W/Nu9ioBkqrWgMpYT+pG1KCzr0g9X+r9HywSS7VjDxI
3r2CremhbhtF+b+ZaFCzC5K8qe+KPNkl/4+798iOMOLABemj+0Vg6Wxlo0AbXwwa
IldX2ggzd3XBKwD56eEJ6gxw7oxgO+PKv4Tp+g9kxNQ/doXzuuLk+eyyGA3Op+jU
eCI87kKeqj+5ojaqAe8p+yUEEwPSe0MACruzIGn7UbelDVfUx3DiIxA6iANo4/B+
pxxleWMYdCA86enE5pbM
=5KJc
-----END PGP SIGNATURE-----

--Signature=_Mon__13_May_2013_00_05_41_+0200_N_5r11mWVre+qZNv--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
raphael.poitevin
Le #25402352
Jean-Marc
Le soucis vient du fichier de config' sites-enabled/default qui spéc ifie les directives listen suivantes :
listen 80;
listen [::]:80 default_server;

Or, suivant la doc' nginx (http://wiki.nginx.org/HttpCoreModule#listen),
" When you enable the address [::]:80, binding port 80 using IPv6, in the listen directive, in Linux, by default, the IPv4 port 80 is also enabled. Meaning that nginx listens for both IPv4 and IPv6 incoming traffic. Therefo re if you erroneously specify also a IPv4 address you'll get an already bin d address error when reloading nginx configuration. "

En clair, si nginx écoute sur le port 80 en IPv6, il le fera aussi p ar défaut sur le port 80 IPv4. Et spécifier les deux conduit à   une erreur au chargement.

Et si je supprime la directive "liste 80;", nginx démarre.

La séparation IPv4 et v6 est possible via sysctl net.ipv6.bindv6only mais la valeur par défaut indique de ne pas séparer l'IPv4 et v6.

Donc, la config' livrée avec nginx ne fonctionne pas.



Elle marchait avant, c'est suite à une mise à jour, je ne sais la quelle
car, j'ai fais longtemps des mises à jours sans redémarrer nginx ;
j'avais rencontré le pb suite à un redémarrage de la machine que j'ai
résolu en effet comme toi.
--
Raphaël
« Tout chercheur plongé dans la science subit une poussée de bas en haut susceptible de lui remonter le moral. »
Monsieur Cyclopède

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme