Configuration fontes gtk

Le
argwella
Bonjour,

Suite à une mise à jour de ma Debian (testing),
je me retrouve avec des fontes toutes petites dans mon
gestionnaire de fenêtres (fluxbox). Cela affecte iceweasel,
la fenêtre de login de xdm, etc.

J'ai cru comprendre que c'est un problème de réglage des fontes
gtk. Apparemment, ceci se règle dans un fichier .gtkrc situé sous /~
mais, je n'ai pas de tel fichier.

Faut-il que j'en crée un ex-nihilo ? Ou bien est-ce réglable ailleurs
dans
un autre fichier de conf ? D'ailleurs, suis-je sur la bonne piste ?

Merci, Argwella
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas George
Le #1968981
argwella wrote in message
Suite à une mise à jour de ma Debian (testing),
je me retrouve avec des fontes toutes petites dans mon
gestionnaire de fenêtres (fluxbox). Cela affecte iceweasel,
la fenêtre de login de xdm, etc.


Commence par vérifier si la dimension physique de ton écran est correctement
détectée. xdpyinfo permet d'avoir l'information.

argwella
Le #1990281
Le 1er avr, 01:25, Nicolas George écrit

Commence par vérifier si la dimension physique de ton écran est
correctement
détectée. xdpyinfo permet d'avoir l'information.


Je reposte, car j'ai répondu en privé par inadvertance.

Donc, la commande xdpyinfo semble retourner des valeurs
cohérentes pour les dimensions de mon écran (1024*768) et je
me demande toujours où régler les tailles de tous les habillages
de fenêtres, de xdm, etc.

Je précise que dans un terminal (aterm) les fontes sont de taille
correcte.

Thierry B.
Le #1991721
--{ argwella a plopé ceci: }--

Donc, la commande xdpyinfo semble retourner des valeurs
cohérentes pour les dimensions de mon écran (1024*768) et je
me demande toujours où régler les tailles de tous les habillages
de fenêtres, de xdm, etc.

Oui, ça c'est la dimension de l'écran. Mais quelle est sa

résolution en "dots per inch" ? Ensuite, il faudrait que
tu regardes si tu n'as pas de problème de chargement de
polices au démarrage de X11, emmenant celui-ci à utiliser
une police de substitution moins appropriée. Essaye avec
xfontsel pour voir si tu arrive à un affichage normal...

Je précise que dans un terminal (aterm) les fontes sont de taille
correcte.


Il me semble bien que aterm a une gestion particulière des
tailles de caractères.

--
00:D0:59:54:18:21 00:80:C8:4B:33:97 00:40:05:48:b5:8e 00:C0:4F:90:DA:0A

Nicolas George
Le #1997531
argwella wrote in message
Je reposte, car j'ai répondu en privé par inadvertance.


Pas de mal.

Donc, la commande xdpyinfo semble retourner des valeurs
cohérentes pour les dimensions de mon écran (1024*768)


J'insiste bien : regarde la dimension _physique_ de l'écran, pas la
dimension en pixels, et vérifie qu'elle correspond à la réalité, mesurée
avec une règle.

argwella
Le #1997521
On 1 avr, 23:09, Nicolas George
J'insiste bien : regarde la dimension _physique_ de l'écran, pas la
dimension en pixels, et vérifie qu'elle correspond à la réalité, m esurée
avec une règle.


Effectivement, j'ai répondu un peu vite !

xdpyinfo me dit 1024*768 pixels, entre parenthèse 347*260 mm,
alors que mon écran fait en réalité 280*215 mm (c'est un portable, on
l'aura deviné).

[ Par ailleurs puisqu'un autre intervenant l'a demandé, la résolution
indiquée est de 75 dpi, ce qui devait déjà être la valeur avant ma
fameuse mise à jour. ]

Donc, il y a effectivement un problème physique.

C'est grave, docteur ?

Nicolas George
Le #2015531
argwella wrote in message
C'est grave, docteur ?


Ça suffit à expliquer la petite taille des polices. Il faudrait chercher
d'où vient cette valeur erronée. Regarde dans les logs du serveur X11 ce
qu'il en dit. Chez moi, j'ai quelque chose comme :

(**) intel(0): Display dimensions: (360, 270) mm

Une valeur aussi précisément égale à 75 DPI semble indiquer que quelqu'un
force la définition à être 75 DPI.

argwella
Le #2046461
On 1 avr, 23:52, Nicolas George
Ça suffit à expliquer la petite taille des polices. Il faudrait cherch er
d'où vient cette valeur erronée. Regarde dans les logs du serveur X11 ce
qu'il en dit. Chez moi, j'ai quelque chose comme :

(**) intel(0): Display dimensions: (360, 270) mm


Bonjour,

$ grep dimensions /var/log/Xorg.0.log

me renvoie tout un tas de messages du type :

ATI(0) : Not using default mode "1024*768" (exceeds panel dimensions)

(j'ai un message de ce type pour chaque dimension).
En revanche, je n'ai pas de ligne qui contient des dimensions en mm,
comme toi.

En tout cas, ceci confirme qu'il y a un problème. Je me demande bien
quelle update a pu provoquer cela.

Nicolas George
Le #2046431
argwella wrote in message
En revanche, je n'ai pas de ligne qui contient des dimensions en mm,
comme toi.


Je n'ai pas à portée de main de carte gérée par le driver « ati » tout
court, donc je ne peux pas comparer.

Le plus simple est d'ajouter une directive DisplaySize à la section Monitor
de la configuration du serveur X11. Cf. le man de xorg.conf (par exemple)
pour les détails.

argwella
Le #2056421
On 2 avr, 11:48, Nicolas George

Le plus simple est d'ajouter une directive DisplaySize à la section Moni tor
de la configuration du serveur X11. Cf. le man de xorg.conf (par exemple)
pour les détails.


C'est fait, et ça marche parfaitement.

Bravo pour le diagnostic et le traitement,

je te remercie.

Argwella

Publicité
Poster une réponse
Anonyme