configuration imprimante sous Debian

Le
Bernard
Bonjour,

Je reprends l'installation de mon imprimante HP Deskjet 11120C après mes
efforts du 13 au 21 janvier (précédente enfilade) interrompus par manque
de temps disponible. Nicolas G. m'avait alors fait remarquer que la
version de HPLIP que j'avais installée (celle disponible pour Debian
SARGE en Stable), n'était pas compatible car trop ancienne. J'avais
précédemment tenté de désinstaller et réinstaller un certain nombre
de choses, dont CUPS, HPLIP et autres, avec au final le même résultat
que précédemment et, ne sachant pas où récupérer et comment installer
la version plus récente de HPLIP, j'avais fait une pause jusqu'à ce
jour.

Aujourd'hui donc, j'ai, à nouveau, tenté de désinstaller cupsys,
hplip mais, cette fois, je n'arrive pas à réinstaller. Je pense que
la différence avec la fois précédente est ceci : pour les
désinstallations, j'ai ajouté l'option '--purge'. En tout état de
cause, désormais, la commande :

apt-get install cupsys

me répond le copié collé suivant :

********************

# apt-get install cupsys -s
Lecture des listes de paquets Fait Construction de l'arbre des
dépendances Fait Certains paquets ne peuvent être installés. Ceci
peut signifier que vous avez demandé l'impossible, ou bien, si vous
utilisez la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.

Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
probablement pas installable et vous devriez envoyer un rapport de bogue.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
cupsys: Dépend: gs-esp mais ne sera pas installé
E: Paquets défectueux

*********************

La tentative d'installation de gs-esp me dit à peu près la même chose,
à ceci près que c'est ici

.
Les paquets suivants contiennent des dépendances non satisfaites :
gs-esp: Dépend: libice6 (>= 1:1.0.0) mais 4.3.0.dfsg.1-14sarge3 devra
être installé
E: Paquets défectueux

*******************

et ainsi de suite Il en va de même pour toute tentative de
réinstaller HPLIP, là c'est précisément cupsys qui est prérequis

J'imagine avoir fait une grosse bétise en désinstallant ces deux
packages avec l'option "purge". Pourtant, la réinstallation dans les
conditions précédentes ne me permettrait pas de faire fonctionner
normalement mon imprimante. Actuellement elle ne fonctionne plus du tout ;
précédemment, elle fonctionnait uniquement avec OpenOffice grâce à
CUPS, mais pas sous GIMP.

Merci d'avance à qui voudra bien m'aider à réinstaller cups et hplip
dans des versions suffisamment récentes pour fonctionner avec mon
imprimante.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
msegura
Le #1883344
Bonjour,

Je reprends l'installation de mon imprimante HP Deskjet 11120C après mes
efforts du 13 au 21 janvier (précédente enfilade) interrompus par manque
de temps disponible. Nicolas G. m'avait alors fait remarquer que la
version de HPLIP que j'avais installée (celle disponible pour Debian
SARGE en Stable), n'était pas compatible car trop ancienne. J'avais
précédemment tenté de désinstaller et réinstaller un certain nombre
de choses, dont CUPS, HPLIP et autres, avec au final le même résultat
que précédemment et, ne sachant pas où récupérer et comment installer
la version plus récente de HPLIP, j'avais fait une pause... jusqu'à ce
jour.

Aujourd'hui donc, j'ai, à nouveau, tenté de désinstaller cupsys,
hplip... mais, cette fois, je n'arrive pas à réinstaller. Je pense que
la différence avec la fois précédente est ceci : pour les
désinstallations, j'ai ajouté l'option '--purge'. En tout état de
cause, désormais, la commande :

apt-get install cupsys

me répond le copié collé suivant :

********************

# apt-get install cupsys -s
Lecture des listes de paquets... Fait Construction de l'arbre des
dépendances... Fait Certains paquets ne peuvent être installés. Ceci
peut signifier que vous avez demandé l'impossible, ou bien, si vous
utilisez la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.

Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
probablement pas installable et vous devriez envoyer un rapport de bogue.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
cupsys: Dépend: gs-esp mais ne sera pas installé
E: Paquets défectueux

*********************

La tentative d'installation de gs-esp me dit à peu près la même chose,
à ceci près que c'est ici

.......
Les paquets suivants contiennent des dépendances non satisfaites :
gs-esp: Dépend: libice6 (>= 1:1.0.0) mais 4.3.0.dfsg.1-14sarge3 devra
être installé
E: Paquets défectueux

*******************

et ainsi de suite... Il en va de même pour toute tentative de
réinstaller HPLIP, là c'est précisément cupsys qui est prérequis...

J'imagine avoir fait une grosse bétise en désinstallant ces deux
packages avec l'option "purge". Pourtant, la réinstallation dans les
conditions précédentes ne me permettrait pas de faire fonctionner
normalement mon imprimante. Actuellement elle ne fonctionne plus du tout ;
précédemment, elle fonctionnait uniquement avec OpenOffice grâce à
CUPS, mais pas sous GIMP.

Merci d'avance à qui voudra bien m'aider à réinstaller cups et hplip
dans des versions suffisamment récentes pour fonctionner avec mon
imprimante.

BJ,

as tu -upgradé- ton systeme en passant de Sarge à Etch par exemple.Sinon
pose ta quetion sur des forums Debian -nombreux sur Internet.

Bernard
Le #1883336
Le Wed, 11 Apr 2007 22:11:02 +0200, msegura a écrit :

Bonjour,

Je reprends l'installation de mon imprimante HP Deskjet 11120C après
mes efforts du 13 au 21 janvier (précédente enfilade) interrompus par
manque de temps disponible. Nicolas G. m'avait alors fait remarquer que
la version de HPLIP que j'avais installée (celle disponible pour Debian
SARGE en Stable), n'était pas compatible car trop ancienne. J'avais
précédemment tenté de désinstaller et réinstaller un certain nombre
de choses, dont CUPS, HPLIP et autres, avec au final le même résultat
que précédemment et, ne sachant pas où récupérer et comment
installer la version plus récente de HPLIP, j'avais fait une pause...
jusqu'à ce jour.

Aujourd'hui donc, j'ai, à nouveau, tenté de désinstaller cupsys,
hplip... mais, cette fois, je n'arrive pas à réinstaller. Je pense que
la différence avec la fois précédente est ceci : pour les
désinstallations, j'ai ajouté l'option '--purge'. En tout état de
cause, désormais, la commande :

apt-get install cupsys

me répond le copié collé suivant :

********************

# apt-get install cupsys -s
Lecture des listes de paquets... Fait Construction de l'arbre des
dépendances... Fait Certains paquets ne peuvent être installés. Ceci
peut signifier que vous avez demandé l'impossible, ou bien, si vous
utilisez la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.

Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
probablement pas installable et vous devriez envoyer un rapport de
bogue. L'information suivante devrait vous aider à résoudre la
situation :

Les paquets suivants contiennent des dépendances non satisfaites :
cupsys: Dépend: gs-esp mais ne sera pas installé
E: Paquets défectueux

*********************

La tentative d'installation de gs-esp me dit à peu près la même
chose, à ceci près que c'est ici

.......
Les paquets suivants contiennent des dépendances non satisfaites :
gs-esp: Dépend: libice6 (>= 1:1.0.0) mais 4.3.0.dfsg.1-14sarge3 devra
être installé
E: Paquets défectueux

*******************

et ainsi de suite... Il en va de même pour toute tentative de
réinstaller HPLIP, là c'est précisément cupsys qui est prérequis...

J'imagine avoir fait une grosse bétise en désinstallant ces deux
packages avec l'option "purge". Pourtant, la réinstallation dans les
conditions précédentes ne me permettrait pas de faire fonctionner
normalement mon imprimante. Actuellement elle ne fonctionne plus du tout
; précédemment, elle fonctionnait uniquement avec OpenOffice grâce à
CUPS, mais pas sous GIMP.

Merci d'avance à qui voudra bien m'aider à réinstaller cups et hplip
dans des versions suffisamment récentes pour fonctionner avec mon
imprimante.

BJ,

as tu -upgradé- ton systeme en passant de Sarge à Etch par exemple.Sinon
pose ta quetion sur des forums Debian -nombreux sur Internet.



oui, j'ai upgradé contre ma volonté, mais je ne sais pas à quoi je suis
passé. Il y a peu de jours, en effet, j'ai voulu faire un "update" par :

#apt-get update

or voici que ma distraction m'a fait écrire "upgrade" à la place de
"update" !! L'opération à duré plus d'une demi-heure, et je n'ai osé
rien faire pour l'interrompre. A la fin, çà m'a posé des questions sur
la façon de configurer le raid logiciel (ce n'est pas moi qui l'avais
configuré au départ) et j'ai répondu au hasard. Lorsque, après un
shutdown, la machine a redémarré normalement, j'ai presque cru au
miracle :=)

Comment savoir si je suis passé à "etch" ? En fait, dans mon fichier
sources.list, je n'ai pas les répertoires me permettant d'accéder à
autre chose qu'à "main" et "stable". Ah mais zut, au fait, j'ai fait
divers essais et modifs, et il n'est pas impossible qu'au moment précis
où j'ai fait un "upgrade" à la place d'un "update", j'ai eu un
sources.list ouvert à d'autres répertoires )=<

Merci de me dire ce que je dois faire. Quant aux newsgroups DEBIAN,
mouais, j'en suis à la seconde tentative pour y accéder. news.free.fr
permet d'y accéder en Read Only. Il y a plusieurs semaines, après une
info pas facile à trouver, j'ai compris qu'il s'agissait de listes de
diffusion, qu'il fallait s'y inscrire. Je l'ai fait. Cà a demandé un
moment. Finalement, une semaine après, je me suis retrouvé abonné à
ces groupes, et... cela s'est traduit par une centaine de messages par
jour... venant s'ajouter aux quelques 200 messages que je reçois déjà,
principalement des spams non sollicités et le plus souvent abusifs, qu'il
me faut trier quotidiennement, en dépit des filtres installés. Alors je
me suis désabonné, ce qui a encore demandé un certain temps.
Aujourd'hui, j'ai décidé de poster dans ces groupes sans recevoir
systématiquement tous les courriers, non par une option "no-mail"
inexistante sur ce système, mais par une gestion du type usenet via
gmane.org. Cà m'a pris un certain temps que de trouver cette alternative.
Le gestionnaire du système (ou le robot en charge d'iceluy) m'a
finalement confirmé que mon courrier au groupe serait posté dans une
dizaine de minutes, mais une dizaine d'heures ont passé, et ce n'est pas
encore paru !


Bernard
Le #1883305
Le Wed, 11 Apr 2007 22:11:02 +0200, msegura a écrit :

Bonjour,

Je reprends l'installation de mon imprimante HP Deskjet 11120C

etc..

as tu -upgradé- ton systeme en passant de Sarge à Etch par exemple.Sinon

pose ta quetion sur des forums Debian -nombreux sur Internet.


Voilà, j'ai pas mal progressé. J'ai, en effet, compris que je suis
passé, sans vraiment l'avoir voulu, de Debian SARGE à Debian ETCH, à
cause d'une seconde d'inattention : j'avais tapé

#apt-get upgrade

au lieu de

#apt-get update

C'est pourquoi je ne pouvais plus réinstaller 'cupsys' précisément
désinstallé avant l'upgrade : il fallait d'abord réinstaller des
paquets que l'upgrade n'avait pas cru bon installer (car cupsys alors
absent).

Alors j'ai ré-installé, un par un, les packages manquants, et j'ai pu
finalement réinstaller cupsys, ainsi qu'une version de hplip plus
récente que celle dont je disposais précédemment. Mon imprimante est à
nouveau reconnue, elle fonctionne bien mieux que précédemment, étant
incomplètement et mal gérée par l'ancienne version de hplip.

Mais tout ne fonctionne pas encore !

L'imprimante fonctionne sous OpenOffice. Elle fonctionne aussi sous GIMP,
depuis que j'ai installé le package 'gimp-print' (sans ce package, çà
ne fonctionnait pas avec GIMP, alors même que çà marchait avec
OpenOffice...)

Mais je n'arrive pas à imprimer avec Mozilla !

Autres étrangetés :

mon imprimante s'appelle 'DeskJet-1120C', avec cette orthographe précise,
le D et le J majuscule, le tiret et pas d'espace avant le C. C'est ainsi
qu'elle est détectée par le système, ainsi que dans CUPS (avec
http://localhost:631), et dans OpenOffice (boîte Printer Settings). Les
imprimantes listables dans OpenOffice, dans GIMP et dans Mozilla, sont
'lp1' et 'DeskJet-1120C'.

lpr -Plp1 filename n'imprime que des fichiers textes, et encore, à
conditions qu'ils ne comportent pas de caractères accentués ; çà
imprime des signes ccabalistiques avec OpenOffice, Gimp ou Mozilla.

Par contre: 'lpr -PDeskJet-1120C filename' me répond:

DeskJet-1120C unknown printer ! Va comprendre ! L'une (lp1) a été
configurée avec "lpd", l'autre avec cups, peut-être est-ce là
l'explication ?

En tous cas, ma question est désormais la suivante : comment faire
fonctionner mon imprimante avec Mozilla-firefox et mozilla-thunderbird ?
Firefox ne me propose que des imprimantes postscript, l'une s'appelant
'postscript printer lp1' et l'autre 'postscript printer DeskJet-1120C'

Et comment puis-je espérer vider un fichier d'imprimante en cas de
problème, étant donné que: 'lprm -PDeskJet-1120C me répond que cette
imprimante n'existe pas ! 'lprm -Plp1 fonctionne toujours s'il y a une
file d'attente non purgée, mais cela ne m'est guère utile, car je
n'imprimerai sans doute rien avec lp1. Devrai-je donc systématiquement
faire appel à localhost:631 pour vider les files d'attente de mon
imprimante ?

Merci d'avance pour toute contribution utile


vibrato
Le #1883301

Bonjour,

Je reprends l'installation de mon imprimante HP Deskjet 11120C après
mes efforts du 13 au 21 janvier (précédente enfilade) interrompus par
manque de temps disponible. Nicolas G. m'avait alors fait remarquer que
la version de HPLIP que j'avais installée (celle disponible pour Debian
SARGE en Stable), n'était pas compatible car trop ancienne. J'avais
précédemment tenté de désinstaller et réinstaller un certain nombre
de choses, dont CUPS, HPLIP et autres, avec au final le même résultat
que précédemment et, ne sachant pas où récupérer et comment
installer la version plus récente de HPLIP, j'avais fait une pause...
jusqu'à ce jour.

Aujourd'hui donc, j'ai, à nouveau, tenté de désinstaller cupsys,
hplip... mais, cette fois, je n'arrive pas à réinstaller. Je pense que
la différence avec la fois précédente est ceci : pour les
désinstallations, j'ai ajouté l'option '--purge'. En tout état de
cause, désormais, la commande :

apt-get install cupsys

me répond le copié collé suivant :

********************

# apt-get install cupsys -s
Lecture des listes de paquets... Fait Construction de l'arbre des
dépendances... Fait Certains paquets ne peuvent être installés. Ceci
peut signifier que vous avez demandé l'impossible, ou bien, si vous
utilisez la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.

Puisque vous n'avez demandé qu'une seule opération, le paquet n'est
probablement pas installable et vous devriez envoyer un rapport de
bogue. L'information suivante devrait vous aider à résoudre la
situation :

Les paquets suivants contiennent des dépendances non satisfaites :
cupsys: Dépend: gs-esp mais ne sera pas installé
E: Paquets défectueux

*********************

La tentative d'installation de gs-esp me dit à peu près la même
chose, à ceci près que c'est ici

.......
Les paquets suivants contiennent des dépendances non satisfaites :
gs-esp: Dépend: libice6 (>= 1:1.0.0) mais 4.3.0.dfsg.1-14sarge3 devra
être installé
E: Paquets défectueux

*******************

et ainsi de suite... Il en va de même pour toute tentative de
réinstaller HPLIP, là c'est précisément cupsys qui est prérequis...

J'imagine avoir fait une grosse bétise en désinstallant ces deux
packages avec l'option "purge". Pourtant, la réinstallation dans les
conditions précédentes ne me permettrait pas de faire fonctionner
normalement mon imprimante. Actuellement elle ne fonctionne plus du tout
; précédemment, elle fonctionnait uniquement avec OpenOffice grâce à
CUPS, mais pas sous GIMP.

Merci d'avance à qui voudra bien m'aider à réinstaller cups et hplip
dans des versions suffisamment récentes pour fonctionner avec mon
imprimante.

BJ,

as tu -upgradé- ton systeme en passant de Sarge à Etch par exemple.Sinon
pose ta quetion sur des forums Debian -nombreux sur Internet.



oui, j'ai upgradé contre ma volonté, mais je ne sais pas à quoi je suis
passé. Il y a peu de jours, en effet, j'ai voulu faire un "update" par :

#apt-get update

or voici que ma distraction m'a fait écrire "upgrade" à la place de
"update" !! L'opération à duré plus d'une demi-heure, et je n'ai osé
rien faire pour l'interrompre. A la fin, çà m'a posé des questions sur
la façon de configurer le raid logiciel (ce n'est pas moi qui l'avais
configuré au départ) et j'ai répondu au hasard. Lorsque, après un
shutdown, la machine a redémarré normalement, j'ai presque cru au
miracle :=)

Comment savoir si je suis passé à "etch" ? En fait, dans mon fichier
sources.list, je n'ai pas les répertoires me permettant d'accéder à
autre chose qu'à "main" et "stable". Ah mais zut, au fait, j'ai fait
divers essais et modifs, et il n'est pas impossible qu'au moment précis
où j'ai fait un "upgrade" à la place d'un "update", j'ai eu un
sources.list ouvert à d'autres répertoires )=<

Merci de me dire ce que je dois faire. Quant aux newsgroups DEBIAN,
mouais, j'en suis à la seconde tentative pour y accéder. news.free.fr
permet d'y accéder en Read Only. Il y a plusieurs semaines, après une
info pas facile à trouver, j'ai compris qu'il s'agissait de listes de
diffusion, qu'il fallait s'y inscrire. Je l'ai fait. Cà a demandé un
moment. Finalement, une semaine après, je me suis retrouvé abonné à
ces groupes, et... cela s'est traduit par une centaine de messages par
jour... venant s'ajouter aux quelques 200 messages que je reçois déjà,
principalement des spams non sollicités et le plus souvent abusifs, qu'il
me faut trier quotidiennement, en dépit des filtres installés. Alors je
me suis désabonné, ce qui a encore demandé un certain temps.
Aujourd'hui, j'ai décidé de poster dans ces groupes sans recevoir
systématiquement tous les courriers, non par une option "no-mail"
inexistante sur ce système, mais par une gestion du type usenet via
gmane.org. Cà m'a pris un certain temps que de trouver cette alternative.
Le gestionnaire du système (ou le robot en charge d'iceluy) m'a
finalement confirmé que mon courrier au groupe serait posté dans une
dizaine de minutes, mais une dizaine d'heures ont passé, et ce n'est pas
encore paru !


Bonsoir,

je consulte souvent ce forum-
http://forum.debian-fr.org/
Inscription obligatoire pour poser une question -reactif tres vite pour
les reponses sur le site meme -pas dans ta boite mail !!!!tu peux
demander à ce qu'on te previenne par mail s'il y a des reponses à ta
question mais c'est une option ..... Fais l'effort de consulter les
Archives -Faq du groupe -la section Trucs et Astuces - avant de demander
de l'aide . Nombre de problemes techniques sont recurrents en
particulier pour les imprimantes et sont donc déjà traites . Les tutos
sont bien faits et clairs. Le groupe dynamique et performant- attention
pas de style sms à l'ecrit .
Debian v4 vient de sortir - essaie de l'installer au plus vite ( vois
les explications detaillées des differentes options d'installation sur
le forum ) .
Bon courage



Bernard
Le #1883297
Le Thu, 12 Apr 2007 20:41:57 +0200, vibrato a écrit :


Bonjour,

Je reprends l'installation de mon imprimante HP Deskjet 11120C après

Bonsoir,




je consulte souvent ce forum-
http://forum.debian-fr.org/
Inscription obligatoire pour poser une question -reactif tres vite pour
les reponses sur le site meme -pas dans ta boite mail !!!!tu peux demander
à ce qu'on te previenne par mail s'il y a des reponses à ta question
mais c'est une option ..... Fais l'effort de consulter les Archives -Faq
du groupe -la section Trucs et Astuces - avant de demander de l'aide .
Nombre de problemes techniques sont recurrents en particulier pour les
imprimantes et sont donc déjà traites . Les tutos sont bien faits et
clairs. Le groupe dynamique et performant- attention pas de style sms à
l'ecrit .
Debian v4 vient de sortir - essaie de l'installer au plus vite ( vois les
explications detaillées des differentes options d'installation sur le
forum ) .
Bon courage


Merci pour ces infos. Entretemps, je suis passé en effet à Debian 4
(Etch) sans le vouloir... (voir mon précédent post), mon inattention
m'ayant porté à taper '#apt-get upgrade' au lieu de "apt-get update' !! =)

Et ce n'est pas une plaisanterie ! Il a ensuite fallu rajuster pas mal
de choses, mais c'est meilleur. Tout ne fonctionne pas encore, cependant.
Avant que de parler de ce qui pèche, j'attends voir s'il y a des
réponses dans les groupes dans lesquels j'ai déjà posé des questions,
et notamment des groupes de la hiérarchie 'linux.debian...'. Il se
pourrait que celui dont tu parles ci-haut soit commun avec un de ceux-là,
je vais, quoiqu'il en soit, le consulter.

Bien cordialement,

Bernard DEBREIL




Publicité
Poster une réponse
Anonyme