Configuration réseau avec machine virtuelle

Le
JKB
Bonjour à tous,

Pour un certain nombre de raisons un peu trop compliquées à
expliquer ici, je dois me balader avec une machine fonctionnant sous
OpenVMS. Mon Alphaserver étant un peu trop encombrante, j'ai
installé la dernière version de simh, fait fait une image du disque
système de mon VAX et après quelques menues configurations, l'engin
boote et accède au réseau.

J'ai donc dans un xterm la console de l'opérateur d'un Vaxserver
3900 capable d'accéder de façon totalement transparente à un réseau
DecNET (c'est le but principal de la chose).

L'ennui, c'est que la console de l'opérateur est polluée de tous les
messages de l'OS (c'est un peu comme si syslog() redirigeait les
messages sous Unix vers /var/log/syslog et vers la console) et qu'il
est très difficile d'utiliser un simple éditeur de texte.

Mon problème est alors simple :
- OpenVMS tournant dans simh possède l'adresse 192.168.0.45 et
accède au réseau (et à internet) en TCP/IP et en DecNET ;
- Linux (le système hôte) accède au réseau normalement avec sa
propre adresse 192.168.0.4 ;
- si je suis sur une machine tierce, je peux lancer un telnet sur le
VAX :

rayleigh:[~] > telnet 192.168.0.45
Trying 192.168.0.45
Connected to 192.168.0.45.
Escape character is '^]'.


Welcome to OpenVMS (TM) VAX Operating System, Version V7.3

Username:
telnet> quit
Connection closed.

Mais depuis la machine qui fait tourner simh, je ne peux pas me
connecter en telnet (ça part en timeout sur une requête ARP) et depuis
VMS, je n'arrive pas à voir la machine hôte.

Ça m'arrangerait pourtant de pouvoir faire un telnet directement
depuis un xterm vers la machine virtuelle. Je suppose que cela doit
pouvoir se faire, mais j'avoue ne pas avoir trouvé.

Une idée ?

Cordialement,

JKB

--
Si votre demande me parvient sur carte perforée, je titiouaillerai très
volontiers une réponse
=> http://grincheux.de-charybde-en-scylla.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Emmanuel Florac
Le #24489321
Le Sat, 19 May 2012 08:23:30 +0000, JKB a écrit:

. Je suppose que cela doit pouvoir se
faire, mais j'avoue ne pas avoir trouvé.



Je suppose que ça ne doit pas, parce que la doc dit que ça ne marche pas:

http://www.retrocomputinggeek.com/retrowiki/SIMHNetworking

Bon, ils expliquent comment s'en tirer quand même, mais ça n'a pas l'air
d'aller de soi :)

--
Yet the gross national product does not allow for the health of our
children, the quality of their education, or the joy of their play. It
does not include the beauty of our poetry or the strength of our
marriages; the intelligence of our public debate or the integrity of our
public officials. It measures neither our wit nor our courage; neither
our wisdom nor our learning; neither our compassion nor our devotion to
our country; it measures everything, in short, except that which makes
life worthwhile. And it tells us everything about America except why we
are proud that we are Americans.
Robert F. Kennedy.
Pascal Hambourg
Le #24489311
Salut,

Emmanuel Florac a écrit :
Le Sat, 19 May 2012 08:23:30 +0000, JKB a écrit:

. Je suppose que cela doit pouvoir se
faire, mais j'avoue ne pas avoir trouvé.



Je suppose que ça ne doit pas, parce que la doc dit que ça ne marche pas:

http://www.retrocomputinggeek.com/retrowiki/SIMHNetworking



Pour ma part je suis tombé sur ça, qui explique aussi pourquoi ça ne
marche pas :

<extrait>
It's likely you'll have problems getting the emulator and the
environment in which it runs (say, Linux) to communicate with each other
on the same machine. The reason for this is simple: the Ethernet card
sends a packet out onto the network under one MAC address looking for a
MAC address that's actually also served by the same card. By design,
Ethernet cards don't receive their own traffic, so the result is that
the packet disappears, well, into the ether. If this is a problem, the
simplest solution is to put a second Ethernet card into the machine and
dedicate it to SIMH; communication between the emulator and its host
environment will then take place via the network just as if the emulator
were running on a physically separate machine.
</extrait>

Bon, ils expliquent comment s'en tirer quand même, mais ça n'a pas l'air
d'aller de soi :)



Si la solution de la seconde carte réseau n'est pas envisageable, il y a
quand même plus simple maintenant : une paire d'interfaces virtuelles
gérées directement par le noyau avec le pilote veth.
En associant une interface de la paire à simh et l'autre à un pont avec
l'interface physique, ça devrait le faire.
JKB
Le #24489301
Le Sat, 19 May 2012 11:57:29 +0200,
Pascal Hambourg
Salut,

Emmanuel Florac a écrit :
Le Sat, 19 May 2012 08:23:30 +0000, JKB a écrit:

. Je suppose que cela doit pouvoir se
faire, mais j'avoue ne pas avoir trouvé.



Je suppose que ça ne doit pas, parce que la doc dit que ça ne marche pas:

http://www.retrocomputinggeek.com/retrowiki/SIMHNetworking



Pour ma part je suis tombé sur ça, qui explique aussi pourquoi ça ne
marche pas :

<extrait>
It's likely you'll have problems getting the emulator and the
environment in which it runs (say, Linux) to communicate with each other
on the same machine. The reason for this is simple: the Ethernet card
sends a packet out onto the network under one MAC address looking for a
MAC address that's actually also served by the same card. By design,
Ethernet cards don't receive their own traffic, so the result is that
the packet disappears, well, into the ether. If this is a problem, the
simplest solution is to put a second Ethernet card into the machine and
dedicate it to SIMH; communication between the emulator and its host
environment will then take place via the network just as if the emulator
were running on a physically separate machine.
</extrait>

Bon, ils expliquent comment s'en tirer quand même, mais ça n'a pas l'air
d'aller de soi :)



Si la solution de la seconde carte réseau n'est pas envisageable, il y a
quand même plus simple maintenant : une paire d'interfaces virtuelles
gérées directement par le noyau avec le pilote veth.
En associant une interface de la paire à simh et l'autre à un pont avec
l'interface physique, ça devrait le faire.



Bonjour,

Pourrais-tu être plus explicite ? J'ai essayé hier de bricoler avec
une interface tap0 et de la bridger avec eth0 et le résultat n'était
pas réellement concluant...

Cordialement,

JKB

--
Si votre demande me parvient sur carte perforée, je titiouaillerai très
volontiers une réponse...
=> http://grincheux.de-charybde-en-scylla.fr
Pascal Hambourg
Le #24489431
JKB a écrit :
Pascal Hambourg
Si la solution de la seconde carte réseau n'est pas envisageable, il y a
quand même plus simple maintenant : une paire d'interfaces virtuelles
gérées directement par le noyau avec le pilote veth.
En associant une interface de la paire à simh et l'autre à un pont avec
l'interface physique, ça devrait le faire.



Pourrais-tu être plus explicite ? J'ai essayé hier de bricoler avec
une interface tap0 et de la bridger avec eth0 et le résultat n'était
pas réellement concluant...



Il y avait quoi à l'autre bout de tap0 ?

Voici comment je vois le montage (pas testé) :

# creation de la paire d'interfaces veth
ip link add type veth
# cela cree veth0 et veth1
# on choisit que veth0 sera associee a simh et veth1 au pont

# creation du pont
brctl addbr br0

# association de l'interface ethernet physique au pont
brctl addif br0 eth0

# association de veth1 au pont
brctl addif br0 veth1

# activation des interfaces
ifconfig veth0 up
ifconfig veth1 up
ifconfig br0 up

La configuration IP de la machine hôte doit maintenant être sur br0 et
non plus sur eth0.
Emmanuel Florac
Le #24489531
Le Sat, 19 May 2012 09:59:33 +0000, JKB a écrit:

Pourrais-tu être plus explicite ? J'ai essayé hier de bricoler avec une
interface tap0 et de la bridger avec eth0 et le résultat n'était pas
réellement concluant...



Dis, t'as pensé à utiliser taptap comme indiqué dans le lien que je t'ai
donné? Le pourquoi et le comment est bien expliqué sur le wiki
retrocomputing...

--
My assertion that we can do better with computer languages is a
persistent belief and fond hope, but you'll note I don't actually claim
to be either rational or right. Except when it's convenient.
Larry Wall
JKB
Le #24489521
Le 19 May 2012 11:03:26 GMT,
Emmanuel Florac
Le Sat, 19 May 2012 09:59:33 +0000, JKB a écrit:

Pourrais-tu être plus explicite ? J'ai essayé hier de bricoler avec une
interface tap0 et de la bridger avec eth0 et le résultat n'était pas
réellement concluant...



Dis, t'as pensé à utiliser taptap comme indiqué dans le lien que je t'ai
donné? Le pourquoi et le comment est bien expliqué sur le wiki
retrocomputing...



J'ai utilisé la doc de simh sur le site hoffman-labs qui est la
référence VMS et qui parlait d'utiliser une interface tap0 avec un
bridge sur eth0. Je vais essayer de trouver un peu de temps ce
week-end pour configurer la chose.

Merci pour les tuyaux, je ferai un compte rendu de mes essais ici.

JKB

--
Si votre demande me parvient sur carte perforée, je titiouaillerai très
volontiers une réponse...
=> http://grincheux.de-charybde-en-scylla.fr
dominique1278 Hors ligne
Le #26394608
Le samedi 19 Mai 2012 à 10:23 par JKB :
Bonjour à tous,

Pour un certain nombre de raisons un peu trop compliquées à
expliquer ici, je dois me balader avec une machine fonctionnant sous
OpenVMS. Mon Alphaserver étant un peu trop encombrante, j'ai
installé la dernière version de simh, fait fait une image du
disque
système de mon VAX et après quelques menues configurations,
l'engin
boote et accède au réseau.

J'ai donc dans un xterm la console de l'opérateur d'un Vaxserver
3900 capable d'accéder de façon totalement transparente à
un réseau
DecNET (c'est le but principal de la chose).

L'ennui, c'est que la console de l'opérateur est polluée de tous
les
messages de l'OS (c'est un peu comme si syslog() redirigeait les
messages sous Unix vers /var/log/syslog et vers la console) et qu'il
est très difficile d'utiliser un simple éditeur de texte.

Mon problème est alors simple :
- OpenVMS tournant dans simh possède l'adresse 192.168.0.45 et
accède au réseau (et à internet) en TCP/IP et en DecNET
;
- Linux (le système hôte) accède au réseau
normalement avec sa
propre adresse 192.168.0.4 ;
- si je suis sur une machine tierce, je peux lancer un telnet sur le
VAX :

rayleigh:[~] > telnet 192.168.0.45
Trying 192.168.0.45...
Connected to 192.168.0.45.
Escape character is '^]'.


Welcome to OpenVMS (TM) VAX Operating System, Version V7.3

Username:
telnet> quit
Connection closed.

Mais depuis la machine qui fait tourner simh, je ne peux pas me
connecter en telnet (ça part en timeout sur une requête ARP) et
depuis
VMS, je n'arrive pas à voir la machine hôte.

Ça m'arrangerait pourtant de pouvoir faire un telnet directement
depuis un xterm vers la machine virtuelle. Je suppose que cela doit
pouvoir se faire, mais j'avoue ne pas avoir trouvé.

Une idée ?

Cordialement,

JKB

--
Si votre demande me parvient sur carte perforée, je titiouaillerai
très
volontiers une réponse...
=> http://grincheux.de-charybde-en-scylla.fr


Le site www.alphorm.com peut donner aussi des idées à tout le monde sur la machine virtuelle. Là, vous pourrez trouver les tutoriels dont vous aurez besoin pour solutionner ce genre de problème. Essayez comme moi et vous verrez
Publicité
Poster une réponse
Anonyme