Configuration réseau dans un VLAN

Le
David BERCOT
Bonjour,

Afin de gérer des serveurs ESXi situés dans un VLAN, je souhaiter=
ais
configurer ma station Debian dans le même VLAN.

J'ai donc fait quelques recherches et suivi les recommendations en la
matière :
# ip link add link eth0 name eth0.1001 type vlan id 1001
# ip addr add 192.168.0.50/24 brd 192.168.0.255 dev eth0.1001
# ip link set dev eth0.1001 up

Or, une fois cette configuration mise en place (et apparemment bonne),
impossible de joindre les ESXi

Auriez-vous une piste qui pourrait m'aider ?

Merci d'avance.

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20121208175417.4803ec76@debian-david
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pascal Hambourg
Le #25035732
Salut,

David BERCOT a écrit :

Afin de gérer des serveurs ESXi situés dans un VLAN, je souhaiterais
configurer ma station Debian dans le même VLAN.

J'ai donc fait quelques recherches et suivi les recommendations en la
matière :
# ip link add link eth0 name eth0.1001 type vlan id 1001
# ip addr add 192.168.0.50/24 brd 192.168.0.255 dev eth0.1001
# ip link set dev eth0.1001 up

Or, une fois cette configuration mise en place (et apparemment bonne),
impossible de joindre les ESXi...



Le port du switch connecté à la station Debian est-il configuré pour le
trafic taggé de ce VLAN ?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
David BERCOT
Le #25035862
Le Sat, 08 Dec 2012 18:18:18 +0100,
Pascal Hambourg
Salut,

David BERCOT a écrit :

Afin de gérer des serveurs ESXi situés dans un VLAN, je souhai terais
configurer ma station Debian dans le même VLAN.

J'ai donc fait quelques recherches et suivi les recommendations en la
matière :
# ip link add link eth0 name eth0.1001 type vlan id 1001
# ip addr add 192.168.0.50/24 brd 192.168.0.255 dev eth0.1001
# ip link set dev eth0.1001 up

Or, une fois cette configuration mise en place (et apparemment
bonne), impossible de joindre les ESXi...



Le port du switch connecté à la station Debian est-il configur é pour le
trafic taggé de ce VLAN ?



En effet, il l'est... D'ailleurs, les ESXi se "voient" entre eux...

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
nono
Le #25036222
--=-McYjNk29Bk0IZUEV2c/1
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

Le samedi 08 décembre 2012 à 19:02 +0100, David BERCOT a écr it :
Le Sat, 08 Dec 2012 18:18:18 +0100,
Pascal Hambourg >Salut,
>
>David BERCOT a écrit :
>>
>> Afin de gérer des serveurs ESXi situés dans un VLAN, je souh aiterais
>> configurer ma station Debian dans le même VLAN.
>>
>> J'ai donc fait quelques recherches et suivi les recommendations en la
>> matière :
>> # ip link add link eth0 name eth0.1001 type vlan id 1001
>> # ip addr add 192.168.0.50/24 brd 192.168.0.255 dev eth0.1001
>> # ip link set dev eth0.1001 up



Que donne un « ip -s link » ? C'est juste pour savoir si il y a-t -il des
paquets en réception sur l'interface ? Exemple de résultat :

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast
state UP qlen 1000
link/ether 00:46:3h:47:fd:e5 brd ff:ff:ff:ff:ff:ff
RX: bytes packets errors dropped overrun mcast
89127021 61263 0 0 0 0
TX: bytes packets errors dropped carrier collsns
2270969 31921 0 0 0 0


nono

>>
>> Or, une fois cette configuration mise en place (et apparemment
>> bonne), impossible de joindre les ESXi...
>
>Le port du switch connecté à la station Debian est-il configur é pour le
>trafic taggé de ce VLAN ?

En effet, il l'est... D'ailleurs, les ESXi se "voient" entre eux...

David.





--=-McYjNk29Bk0IZUEV2c/1
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: This is a digitally signed message part

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEABECAAYFAlDDkp4ACgkQsuWx6lZRvlvlWQCdFSU/BEeqFLPbgpFPyMRXtIu/
FBYAoLUvQ3sEEnlwGcCX0wjHP5kMUQlc
’qG
-----END PGP SIGNATURE-----

--=-McYjNk29Bk0IZUEV2c/1--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Pascal Hambourg
Le #25036342
David BERCOT a écrit :
Le Sat, 08 Dec 2012 18:18:18 +0100,

Or, une fois cette configuration mise en place (et apparemment
bonne), impossible de joindre les ESXi...







Au fait, comment se caractérise *d'un point de vue réseau IP/ethernet*
"joindre les ESXi" et "impossible de..." précisément ?

Le port du switch connecté à la station Debian est-il configuré pour le
trafic taggé de ce VLAN ?



En effet, il l'est... D'ailleurs, les ESXi se "voient" entre eux...



Les ESXi sont connectés sur d'autres ports du switch, dont je ne vois
pas en quoi c'est pertinent. Ou alors je n'ai pas tout compris.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
David BERCOT
Le #25036542
Le Sat, 08 Dec 2012 20:40:18 +0100,
Pascal Hambourg
David BERCOT a écrit :
Le Sat, 08 Dec 2012 18:18:18 +0100,

Or, une fois cette configuration mise en place (et apparemment
bonne), impossible de joindre les ESXi...







Au fait, comment se caractérise *d'un point de vue réseau IP/eth ernet*
"joindre les ESXi" et "impossible de..." précisément ?



OK, je développe un peu... Donc, à partir d'un ESXi, un ping vers un
autre ESXi répond...

Le port du switch connecté à la station Debian est-il configu ré
pour le trafic taggé de ce VLAN ?



En effet, il l'est... D'ailleurs, les ESXi se "voient" entre eux...



Les ESXi sont connectés sur d'autres ports du switch, dont je ne vois
pas en quoi c'est pertinent. Ou alors je n'ai pas tout compris.



J'ai configuré tous les ports du switch de la même manière e t, même en
changeant de port, le résultat est identique...

David.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
David BERCOT
Le #25036552
Le Sat, 08 Dec 2012 20:19:01 +0100,
nono
>> J'ai donc fait quelques recherches et suivi les recommendations
>> en la matière :
>> # ip link add link eth0 name eth0.1001 type vlan id 1001
>> # ip addr add 192.168.0.50/24 brd 192.168.0.255 dev eth0.1001
>> # ip link set dev eth0.1001 up



Que donne un « ip -s link » ? C'est juste pour savoir si il y a- t-il
des paquets en réception sur l'interface ? Exemple de résultat :

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast
state UP qlen 1000
link/ether 00:46:3h:47:fd:e5 brd ff:ff:ff:ff:ff:ff
RX: bytes packets errors dropped overrun mcast
89127021 61263 0 0 0 0
TX: bytes packets errors dropped carrier collsns
2270969 31921 0 0 0 0



Là, je ne suis plus dans cette configuration. Mais, dès que possi ble,
je ferai le test...

Merci.

David.

P.S. : je suppose que, si tu réponds ça, c'est que la procéd ure
utilisée doit être plutôt dans les clous ;-)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
David Hannequin
Le #25036562
Bonjour,

Ton problème n'a que peu de chose à voir avec la distribution Linu x Debian mais c'est un problème de configuration de ton switch au nivea u Vlan.

Envoyé de mon iPhone

Le 8 déc. 2012 à 20:40, Pascal Hambourg
David BERCOT a écrit :
Le Sat, 08 Dec 2012 18:18:18 +0100,

Or, une fois cette configuration mise en place (et apparemment
bonne), impossible de joindre les ESXi...







Au fait, comment se caractérise *d'un point de vue réseau IP/eth ernet*
"joindre les ESXi" et "impossible de..." précisément ?

Le port du switch connecté à la station Debian est-il configur é pour le
trafic taggé de ce VLAN ?



En effet, il l'est... D'ailleurs, les ESXi se "voient" entre eux...



Les ESXi sont connectés sur d'autres ports du switch, dont je ne vois
pas en quoi c'est pertinent. Ou alors je n'ai pas tout compris.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
David Hannequin
Le #25036702
À mon avis c'est uniquement un problème de configuration au niveau de tes vlan. Pour ma par j'ai ce type de configuration au taff et ça m arche sans souscis. Est ce que tu as le paquet vlan sur ta debian ( je suppo se que oui mais à tout hasard ) ?

Envoyé de mon iPhone

Le 8 déc. 2012 à 22:09, David BERCOT
Le Sat, 08 Dec 2012 20:19:01 +0100,
nono
J'ai donc fait quelques recherches et suivi les recommendations
en la matière :
# ip link add link eth0 name eth0.1001 type vlan id 1001
# ip addr add 192.168.0.50/24 brd 192.168.0.255 dev eth0.1001
# ip link set dev eth0.1001 up







Que donne un « ip -s link » ? C'est juste pour savoir si il y a -t-il
des paquets en réception sur l'interface ? Exemple de résultat :

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast
state UP qlen 1000
link/ether 00:46:3h:47:fd:e5 brd ff:ff:ff:ff:ff:ff
RX: bytes packets errors dropped overrun mcast
89127021 61263 0 0 0 0
TX: bytes packets errors dropped carrier collsns
2270969 31921 0 0 0 0



Là, je ne suis plus dans cette configuration. Mais, dès que poss ible,
je ferai le test...

Merci.

David.

P.S. : je suppose que, si tu réponds ça, c'est que la procé dure
utilisée doit être plutôt dans les clous ;-)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
nono
Le #25072622
--=-YkI4KcO+2Q3rhHq/v/Fm
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

Le samedi 08 décembre 2012 à 22:07 +0100, David BERCOT a écr it :
Le Sat, 08 Dec 2012 20:40:18 +0100,
Pascal Hambourg >David BERCOT a écrit :
>> Le Sat, 08 Dec 2012 18:18:18 +0100,
>>>>
>>>> Or, une fois cette configuration mise en place (et apparemment
>>>> bonne), impossible de joindre les ESXi...
>
>Au fait, comment se caractérise *d'un point de vue réseau IP/e thernet*
>"joindre les ESXi" et "impossible de..." précisément ?

OK, je développe un peu... Donc, à partir d'un ESXi, un ping ve rs un
autre ESXi répond...

>>> Le port du switch connecté à la station Debian est-il confi guré
>>> pour le trafic taggé de ce VLAN ?
>>
>> En effet, il l'est... D'ailleurs, les ESXi se "voient" entre eux...
>
>Les ESXi sont connectés sur d'autres ports du switch, dont je ne vo is
>pas en quoi c'est pertinent. Ou alors je n'ai pas tout compris.

J'ai configuré tous les ports du switch de la même manière et, même en
changeant de port, le résultat est identique...



Si les ports de ton switch appartiennent à 1 seul vlan et que ta debia n
est branchée sur un de ces port (à priori sans tag, je suppose).. .
alors je pense que tu devrais configurer l'interface de ta debian eth0
sans identifier un quelconque vlan, donc sans tag, et cela fonctionnera
beaucoup mieux. En gros, configure ta debian dans le bon réseau IP san s
te soucier des vlan :

ip addr add 192.168.0.50/24 brd 192.168.0.255 dev eth0
ip link set dev eth0 up

nono


David.





--=-YkI4KcO+2Q3rhHq/v/Fm
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: This is a digitally signed message part

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEABECAAYFAlDR5WcACgkQsuWx6lZRvluhYwCdHix6LZCnZVdB++wKKrcT/N/I
Hd4AoLse/tN8xN8rTjMCeoQtbaiWBJi+
=4nPq
-----END PGP SIGNATURE-----

--=-YkI4KcO+2Q3rhHq/v/Fm--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme