Configurer un proxy pour dellomsa ?

Le
Frédéric Massot
Bonjour,

J'ai le logicel Dell OpenManage Server (paquet dellomsa) qui tourne sur
un serveur Dell avec une Debian Squezze.

Ce logiciel écoute sur le port TCP/1311 sur la boucle local (localhost).
C'est du HTTPS sur le port 1311.

J'essaye de configurer un hôte virtuel Apache en proxy pour pouvoir
accéder à OMSA sur le port 443.

J'ai donc la configuration suivante :

<VirtualHost serveur.chez.moi:443>

ServerName omsa.chez.moi

ErrorLog /var/log/apache2/omsa.chez.moi-error.log
CustomLog /var/log/apache2/omsa.chez.moi-access.log combined

<Proxy *>
Order deny,allow
Allow from all
</Proxy>

ProxyRequests Off

ProxyPass / https://127.0.0.1:1311/
ProxyPassReverse / https://127.0.0.1:1311/

</VirtualHost>


Cela ne fonctionne pas et je n'ai aucune traces dans les logs :o(

Voyez-vous ce qui ne va pas ?


Merci.
--
=
| FRÉDÉRIC MASSOT |
| http://www.juliana-multimedia.com |
| mailto:frederic@juliana-multimedia.com |
==Þbian=GNU/Linux

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Allaedine El Banna
Le #20418431
Frédéric Massot à 19:30 :
> >
> ServerName omsa.chez.moi
>
> ErrorLog /var/log/apache2/omsa.chez.moi-error.log
> CustomLog /var/log/apache2/omsa.chez.moi-access.log combined
>
> <Proxy *>
> Order deny,allow
> Allow from all
> </Proxy>
>
> ProxyRequests Off
>
> ProxyPass / https://127.0.0.1:1311/
> ProxyPassReverse / https://127.0.0.1:1311/
>
> </VirtualHost>
>
>
> Cela ne fonctionne pas et je n'ai aucune traces dans les logs :o(
>
> Voyez-vous ce qui ne va pas ?

Bonjour,

personnellement, je ne mets jamais de noms dans la balise <VirtualHost>,
mais seulement une adresse IP et port, ou bien une astérisque suivie
d'un port, comme ceci :

Tentez en remplaçant serveur.chez.moi par l'IP sur laquelle vous placez
votre VHost, ou mettez une astérisque.

Regardez ensuite dans le log d'Apache pour voir s'il n'y a pas encore
une erreur, et/ou lancez un "apache2ctl configtest" si vous utilisez
Apache2.

--
Allaedine El Banna

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Kevin Hinault
Le #20426391
Le 26 octobre 2009 12:09, Frédéric Massot


Je vais me renseigner auprès de l'hebergeur pour voir si il a ouvert le
port 443 vers ce serveur. On sait jamais...




Ca ne pourrait pas être juste une règle iptables oubliée ?

Sinon pour les virtual host, il faut aussi que la directive
NameVirtualHost soit permissive (souvent dans le fichier de virtual
host par defaut) :

NameVirtualHost *:80
NameVirtualHost *:443
etc ..


--
Kévin
Membre de l'April - « promouvoir et défendre le logiciel libre » -
http://www.april.org
http://identi.ca/khi - http://twitter.com/kh_i - http://system-linux.eu
Nick IRC : KevinH sur irc.mozilla.org - irc.debian.org - irc.freenode.net

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Frédéric Massot
Le #20426381
Allaedine El Banna a écrit :

personnellement, je ne mets jamais de noms dans la balise
<VirtualHost>, mais seulement une adresse IP et port, ou bien une
astérisque suivie d'un port, comme ceci : <VirtualHost *:443> ou

Tentez en remplaçant serveur.chez.moi par l'IP sur laquelle vous
placez votre VHost, ou mettez une astérisque.

Regardez ensuite dans le log d'Apache pour voir s'il n'y a pas encore
une erreur, et/ou lancez un "apache2ctl configtest" si vous utilisez
Apache2.



Bonjour,

Merci pour vos réponses.

"apache2ctl configtest" ne donne aucune erreur. Je l'utilise toujours
avant de recharger la configuration d'Apache.

J'ai mis une astérisque suivie du port "443" dans la directive
"VirtualHost", mais cela n'a rien changé. Le navigateur tourne en boucle
jusqu'au timeout (Délai d'attente dépassé). Et les logs sont vides, il
n'y a aucune traces dans les logs de l'hôte virtuel et dans les logs
d'Apache.

Je vais me renseigner auprès de l'hebergeur pour voir si il a ouvert le
port 443 vers ce serveur. On sait jamais...


--
============================================= | FRÉDÉRIC MASSOT |
| http://www.juliana-multimedia.com |
| mailto: |
==========================Þbian=GNU/Linux==
--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme