Conflit libc6, libc6-dev

Le
axelle_apvrille
Bonjour,
Je voudrais installer la libc6-dev. Malheureusement, j'obtiens:
The following packages have unmet dependencies:
libc6-dev: Depends: libc6 (= 2.3.6.ds1-13etch5) but 2.6.1-3 is to be
installed
E: Broken packages

Effectivement, j'ai ma libc6 en 2.6.1-3.
Comment est-ce que je la downgrade en 2.3.6.ds1-13etch5. J'ai essayé de
le faire avec Synaptic, mais cela me signalait que cela allait enlever
tout un tas de packages importants (apt, bash, coreutils, debianutils
etc !). Du coup, j'ai préféré ne pas faire la modif

Quelle est la marche à suivre ?

Merci,
Axelle.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Vincent Lefevre
Le #9710351
Bonjour,

On 2008-02-20 22:28:54 +0100, wrote:
Bonjour,
Je voudrais installer la libc6-dev. Malheureusement, j'obtiens:
The following packages have unmet dependencies:
libc6-dev: Depends: libc6 (= 2.3.6.ds1-13etch5) but 2.6.1-3 is to be
installed
E: Broken packages

Effectivement, j'ai ma libc6 en 2.6.1-3.
Comment est-ce que je la downgrade en 2.3.6.ds1-13etch5.



Peut-être:

apt-get install libc6=2.3.6.ds1-13etch5

Mais ATTENTION! Les downgrade, ce n'est pas supporté officiellement.
Avec un downgrade de la libc6 qui risque d'échouer, tu risques de
casser ton système et de ne plus pouvoir récupérer, car quasiment
tout dépend de la libc6. Je déconseille vivement! (Personnellement,
c'est un truc que je ne ferais jamais sur la libc6, sauf cas très
particuliers.)

Tu ne voudrais pas plutôt essayer d'installer une version plus
récente de libc6-dev?

"apt-cache show libc6-dev" te donne toutes les versions disponibles.

Mais avec les versions actuelles dans testing et unstable, il y a de
fortes chances que tu doives aussi upgrader la libc6 (et éventuellement
d'autres paquets en conséquence). Cf

http://packages.debian.org/search?keywords=libc6&searchon=names&exact=1&suite=all&section=all

Essaie toujours:

apt-get install -t testing libc6-dev

et

apt-get install -t unstable libc6-dev

pour voir ce que apt-get te propose.

J'ai essayé de le faire avec Synaptic, mais cela me signalait que
cela allait enlever tout un tas de packages importants (apt, bash,
coreutils, debianutils etc !). Du coup, j'ai préféré ne pas faire la
modif...



Je n'utilise pas Synaptic (uniquement aptitude et apt-get, avec
lesquels il y a le même genre de problème), mais c'est probablement
parce que ces paquets devraient être upgradés en unstable pour
satisfaire les dépendances, mais il faut l'autoriser explicitement,
en ajoutant les paquets en question à upgrader.

Une autre solution est d'aller récupérer la version 2.6.1-3 de
libc6-dev sur est qu'il n'y aura probablement pas de problème de dépendances.

Maintenant, rester avec une version (de la libc6 ou autre) qui ne se
trouve plus dans les archives principales (stable, testing, unstable),
ce n'est pas l'idéal, surtout s'il y a un trou de sécurité dans la
version en question (pas facile de savoir).

--
Vincent Lefèvre 100% accessible validated (X)HTML - Blog: Work: CR INRIA - computer arithmetic / Arenaire project (LIP, ENS-Lyon)


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme