connexion sur le site pmu en automatique

Le
didiflo Hors ligne
Bonjour,
voila je voudrais me connecter sur le site pmu avec mes identifiant en automatique lorsque je lance une procédure dans mon logiciel
j'ai déjà essayer avec httprequete sa fonctionne pas
je suis donc passer par active x et pilotage de IE mais le problème c'est que j’arrive pas a valider et a me connecter
je réussit a remplir les champs mais c'est tout
voici le code

"// Déclaration de l'objet pour piloter Internet Explorer
CliExplore:InitActiveX()
CliExplore:SetURL("http://www.pmu.fr/turf")
CliExplore:TempoChargement()

// Recherche par nom du champ
SI CliExplore:bRechercheChampParNom("login") ALORS
CliExplore:SetValeur(SAI_numero_compte)

FIN

SI CliExplore:bRechercheChampParNom("password") ALORS
CliExplore:SetValeur(SAI_password)
FIN

SI CliExplore:bRechercheChampParNom("codePinPad") ALORS
CliExplore:SetValeur(SAI_password2)
FIN"

et celui du submit

"
PROCEDURE bSubmit(pnI=0)
// pnI est l'indice du formulaire dont on veut faire le SUBMIT

// Pointeur sur l'objet
pDisp est un objet OLE dynamique

// Tantque la page n'est pas chargée : attente
:TempoChargement()

QUAND EXCEPTION DANS
// Pointeur sur une collection d'objets de type FORM
pDisp = :m_pActiveX>>Document>>getElementsByTagName("FORM")


FAIRE

Erreur("Le document n'est pas accessible.")
RENVOYER Faux
FIN

// L'indice est-il correct ?
SI pnI > pDisp>>length ALORS
Erreur("Indice hors borne.")
RENVOYER Faux
FIN

// s'il y a plusieurs formulaire et qu'aucun indice n'a été précisé
SI pDisp>>length > 1 ET pnI=0 ALORS

Info("Il y a plusieurs formulaires dans cette page.","Il n'est pas possible de déterminer automatiquement sur quel formulaire faire le SUBMIT.")
RENVOYER Faux
FIN


// Sélection du formulaire
pDisp = pDisp>>item(pnI)
SI pDisp<>Null
// Submit
QUAND EXCEPTION DANS
RENVOYER pDisp>>Submit
FAIRE
RENVOYER Faux
FIN
FIN

RENVOYER Faux "

j'ai pris l'exemple de windev mais rien a faire je peut pas me connecter, je suis obliger de cliquer manuellement ce que je veut pas

merci a tous de votre aide
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
akeem421
Le #24851232
Le mercredi 1 août 2012 01:45:34 UTC+2, didiflo a écrit :
Bonjour,

voila je voudrais me connecter sur le site pmu avec mes identifiant en

automatique lorsque je lance une proc�dure dans mon logiciel

j'ai d�j� essayer avec httprequete sa fonctionne pas

je suis donc passer par active x et pilotage de IE mais le probl� me c'est que

j�arrive pas a valider et a me connecter

je r�ussit a remplir les champs mais c'est tout

voici le code



"// D�claration de l'objet pour piloter Internet Explorer

CliExplore:InitActiveX()

CliExplore:SetURL("http://www.pmu.fr/turf")

CliExplore:TempoChargement()



// Recherche par nom du champ

SI CliExplore:bRechercheChampParNom("login") ALORS

CliExplore:SetValeur(SAI_numero_compte)



FIN



SI CliExplore:bRechercheChampParNom("password") ALORS

CliExplore:SetValeur(SAI_password)

FIN



SI CliExplore:bRechercheChampParNom("codePinPad") ALORS

CliExplore:SetValeur(SAI_password2)

FIN"



et celui du submit



"

PROCEDURE bSubmit(pnI=0)

// pnI est l'indice du formulaire dont on veut faire le SUBMIT



// Pointeur sur l'objet

pDisp est un objet OLE dynamique



// Tantque la page n'est pas charg�e : attente

:TempoChargement()



QUAND EXCEPTION DANS

// Pointeur sur une collection d'objets de type FORM

pDisp = :m_pActiveX>>Document>>getElementsByTagName("FORM")





FAIRE



Erreur("Le document n'est pas accessible.")

RENVOYER Faux

FIN



// L'indice est-il correct ?

SI pnI > pDisp>>length ALORS

Erreur("Indice hors borne.")

RENVOYER Faux

FIN



// s'il y a plusieurs formulaire et qu'aucun indice n'a �tï¿ ½ pr�cis�

SI pDisp>>length > 1 ET pnI=0 ALORS



Info("Il y a plusieurs formulaires dans cette page.","Il n'est pas possib le de

d�terminer automatiquement sur quel formulaire faire le SUBMIT.")

RENVOYER Faux

FIN





// S�lection du formulaire

pDisp = pDisp>>item(pnI)

SI pDisp<>Null

// Submit

QUAND EXCEPTION DANS

RENVOYER pDisp>>Submit

FAIRE

RENVOYER Faux

FIN

FIN



RENVOYER Faux "



j'ai pris l'exemple de windev mais rien a faire je peut pas me connecter, je

suis obliger de cliquer manuellement ce que je veut pas



merci a tous de votre aide



Bonjour,
je voudrais savoir si vous avez avancer dans votre connexion automatique su r le site pmu?

cordialement
Publicité
Poster une réponse
Anonyme