Connexion a SQl Server 2000 depuis l'exterieur

Le
batteoui
Bonjour,

j'ai besoin vraiment de votre aide, je vous decrit mon probléme.

Je souhaite me connecter ma base depuis m'exterieur de mon reseau,
voici les manips que j'ai suivi.

A) j'utilise la chaine de connexion : Data
Source=196.211,23.90,1433;Network Library=DBMSSOCN;Initial
Catalog=Mabase;User ID=test;Password=test;

B) j'ai créer un compte utilisateur windows nomé "test" avec un mot de
passe "test", j'ai ajouté cette utilisateur comme "logins" dans la
rubrique de "Security" sur SQL Server, et je lui ai affété le droit
"Owner" sur la base

C) j'ai redirigé le port 1433 vers le Serveur SQL

Aprés le test le connexion, je reçois le message suivant :
"SQL Server n'existe pas ou l'accès est refusé"

Merci de votre aide.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sylvain Lafontaine
Le #11864851
À moins que vous n'ayez un VPN et un domaine configuré en conséquence, vous
ne pouvez pas utiliser de compte windows pour permettre à un utilisateur de
l'extérieur de se connecter. Vous devez créer et utiliser un compte
SQL-Server. Notez aussi que votre machine doit être configuré pour accepter
les logins mixtes (Windows + SQL-Server) puisque par défaut, les comptes
SQL-Server sont désactivés (cela même si vous en avez créé un).

Vérifier aussi que votre installation de SQL-Server est l'instance par
défaut et non pas une instance nommée car dans le cas d'une instance nommée,
vous devez également ajouter son nom après l'adresse du serveur.

--
Sylvain Lafontaine, ing.
MVP - Technologies Virtual-PC
E-mail: sylvain aei ca (fill the blanks, no spam please)


news:
Bonjour,

j'ai besoin vraiment de votre aide, je vous decrit mon probléme.

Je souhaite me connecter ma base depuis m'exterieur de mon reseau,
voici les manips que j'ai suivi.

A) j'utilise la chaine de connexion : Data
Source6.211,23.90,1433;Network LibraryÛMSSOCN;Initial
Catalog=Mabase;User ID=test;Password=test;

B) j'ai créer un compte utilisateur windows nomé "test" avec un mot de
passe "test", j'ai ajouté cette utilisateur comme "logins" dans la
rubrique de "Security" sur SQL Server, et je lui ai affété le droit
"Owner" sur la base

C) j'ai redirigé le port 1433 vers le Serveur SQL

Aprés le test le connexion, je reçois le message suivant :
"SQL Server n'existe pas ou l'accès est refusé"

Merci de votre aide.
batteoui
Le #11864841
Merci bcp pour votre aide,

A) jusqu'a present j'ai pas en reussi a etablir la connexion, j'ai
creé un compte SQL-Server nomé test, ci-join une capture ecran de la
reation du compte
http://apu.mabul.org/up/apu/2007/12/10/img-hqktzhiwf0s.jpg

B) j'ai verifier l'instance de SQL Server installée sur le serveur,
avec le script
---------------------------------------------------------------------------- -
select case
WHEN convert(sysname, serverproperty('InstanceName')) IS NULL THEN
'INSTANCE PAR DEFAUT'
ELSE
convert(sysname, serverproperty('InstanceName'))
END AS INSTANCE_NAME
---------------------------------------------------------------------------
Résultat instant "INSTANCE PAR DEFAUT"

C) j'ai changé l'authentification de SQL-Server à "SQL Server and
Windows"


et j'ai retesté ma connexion a nouveau "Data
SourceA.250.32.106,1433;Network LibraryÛMSSOCN;Initial
Catalog=PharmaGest;User ID=test;Password=test;"
et apparement le meme probleme qui persiste.

y a t il une manip que j'ai loupé ??

Merci encore
On 10 déc, 17:48, "Sylvain Lafontaine" <sylvain aei ca (fill the
blanks, no spam please)> wrote:
À moins que vous n'ayez un VPN et un domaine configuré en conséquenc e, vous
ne pouvez pas utiliser de compte windows pour permettre à un utilisateur de
l'extérieur de se connecter. Vous devez créer et utiliser un compte
SQL-Server. Notez aussi que votre machine doit être configuré pour ac cepter
les logins mixtes (Windows + SQL-Server) puisque par défaut, les comptes
SQL-Server sont désactivés (cela même si vous en avez créé un).

Vérifier aussi que votre installation de SQL-Server est l'instance par
défaut et non pas une instance nommée car dans le cas d'une instance n ommée,
vous devez également ajouter son nom après l'adresse du serveur.



Sylvain Lafontaine
Le #11864831
Un nom tel que D676...test me donne à penser qu'il s'agit toujours d'une
identification Windows (groupe ou utilisateur) et non pas d'une
authentification SQL-Server.

Dans l'option Securité | Connexions (ou Login en anglais) du serveur, est-ce
que le compte Test est décrit comme étant Standard (ce que l'on veut ici) ou
Groupe Windows ou Utilisateur Windows (ce que l'on ne veut pas ici) ?

--
Sylvain Lafontaine, ing.
MVP - Technologies Virtual-PC
E-mail: sylvain aei ca (fill the blanks, no spam please)


news:
Merci bcp pour votre aide,

A) jusqu'a present j'ai pas en reussi a etablir la connexion, j'ai
creé un compte SQL-Server nomé test, ci-join une capture ecran de la
reation du compte
http://apu.mabul.org/up/apu/2007/12/10/img-hqktzhiwf0s.jpg

B) j'ai verifier l'instance de SQL Server installée sur le serveur,
avec le script
-----------------------------------------------------------------------------
select case
WHEN convert(sysname, serverproperty('InstanceName')) IS NULL THEN
'INSTANCE PAR DEFAUT'
ELSE
convert(sysname, serverproperty('InstanceName'))
END AS INSTANCE_NAME
---------------------------------------------------------------------------
Résultat instant "INSTANCE PAR DEFAUT"

C) j'ai changé l'authentification de SQL-Server à "SQL Server and
Windows"


et j'ai retesté ma connexion a nouveau "Data
SourceA.250.32.106,1433;Network LibraryÛMSSOCN;Initial
Catalog=PharmaGest;User ID=test;Password=test;"
et apparement le meme probleme qui persiste.

y a t il une manip que j'ai loupé ??

Merci encore
On 10 déc, 17:48, "Sylvain Lafontaine" <sylvain aei ca (fill the
blanks, no spam please)> wrote:
À moins que vous n'ayez un VPN et un domaine configuré en conséquence,
vous
ne pouvez pas utiliser de compte windows pour permettre à un utilisateur
de
l'extérieur de se connecter. Vous devez créer et utiliser un compte
SQL-Server. Notez aussi que votre machine doit être configuré pour
accepter
les logins mixtes (Windows + SQL-Server) puisque par défaut, les comptes
SQL-Server sont désactivés (cela même si vous en avez créé un).

Vérifier aussi que votre installation de SQL-Server est l'instance par
défaut et non pas une instance nommée car dans le cas d'une instance
nommée,
vous devez également ajouter son nom après l'adresse du serveur.



batteoui
Le #11864811
Efectivement, le compte test appartient a une identification Windows.
j'ai crée un nouveau compte "aa" avec un mot de passe "aa", comme vous
montre l'image a côte.

http://apu.mabul.org/up/apu/2007/12/11/img-3b31n6gyvz2.jpg

Au debut j'ai testé les comptes "aa" et "sa" en local, et je me
retrouve avec le meme message d'erreur, voici la chaine que j'utilise
Server7.0.0.1;Database=PharmaGest;User
IDª;Passwordª;Trusted_Connectionúlse;

et evidament je me retrouve avec le meme message quand j'essaye de se
connecter depuis l'exerieur avec la chaine
Data SourceA.130.11.167,1433;Network LibraryÛMSSOCN;Initial
Catalog=PharmaGest;User IDª;Passwordª;




On 10 déc, 21:15, "Sylvain Lafontaine" <sylvain aei ca (fill the
blanks, no spam please)> wrote:
Un nom tel que D676...test me donne à penser qu'il s'agit toujours d'un e
identification Windows (groupe ou utilisateur) et non pas d'une
authentification SQL-Server.

Dans l'option Securité | Connexions (ou Login en anglais) du serveur, es t-ce
que le compte Test est décrit comme étant Standard (ce que l'on veut i ci) ou
Groupe Windows ou Utilisateur Windows (ce que l'on ne veut pas ici) ?


batteoui
Le #11864801
desolé j'ai pas fais attention a la chaine de connexion en local, j'ai
remplacé l'IP 127.0.0.1 par le nom de la machine et ca fonctionné,
soit avec le compte "aa" ou le compte "sa".

ca reste la deusiemem chaine qui ne fonctionne pas.

Crd.

On 11 déc, 09:14, wrote:
Efectivement, le compte test appartient a une identification Windows.
j'ai crée un nouveau compte "aa" avec un mot de passe "aa", comme vous
montre l'image a côte.

http://apu.mabul.org/up/apu/2007/12/11/img-3b31n6gyvz2.jpg

Au debut j'ai testé les comptes "aa" et "sa" en local, et je me
retrouve avec le meme message d'erreur, voici la chaine que j'utilise
Server7.0.0.1;Database=PharmaGest;User
IDª;Passwordª;Trusted_Connectionúlse;

et evidament je me retrouve avec le meme message quand j'essaye de se
connecter depuis l'exerieur avec la chaine
Data SourceA.130.11.167,1433;Network LibraryÛMSSOCN;Initial
Catalog=PharmaGest;User IDª;Passwordª;

On 10 déc, 21:15, "Sylvain Lafontaine" <sylvain aei ca (fill the
blanks, no spam please)> wrote:



> Un nom tel que D676...test me donne à penser qu'il s'agit toujours d' une
> identification Windows (groupe ou utilisateur) et non pas d'une
> authentification SQL-Server.

> Dans l'option Securité | Connexions (ou Login en anglais) du serveur, est-ce
> que le compte Test est décrit comme étant Standard (ce que l'on veut ici) ou
> Groupe Windows ou Utilisateur Windows (ce que l'on ne veut pas ici) ?- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -


Sylvain Lafontaine
Le #11864781
Vous ne semblez pas utiliser le même provider dans les deux cas. Dans le
premier cas, vous utilisez Server7.0.0.1 et dans le deuxième, vous
utilisez Data SourceA.130.11.167. Si vous commencer à mélanger ODBC et
OLEDB, vous allez avoir des problèmes à débugger votre système. J'imagine
que votre problème provient de là; sinon, vous allez devoir débugger votre
installation, comme par exemple vérifier si vous êtes capable de pinger
(command ping) la machine à l'adresse 41.130.11.167, de vérifier que le
service 1433 est bien ouvert à travers le(s) firewall et que le service 1433
est bien redirigé sur votre machine si vous avez un routeur.

Vérifiez votre chaîne de connection en choisissant ou bien ODBC pour
SQL-Server ou bien OLEDB pour SQL-Server (ne prenez pas MSDASQL - Microsoft's
OLEDB Provider for ODBC - si possible) et ne mélangez pas les types de
paramètres entre ces deux types de provider:

http://www.carlprothman.net/Default.aspx?tabid

http://www.connectionstrings.com/


--
Sylvain Lafontaine, ing.
MVP - Technologies Virtual-PC
E-mail: sylvain aei ca (fill the blanks, no spam please)


news:
desolé j'ai pas fais attention a la chaine de connexion en local, j'ai
remplacé l'IP 127.0.0.1 par le nom de la machine et ca fonctionné,
soit avec le compte "aa" ou le compte "sa".

ca reste la deusiemem chaine qui ne fonctionne pas.

Crd.

On 11 déc, 09:14, wrote:
Efectivement, le compte test appartient a une identification Windows.
j'ai crée un nouveau compte "aa" avec un mot de passe "aa", comme vous
montre l'image a côte.

http://apu.mabul.org/up/apu/2007/12/11/img-3b31n6gyvz2.jpg

Au debut j'ai testé les comptes "aa" et "sa" en local, et je me
retrouve avec le meme message d'erreur, voici la chaine que j'utilise
Server7.0.0.1;Database=PharmaGest;User
IDª;Passwordª;Trusted_Connectionúlse;

et evidament je me retrouve avec le meme message quand j'essaye de se
connecter depuis l'exerieur avec la chaine
Data SourceA.130.11.167,1433;Network LibraryÛMSSOCN;Initial
Catalog=PharmaGest;User IDª;Passwordª;

On 10 déc, 21:15, "Sylvain Lafontaine" <sylvain aei ca (fill the
blanks, no spam please)> wrote:



> Un nom tel que D676...test me donne à penser qu'il s'agit toujours
> d'une
> identification Windows (groupe ou utilisateur) et non pas d'une
> authentification SQL-Server.

> Dans l'option Securité | Connexions (ou Login en anglais) du serveur,
> est-ce
> que le compte Test est décrit comme étant Standard (ce que l'on veut
> ici) ou
> Groupe Windows ou Utilisateur Windows (ce que l'on ne veut pas ici) ?-
> Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -


batteoui
Le #11864771
mon probleme perciste toujours, aprés la vérification sur les fichiers
log (Microsoft SQL ServerMSSQLLOG) j'ai constaté que mon instant SQL
Server, n'ecoute pas sur le port 1433, meme avec netstat -an ca ne
donne toujours rien.
j'ai verifié le "Client Network Utility", le protocole TCP/IP est bien
activé et son port part defaut est "1433"

je me demande s'il y a une commande pour forcer le demarrage de
l'ecoute sur le ce port ?
Sylvain Lafontaine
Le #11864761
Le Client Network Utility est pour les clients, pas pour le serveur. Vous
devez activer le protocol pour le serveur en utilisant je ne sais plus quel
programme.

--
Sylvain Lafontaine, ing.
MVP - Technologies Virtual-PC
E-mail: sylvain aei ca (fill the blanks, no spam please)


news:
mon probleme perciste toujours, aprés la vérification sur les fichiers
log (Microsoft SQL ServerMSSQLLOG) j'ai constaté que mon instant SQL
Server, n'ecoute pas sur le port 1433, meme avec netstat -an ca ne
donne toujours rien.
j'ai verifié le "Client Network Utility", le protocole TCP/IP est bien
activé et son port part defaut est "1433"

je me demande s'il y a une commande pour forcer le demarrage de
l'ecoute sur le ce port ?
batteoui
Le #11864741
En fin c réglé, le probleme venaient exactement du port 1433,
apparement il n'etait pas en ecoute.

Aprés l'installation du service pack3, tout est remit dans l'ordre,
j'ai aperçu l'ecoute au port 1433 via la commance netstat -an.

Je vous remerci beaucoup pour l'aide que vous m'avez appoté, chapeau
Publicité
Poster une réponse
Anonyme