Connexion wifi WPA driver ipw2200 avec une livebox

Le
giggz
Bonjour la liste,

Tout d'abord bonnes fêtes!

N'étant pas chez moi je tente de me connecter sur le wifi familial (une
livebox) et je n'y arrive pas. J'ai bien mon interface eth1 avec le
module ipw2200 qui est chargé. Je n'ai normalement pas de pb à me
connecter en wifi avec du WEP, mais là c'est du WPA.

J'ai donc installé wpasupplicant. Il y a bcp de tutos sous google à ce
sujet. mais j'aimerai avoir vos conseils :
pour l'instant j'ai mis ça dans mon /etc/network/interfaces :
iface eth1 inet dhcp
wpa-driver wext
wpa-ssid MonEssid
wpa-psk MonMotdePasse
wpa-key-mgmt WPA-PSK
wpa-pairwise TKIP
wpa-proto WPA

je ne pense pas me tromper dans la conf ci-dessus. UN iwlist scan me donne :
Protocol:IEEE 802.11bg
Mode:Master
Frequency:2.412 GHz (Channel 1)
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
QualityF/100 Signal level=-73 dBm
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Extra: Last beacon: 483ms ago

Sous quelle forme dois je rentrer le mot de passe ?

Y a t il des options particulières à activer dans le noyau pour le WPA ?
(je le compile à la main avec un minimum de choses activéesd'où
parfois qqs problèmes de ce genre)

puis je laisse faire debian car j'ai ifplugd d'installer. donc il passe
dans ce fichier. J'ai appuyer sur le petit bouton de la livebox pour me
mettre en acquisition, mais rien ne se passe

Ai je oublié qqch ?
Doit on lancer wpasupplicant à la main ?
Bref ttes remarques est la bienvenue!

Merci bien
Guillaume


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Christophe Alonso
Le #9634761
Le lundi 24 décembre 2007 à 15:58 +0100, giggz a écrit :
Bonjour la liste,

Tout d'abord bonnes fêtes!

N'étant pas chez moi je tente de me connecter sur le wifi familial (une
livebox) et je n'y arrive pas. J'ai bien mon interface eth1 avec le
module ipw2200 qui est chargé. Je n'ai normalement pas de pb à me
connecter en wifi avec du WEP, mais là c'est du WPA.



Tiens il y a eu du changement chez orange :)

J'ai donc installé wpasupplicant. Il y a bcp de tutos sous google à ce
sujet. mais j'aimerai avoir vos conseils :
pour l'instant j'ai mis ça dans mon /etc/network/interfaces :
iface eth1 inet dhcp
wpa-driver wext
wpa-ssid MonEssid
wpa-psk MonMotdePasse
wpa-key-mgmt WPA-PSK
wpa-pairwise TKIP
wpa-proto WPA



Ça paraît bon en effet.

je ne pense pas me tromper dans la conf ci-dessus. UN iwlist scan me donne :
Protocol:IEEE 802.11bg
Mode:Master
Frequency:2.412 GHz (Channel 1)
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
QualityF/100 Signal level=-73 dBm
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Extra: Last beacon: 483ms ago



Correct, oui.

Sous quelle forme dois je rentrer le mot de passe ?



Soit en hex sans les "" (a7fd9807de...) soit en toutes lettres avec
"" ("monmotdepasseestincassablemouahaha").

Y a t il des options particulières à activer dans le noyau pour le WPA ?
(je le compile à la main avec un minimum de choses activées...d'où
parfois qqs problèmes de ce genre)



Là oui. Il faut au minimum les modules de crypto michael_mic et arc4
(mais si le wep fonctionne c'est qu'ils doivent être déjà chargés) ainsi
que ieee80211_crypt_tkip et/ou ieee80211_crypt_ccmp. En plus si wpa2 je
crois, il faut le module aes. Voilà, voilà.

puis je laisse faire debian car j'ai ifplugd d'installer. donc il passe
dans ce fichier. J'ai appuyer sur le petit bouton de la livebox pour me
mettre en acquisition, mais rien ne se passe...



Le plus simple, si tu utilises gnome c'est de passer par network
manager.

Ai je oublié qqch ?
Doit on lancer wpasupplicant à la main ?



En principe non.

Bref ttes remarques est la bienvenue!

Merci bien
Guillaume



Bonnes fêtes,

Christophe


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
giggz
Le #9634751
giggz a écrit :
Bonjour la liste,

Tout d'abord bonnes fêtes!

N'étant pas chez moi je tente de me connecter sur le wifi familial (une
livebox) et je n'y arrive pas. J'ai bien mon interface eth1 avec le
module ipw2200 qui est chargé. Je n'ai normalement pas de pb à me
connecter en wifi avec du WEP, mais là c'est du WPA.

J'ai donc installé wpasupplicant. Il y a bcp de tutos sous google à ce
sujet. mais j'aimerai avoir vos conseils :
pour l'instant j'ai mis ça dans mon /etc/network/interfaces :
iface eth1 inet dhcp
wpa-driver wext
wpa-ssid MonEssid
wpa-psk MonMotdePasse
wpa-key-mgmt WPA-PSK
wpa-pairwise TKIP
wpa-proto WPA




le mode de passe "MonMotdePasse" est genere via :
wpa_passphrase MonEssid MotdePasse

je ne pense pas me tromper dans la conf ci-dessus. UN iwlist scan me donne :
Protocol:IEEE 802.11bg
Mode:Master
Frequency:2.412 GHz (Channel 1)
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
QualityF/100 Signal level=-73 dBm
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Extra: Last beacon: 483ms ago

Sous quelle forme dois je rentrer le mot de passe ?

Y a t il des options particulières à activer dans le noyau pour le WPA ?
(je le compile à la main avec un minimum de choses activées...d'où
parfois qqs problèmes de ce genre)

puis je laisse faire debian car j'ai ifplugd d'installer. donc il passe
dans ce fichier. J'ai appuyer sur le petit bouton de la livebox pour me
mettre en acquisition, mais rien ne se passe...

Ai je oublié qqch ?
Doit on lancer wpasupplicant à la main ?
Bref ttes remarques est la bienvenue!

Merci bien
Guillaume






--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
giggz
Le #9634741
Christophe Alonso a écrit :
Le lundi 24 décembre 2007 à 15:58 +0100, giggz a écrit :
Bonjour la liste,

Tout d'abord bonnes fêtes!

N'étant pas chez moi je tente de me connecter sur le wifi familial (une
livebox) et je n'y arrive pas. J'ai bien mon interface eth1 avec le
module ipw2200 qui est chargé. Je n'ai normalement pas de pb à me
connecter en wifi avec du WEP, mais là c'est du WPA.



Tiens il y a eu du changement chez orange :)

J'ai donc installé wpasupplicant. Il y a bcp de tutos sous google à ce
sujet. mais j'aimerai avoir vos conseils :
pour l'instant j'ai mis ça dans mon /etc/network/interfaces :
iface eth1 inet dhcp
wpa-driver wext
wpa-ssid MonEssid
wpa-psk MonMotdePasse
wpa-key-mgmt WPA-PSK
wpa-pairwise TKIP
wpa-proto WPA



Ça paraît bon en effet.

je ne pense pas me tromper dans la conf ci-dessus. UN iwlist scan me donne :
Protocol:IEEE 802.11bg
Mode:Master
Frequency:2.412 GHz (Channel 1)
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
QualityF/100 Signal level=-73 dBm
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Extra: Last beacon: 483ms ago



Correct, oui.

Sous quelle forme dois je rentrer le mot de passe ?



Soit en hex sans les "" (a7fd9807de...) soit en toutes lettres avec
"" ("monmotdepasseestincassablemouahaha").



ah ok po besoin de passer le tout en hexa


Y a t il des options particulières à activer dans le noyau pour le WPA ?
(je le compile à la main avec un minimum de choses activées...d'où
parfois qqs problèmes de ce genre)



Là oui. Il faut au minimum les modules de crypto michael_mic et arc4
(mais si le wep fonctionne c'est qu'ils doivent être déjà chargés) ainsi
que ieee80211_crypt_tkip et/ou ieee80211_crypt_ccmp. En plus si wpa2 je
crois, il faut le module aes. Voilà, voilà.

puis je laisse faire debian car j'ai ifplugd d'installer. donc il passe
dans ce fichier. J'ai appuyer sur le petit bouton de la livebox pour me
mettre en acquisition, mais rien ne se passe...



Le plus simple, si tu utilises gnome c'est de passer par network
manager.



ben en fait je veux eviter cette énorme truc...moi je voudrai que ça
fonctionne via /etc/network/interfaces...(je sais suis chiant)


Ai je oublié qqch ?
Doit on lancer wpasupplicant à la main ?



En principe non.



Ne faut il pas le lancer en daemon ou qqch comme ça ?
EN effet j'ai l'impression que mon portable s'associe bien à la livebox
mais qu'ensuite il n'y a pas de dialogue...comme si wpasupplicant ne
faisait rien. Aucun module de cryptage ne se charge...Pourtant je les ai
bien compilé...
Comment les utilisateurs de live box font pour se connecter en wifi sous
debian sid ? ss frontend...


Bref ttes remarques est la bienvenue!

Merci bien
Guillaume



Bonnes fêtes,

Christophe



merci!







--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Christophe Alonso
Le #9634731
Le lundi 24 décembre 2007 à 17:10 +0100, giggz a écrit :
Christophe Alonso a écrit :
> Le lundi 24 décembre 2007 à 15:58 +0100, giggz a écrit :
>> Bonjour la liste,
>>
>> Tout d'abord bonnes fêtes!
>>
>> N'étant pas chez moi je tente de me connecter sur le wifi familial (une
>> livebox) et je n'y arrive pas. J'ai bien mon interface eth1 avec le
>> module ipw2200 qui est chargé. Je n'ai normalement pas de pb à me
>> connecter en wifi avec du WEP, mais là c'est du WPA.
>
> Tiens il y a eu du changement chez orange :)
>
>> J'ai donc installé wpasupplicant. Il y a bcp de tutos sous google à ce
>> sujet. mais j'aimerai avoir vos conseils :
>> pour l'instant j'ai mis ça dans mon /etc/network/interfaces :
>> iface eth1 inet dhcp
>> wpa-driver wext
>> wpa-ssid MonEssid
>> wpa-psk MonMotdePasse
>> wpa-key-mgmt WPA-PSK
>> wpa-pairwise TKIP
>> wpa-proto WPA
>
> Ça paraît bon en effet.
>
>> je ne pense pas me tromper dans la conf ci-dessus. UN iwlist scan me donne :
>> Protocol:IEEE 802.11bg
>> Mode:Master
>> Frequency:2.412 GHz (Channel 1)
>> Encryption key:on
>> Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
>> 11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
>> 48 Mb/s; 54 Mb/s
>> QualityF/100 Signal level=-73 dBm
>> IE: WPA Version 1
>> Group Cipher : TKIP
>> Pairwise Ciphers (1) : TKIP
>> Authentication Suites (1) : PSK
>> Extra: Last beacon: 483ms ago
>
> Correct, oui.
>
>> Sous quelle forme dois je rentrer le mot de passe ?
>
> Soit en hex sans les "" (a7fd9807de...) soit en toutes lettres avec
> "" ("monmotdepasseestincassablemouahaha").

ah ok po besoin de passer le tout en hexa

>
>> Y a t il des options particulières à activer dans le noyau pour le WPA ?
>> (je le compile à la main avec un minimum de choses activées...d'où
>> parfois qqs problèmes de ce genre)
>
> Là oui. Il faut au minimum les modules de crypto michael_mic et arc4
> (mais si le wep fonctionne c'est qu'ils doivent être déjà chargés) ainsi
> que ieee80211_crypt_tkip et/ou ieee80211_crypt_ccmp. En plus si wpa2 je
> crois, il faut le module aes. Voilà, voilà.
>
>> puis je laisse faire debian car j'ai ifplugd d'installer. donc il passe
>> dans ce fichier. J'ai appuyer sur le petit bouton de la livebox pour me
>> mettre en acquisition, mais rien ne se passe...
>
> Le plus simple, si tu utilises gnome c'est de passer par network
> manager.

ben en fait je veux eviter cette énorme truc...moi je voudrai que ça
fonctionne via /etc/network/interfaces...(je sais suis chiant)



Non, non, c'est une question de goût, pas de problèmes.

>> Ai je oublié qqch ?
>> Doit on lancer wpasupplicant à la main ?
>
> En principe non.

Ne faut il pas le lancer en daemon ou qqch comme ça ?



"wpasupplicant is now integrated into ifupdown. You can configure it in
/etc/network/interfaces, in a similar method to configuring WEP keys[1].
After that, wpa_supplicant will be controlled by ifupdown without
further user intervention."
Donc, encore une fois, en principe non. Maintenant, en unstable, qui
sait ;)

EN effet j'ai l'impression que mon portable s'associe bien à la livebox
mais qu'ensuite il n'y a pas de dialogue...comme si wpasupplicant ne
faisait rien. Aucun module de cryptage ne se charge...Pourtant je les ai
bien compilé...
Comment les utilisateurs de live box font pour se connecter en wifi sous
debian sid ? ss frontend...

>
>> Bref ttes remarques est la bienvenue!
>>
>> Merci bien
>> Guillaume
>
> Bonnes fêtes,
>
> Christophe

merci!




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme