console + à la ligne

Le
mess-mate
Bonjour,

voici des années que j'ai le phénomène qu'un à la ligne ne se fait pas
lorsque le texte exède la largueur de l'écran.

En console, xterm et en konsole de kde.

Un changement de clavier n'arrange rien.

Quelqu'un aurait une piste ?

amicalement





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Edi Stojicevic
Le #19926751
* mess-mate
Bonjour,



Salut,

voici des années que j'ai le phénomène qu'un à la ligne ne se fait pas
lorsque le texte exède la largueur de l'écran.

En console, xterm et en konsole de kde.

Un changement de clavier n'arrange rien.

Quelqu'un aurait une piste ?



Essayes avec rxvt-unicode ...

amicalement




--
.''`. Edi Stojicevic
: :' : Debian GNU/Linux user, admin & developer - http://www.debian.org
`. `~' French speaking Debian website founder - http://www.debianworld.org
`- GPG Key Id : 0x1237B032

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
mess-mate
Le #19931001
Edi Stojicevic wrote:

* mess-mate

Bonjour,




Salut,


voici des années que j'ai le phénomène qu'un à la ligne ne se fait pas
lorsque le texte exède la largueur de l'écran.

En console, xterm et en konsole de kde.

Un changement de clavier n'arrange rien.

Quelqu'un aurait une piste ?




Essayes avec rxvt-unicode ...


amicalement








Merci, mais cela n'arrange rien. C'est un phénomène commun à tous les
terminaux.
Je vois pas très bien comment résoudre ce problème.
amicalement



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Leopold BAILLY
Le #20108531
mess-mate
Bonjour,



Salut, (je remonte le temps)

voici des années que j'ai le phénomène qu'un à la ligne ne se fait pas
lorsque le texte exède la largueur de l'écran.

En console, xterm et en konsole de kde.

Un changement de clavier n'arrange rien.

Quelqu'un aurait une piste ?



Je crois savoir que le terminal se configure par la commande stty.

Pour comparaison, voici la configuration (fonctionnelle) de mon
terminal sous xterm :

~$ stty -a
speed 38400 baud; rows 41; columns 159; line = 0;
intr = ^C; quit = ^; erase = ^?; kill = ^U; eof = ^D; eol = <undef>; eol2 = <undef>; swtch = <undef>; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R;
werase = ^W; lnext = ^V; flush = ^O; min = 1; time = 0;
-parenb -parodd cs8 -hupcl -cstopb cread -clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff -iuclc -ixany -imaxbel -iutf8
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke


--
Léo.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
mess-mate
Le #20109121
Leopold BAILLY wrote:

mess-mate

Bonjour,




Salut, (je remonte le temps)


voici des années que j'ai le phénomène qu'un à la ligne ne se fait pas
lorsque le texte exède la largueur de l'écran.

En console, xterm et en konsole de kde.

Un changement de clavier n'arrange rien.

Quelqu'un aurait une piste ?




Je crois savoir que le terminal se configure par la commande stty.

Pour comparaison, voici la configuration (fonctionnelle) de mon
terminal sous xterm :

~$ stty -a
speed 38400 baud; rows 41; columns 159; line = 0;
intr = ^C; quit = ^; erase = ^?; kill = ^U; eof = ^D; eol = <undef>; eol2 = <undef>; swtch = <undef>; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R;
werase = ^W; lnext = ^V; flush = ^O; min = 1; time = 0;
-parenb -parodd cs8 -hupcl -cstopb cread -clocal -crtscts
-ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff -iuclc -ixany -imaxbel -iutf8
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke





Merci pour la réponse Léo.
J'ai exactement la même chose à part les lines et colums.
Idem dans console.
Et rien n'a changé, toujours pas de à la ligne.
amicalement



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
mess-mate
Le #20110761
julien.garcia wrote:


Bonjour, il me semble déjà avoir eu ce problème, et si je me souviens
bien c'était ma variable PS1 qui était mal formulé.
pour tester il faut juste redéfinir PS1 à la volée et pour rétablir
l'ancienne valeur faire "source ~/.bashrc"

:~$ PS1="-->"
-->source ~/.bashrc
:~$
jg


mess-mate a écrit :
Bonjour,

voici des années que j'ai le phénomène qu'un à la ligne ne se fait
pas lorsque le texte exède la largueur de l'écran.

En console, xterm et en konsole de kde.

Un changement de clavier n'arrange rien.

Quelqu'un aurait une piste ?

amicalement










Merciiiii, en effet c'est ma bashrc que j'avais repris de lenny.
J'ai une couleur de texte pour le user et une couleur pour root.
En enlevant cette couleur ça marche.
Ne peut-on plus mettre une couleur au texte maintenant ?
Voici ce que j'avais fait et ce qui marche:
#PS1="33[0;/W$ "
PS1=':w$ '



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
julien.garcia
Le #20110801
Bonjour, il me semble déjà avoir eu ce problème, et si je me souviens
bien c'était ma variable PS1 qui était mal formulé.
pour tester il faut juste redéfinir PS1 à la volée et pour rétablir
l'ancienne valeur faire "source ~/.bashrc"

:~$ PS1="-->"
-->source ~/.bashrc
:~$
jg


mess-mate a écrit :
Bonjour,

voici des années que j'ai le phénomène qu'un à la ligne ne se fait pas
lorsque le texte exède la largueur de l'écran.

En console, xterm et en konsole de kde.

Un changement de clavier n'arrange rien.

Quelqu'un aurait une piste ?

amicalement








--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
julien.garcia
Le #20111001
mess-mate a écrit :
julien.garcia wrote:


Bonjour, il me semble déjà avoir eu ce problème, et si je me souviens
bien c'était ma variable PS1 qui était mal formulé.
pour tester il faut juste redéfinir PS1 à la volée et pour rétablir
l'ancienne valeur faire "source ~/.bashrc"

:~$ PS1="-->"
-->source ~/.bashrc
:~$
jg


mess-mate a écrit :
Bonjour,

voici des années que j'ai le phénomène qu'un à la ligne ne se fait
pas lorsque le texte exède la largueur de l'écran.

En console, xterm et en konsole de kde.

Un changement de clavier n'arrange rien.

Quelqu'un aurait une piste ?

amicalement










Merciiiii, en effet c'est ma bashrc que j'avais repris de lenny.
J'ai une couleur de texte pour le user et une couleur pour root.
En enlevant cette couleur ça marche.
Ne peut-on plus mettre une couleur au texte maintenant ?


si si, j'ai également 2 couleurs différentes
voici la mienne
PS1='${debian_chroot:+($debian_chroot)}[33[36;40m][33[00m]:[33[01;30m]w[33[00m]$
'
c'est celle de base un peu modifié
Voici ce que j'avais fait et ce qui marche:
#PS1="33[0;/W$ "


il doit manquer un [ ou un je sais pas
PS1=':w$ '






--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Sylvain Sauvage
Le #20110991
mess-mate, jeudi 10 septembre 2009, 14:26:18 CEST
[…]
Merciiiii, en effet c'est ma bashrc que j'avais repris de lenny.
J'ai une couleur de texte pour le user et une couleur pour root.
En enlevant cette couleur ça marche.
Ne peut-on plus mettre une couleur au texte maintenant ?



Si, mais il faut encadrer avec [ et ] pour éviter que les
caractères d’échappement, donc invisibles, soient compt és.

Il y a aussi la variable PROMPT_COMMAND qui peut servir à
ajouter un texte variable (la sortie de la commande) avant
chaque prompt.

man bash /INVITE (en FR)

Voici ce que j'avais fait et ce qui marche:
#PS1="33[0;/W$ "
PS1=':w$ '



--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
mess-mate
Le #20113371
julien.garcia wrote:




mess-mate a écrit :
julien.garcia wrote:


Bonjour, il me semble déjà avoir eu ce problème, et si je me
souviens bien c'était ma variable PS1 qui était mal formulé.
pour tester il faut juste redéfinir PS1 à la volée et pour rétablir
l'ancienne valeur faire "source ~/.bashrc"

:~$ PS1="-->"
-->source ~/.bashrc
:~$
jg


mess-mate a écrit :
Bonjour,

voici des années que j'ai le phénomène qu'un à la ligne ne se fait
pas lorsque le texte exède la largueur de l'écran.

En console, xterm et en konsole de kde.

Un changement de clavier n'arrange rien.

Quelqu'un aurait une piste ?

amicalement










Merciiiii, en effet c'est ma bashrc que j'avais repris de lenny.
J'ai une couleur de texte pour le user et une couleur pour root.
En enlevant cette couleur ça marche.
Ne peut-on plus mettre une couleur au texte maintenant ?


si si, j'ai également 2 couleurs différentes
voici la mienne
PS1='${debian_chroot:+($debian_chroot)}[33[36;40m][33[00m]:[33[01;30m]w[33[00m]$
'
c'est celle de base un peu modifié
Voici ce que j'avais fait et ce qui marche:
#PS1="33[0;/W$ "


il doit manquer un [ ou un je sais pas
PS1=':w$ '








En effet il manquait un [ .
Encore merci pour l'aide
amicalement



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
hého
Le #20113441
Sylvain Sauvage a écrit, le 10.09.2009 15:10 :

Si, mais il faut encadrer avec [ et ] pour éviter que les
caractères d'échappement, donc invisibles, soient comptés.




julien.garcia a écrit, le 10.09.2009 15:02 :
si si, j'ai également 2 couleurs différentes
voici la mienne
PS1='${debian_chroot:+($debian_chroot)}[33[36;40m][33[00m]:[33[01;30m]w[33[00m]$'
c'est celle de base un peu modifié



Zuper merci,

j'avais le problème depuis pas mal de temps (toujours)
et jusqu'à il y a 2 minutes ;)
avec un prompt 3 couleurs

il me manquait un "[" devant le "33[00m" de la fin.

maintenant ça marche.

cordialement
hého

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme