Conversion de nombre en texte

Le
Jean-Pierre Allidières
Bonjour,

Je reçois de différentes filiales un fichier dont la 1ère colonne comprend
des numéros de comptes comptables. Dans un même fichier, certains de ces
numéros sont soit des valeurs, soit du texte. Je souhaite les convertir tous
en texte en respectant leur apparence initiale.

Par exemple,
0010, qui est déjà du texte, doit rester 0010 en texte
3.456, qui est soit du texte, soit une valeur, doit devenir 3.456 en texte
110, qui est soit du texte, soit une valeur, doit devenir 110 en texte

J'ai essayé les formules :
=texte(a1;"#")
=texte(a1;"Standard")
=texte(a1;"@")
mais aucune n'est valable dans tous les cas de figure.

Savez-vous s'il y a un argument de la fonction Texte qui permet cela, car je
voudrais éviter de passer par une formule comme :
=SI(ESTTEXTE(A1);A1;TEXTE(A1;"Standard"))
qui elle semble fonctionner, car je dois intégrer tout cela dans une formule
déjà longue.

Merci de votre aide,
Jean-Pierre Allidières
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JPMonnier
Le #17445621
Bonjour,
Sélectionne tes données,
Menu Données/Convertir
Suivant
Suivant
Coche Texte
Terminer

--
Cordialement

"Jean-Pierre Allidières" écrit dans le message de
news:
Bonjour,

Je reçois de différentes filiales un fichier dont la 1ère colonne comprend
des numéros de comptes comptables. Dans un même fichier, certains de ces
numéros sont soit des valeurs, soit du texte. Je souhaite les convertir
tous
en texte en respectant leur apparence initiale.

Par exemple,
0010, qui est déjà du texte, doit rester 0010 en texte
3.456, qui est soit du texte, soit une valeur, doit devenir 3.456 en texte
110, qui est soit du texte, soit une valeur, doit devenir 110 en texte

J'ai essayé les formules :
=texte(a1;"#")
=texte(a1;"Standard")
=texte(a1;"@")
mais aucune n'est valable dans tous les cas de figure.

Savez-vous s'il y a un argument de la fonction Texte qui permet cela, car
je
voudrais éviter de passer par une formule comme :
=SI(ESTTEXTE(A1);A1;TEXTE(A1;"Standard"))
qui elle semble fonctionner, car je dois intégrer tout cela dans une
formule
déjà longue.

Merci de votre aide,
Jean-Pierre Allidières


Jean-Pierre Allidières
Le #17446381
Merci pour cette idée.
C'est effectivement une bonne solution s'il n'y a pas de formule simple de
disponible.
--
Jean-Pierre Allidières


"JPMonnier" a écrit :

Bonjour,
Sélectionne tes données,
Menu Données/Convertir
Suivant
Suivant
Coche Texte
Terminer

--
Cordialement

"Jean-Pierre Allidières" écrit dans le message de
news:
> Bonjour,
>
> Je reçois de différentes filiales un fichier dont la 1ère colonne comprend
> des numéros de comptes comptables. Dans un même fichier, certains de ces
> numéros sont soit des valeurs, soit du texte. Je souhaite les convertir
> tous
> en texte en respectant leur apparence initiale.
>
> Par exemple,
> 0010, qui est déjà du texte, doit rester 0010 en texte
> 3.456, qui est soit du texte, soit une valeur, doit devenir 3.456 en texte
> 110, qui est soit du texte, soit une valeur, doit devenir 110 en texte
>
> J'ai essayé les formules :
> =texte(a1;"#")
> =texte(a1;"Standard")
> =texte(a1;"@")
> mais aucune n'est valable dans tous les cas de figure.
>
> Savez-vous s'il y a un argument de la fonction Texte qui permet cela, car
> je
> voudrais éviter de passer par une formule comme :
> =SI(ESTTEXTE(A1);A1;TEXTE(A1;"Standard"))
> qui elle semble fonctionner, car je dois intégrer tout cela dans une
> formule
> déjà longue.
>
> Merci de votre aide,
> Jean-Pierre Allidières




garnote
Le #17451741
Salut Jean-Pierre,

Peut-être que :
En supposant que tes données sont de A1 à Ax,
sélectionne une cellule libre sur la première ligne
d'une colonne quelconque et clique :

Insertion / Nom / Définir :
Nom : ct
Fait référence à :
=SI(ESTVIDE($A1);"";SI(ESTTEXTE($A1);$A1;TEXTE($A1;"Standard")))

Et si, par exemple, tu entres la formule =ct dans la ligne 10 d'une colonne quelconque,
tu obtiendras la valeur de A10 transformée en texte.
Tu pourras recopier =ct vers le bas.
Tu pourras utiliser ct dans d'autres formules.

Qu'en penses-tu ?


Serge





"Jean-Pierre Allidières"
Merci pour cette idée.
C'est effectivement une bonne solution s'il n'y a pas de formule simple de
disponible.
--
Jean-Pierre Allidières


"JPMonnier" a écrit :

Bonjour,
Sélectionne tes données,
Menu Données/Convertir
Suivant
Suivant
Coche Texte
Terminer

--
Cordialement

"Jean-Pierre Allidières" écrit dans le message de
news:
> Bonjour,
>
> Je reçois de différentes filiales un fichier dont la 1ère colonne comprend
> des numéros de comptes comptables. Dans un même fichier, certains de ces
> numéros sont soit des valeurs, soit du texte. Je souhaite les convertir
> tous
> en texte en respectant leur apparence initiale.
>
> Par exemple,
> 0010, qui est déjà du texte, doit rester 0010 en texte
> 3.456, qui est soit du texte, soit une valeur, doit devenir 3.456 en texte
> 110, qui est soit du texte, soit une valeur, doit devenir 110 en texte
>
> J'ai essayé les formules :
> =texte(a1;"#")
> =texte(a1;"Standard")
> =texte(a1;"@")
> mais aucune n'est valable dans tous les cas de figure.
>
> Savez-vous s'il y a un argument de la fonction Texte qui permet cela, car
> je
> voudrais éviter de passer par une formule comme :
> =SI(ESTTEXTE(A1);A1;TEXTE(A1;"Standard"))
> qui elle semble fonctionner, car je dois intégrer tout cela dans une
> formule
> déjà longue.
>
> Merci de votre aide,
> Jean-Pierre Allidières






Jean-Pierre Allidières
Le #17831941
Bonjour Serge,

Désolé de n'avoir pris connaissance de ton message qu'aujourd'hui, je ne
pensais pas avoir d'autres réponses sur ce sujet. Ta solution fonctionne bien
et, surtout, m'apprend une utilisation que j'ignorais des noms de champs.

Jean-Pierre,


--
Jean-Pierre Allidières


"garnote" a écrit :

Salut Jean-Pierre,

Peut-être que :
En supposant que tes données sont de A1 à Ax,
sélectionne une cellule libre sur la première ligne
d'une colonne quelconque et clique :

Insertion / Nom / Définir :
Nom : ct
Fait référence à :
=SI(ESTVIDE($A1);"";SI(ESTTEXTE($A1);$A1;TEXTE($A1;"Standard")))

Et si, par exemple, tu entres la formule =ct dans la ligne 10 d'une colonne quelconque,
tu obtiendras la valeur de A10 transformée en texte.
Tu pourras recopier =ct vers le bas.
Tu pourras utiliser ct dans d'autres formules.

Qu'en penses-tu ?


Serge



Publicité
Poster une réponse
Anonyme