Copie hda->hdb : taille différente

Le
Bulot Grégory
bonjour,

j'ai mon fournisseur habituel de disque dur qui n'a plus les anciens disque=

dur que j'utlisais habituellement, j'ai eu une autre marque de capacité
équivalante

sauf que dd if=/dev/hda of=/dev/hdb en init 2 ne semble plus fonctionne=
r !
en effet lorsque je retire le hda, je bascule le hdb en hda , au démarrag=
e la
machine démarre comme si le secteur de boot du disque copié n'existe pa=
s.
cfdisk sur le disque copié me confirme l'existance du flag boot


Par ailleurs, y'a-t-il une autre méthode pour copier des disques (hda->hd=
b),
sachant que je ne peux installer mondo (a cause des dépenses j'ai quasime=
nt
une reinstall complète du système, pour l'instant je souhaiterais l'é=
viter)


j'avais pensé
1) sfdisk -d /dev/hda | sfdisk /dev/hdb
2) montage des partition de hdb dans /mnt/partitionx
3) cp -ax partition sur hda vers partition sur hdb
(là j'ai un soucis de copie avec /proc/ .)
4) en shell un grub qui install le boot

mais ça fait 1 heures que je galère sur le points 2



= mon script qui foire =

cat initDisk.sh
#!/bin/sh

partition[1]=/
# 2 = swap
partition[3]=/usr
partition[5]=/var
partition[6]=/tmp
partition[7]=/home


function FormatPartition () {
for i in 1 3 5 6 7 ; do mkfs.ext3 /dev/hdb$i ; done
}

function leSwap () {
mkswap /dev/hdb2
}

function CreationPointMontage () {
mkdir /dev/hdb1 /mnt/hdb1
mkdir /dev/hdb3 /mnt/hdb3
mkdir /dev/hdb5 /mnt/hdb5
mkdir /dev/hdb6 /mnt/hdb6
mkdir /dev/hdb7 /mnt/hdb7
}

function MontageDisque () {
for i in 1 3 5 6 7
do
mount /dev/hdb$i /mnt/hdb$i
done
}

function Copiefichiers () {
for i in 1 3 5 6 7
do
#cp -ax /usr/* /mnt/hdb3/.
Src=${partition[$i]}
Src=$Src'/''*'
echo $Src
Dest="/mnt/hdb$i"
#cp -prdx / /mnt/destination
cmd="cp -ax $Src $Dest"'/.'
`$cmd` # ça me recréer /usr/* par exemple !!!!
done
}


#leSwap
#FormatPartition
#CreationPointMontage
#MontageDisque

Copiefichiers
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Cédric Lucantis
Le #9526831
Salut,


sauf que dd if=/dev/hda of=/dev/hdb en init 2 ne semble plus fonction ner !
en effet lorsque je retire le hda, je bascule le hdb en hda , au démarr age
la machine démarre comme si le secteur de boot du disque copié n'exis te
pas. cfdisk sur le disque copié me confirme l'existance du flag boot




Je ne suis pas sûr que ce flag serve à quelque chose en dehors de dos/w indows;
est-ce qu'il ne faudrait pas plutôt réinstaller grub/lilo? (Mais là d essus je
n'y connais pas grand chose :)


Par ailleurs, y'a-t-il une autre méthode pour copier des disques
(hda->hdb), sachant que je ne peux installer mondo (a cause des dépenses
j'ai quasiment une reinstall complète du système, pour l'instant je
souhaiterais l'éviter)


j'avais pensé
1) sfdisk -d /dev/hda | sfdisk /dev/hdb
2) montage des partition de hdb dans /mnt/partitionx
3) cp -ax partition sur hda vers partition sur hdb
(là j'ai un soucis de copie avec /proc/ ....)
4) en shell un grub qui install le boot




La méthode tar devrait marcher:

tar --one-file-system --numeric-owner -p -C /mnt/hda1 -cf - . |
tar -C /mnt/hdb1 -xf -

mais cp devrait marcher aussi, quel est le souci avec /proc? (il devrait être
ignoré par -x)

                Src=${partition[$i]}
                Src=$Src'/''*'
                echo $Src
                Dest="/mnt/hdb$i"
cmd="cp -ax $Src $Dest"'/.'
`$cmd` # ça me recréer /usr/* par exemple !!!!



ça c'est très bizarre :) pourquoi pas simplement

Src="${partition[$i]}"
Dest="/mnt/hdb$i"
cp -ax "$Src"/* "$Dest"

??

Pour finir, je ne sais pas trop si c'est une bonne idée de faire ça sur un
système qui tourne, peut être que tu aurais moins de problèmes à pa rtir d'un
système live?

--
Cédric Lucantis
Jacques L'helgoualc'h
Le #9526821
Cédric Lucantis a écrit, mardi 20 mars 2007, à 16:28 :
Salut,



aussi,

> sauf que dd if=/dev/hda of=/dev/hdb en init 2 ne semble plus fonctionner !
> en effet lorsque je retire le hda, je bascule le hdb en hda , au démarrage
> la machine démarre comme si le secteur de boot du disque copié n'existe
> pas. cfdisk sur le disque copié me confirme l'existance du flag boot



Les 446 premiers octets (le code bouteur) ont bien été copiés ?

Je ne suis pas sûr que ce flag serve à quelque chose en dehors de dos/windows;



oui.

est-ce qu'il ne faudrait pas plutôt réinstaller grub/lilo? (Mais là dessus je
n'y connais pas grand chose :)



La commande dd a *tout* copié bit à bit, donc ça devrait marcher (sauf
si hda est plus gros, peut-être) --- comment est faite la bascule ? Par
le BIOS, ou physiquement ? Est-ce que les deux disques ont la même
géométrie, le même mode (LBA, etc.) ?

> Par ailleurs, y'a-t-il une autre méthode pour copier des disques
> (hda->hdb), sachant que je ne peux installer mondo (a cause des dépenses
> j'ai quasiment une reinstall complète du système, pour l'instant je
> souhaiterais l'éviter)



Ce sujet a été abordé sur la liste il n'y a pas très longtemps...

> j'avais pensé
> 1) sfdisk -d /dev/hda | sfdisk /dev/hdb



sfdisk -d /dev/hda |sed s,/dev/hda,/dev/hdb,| sfdisk /dev/hdb

mais il peut être utile d'ajuster un peu --- ensuite, c'est moins simple.


[...]
[pour Gregory]

Dans la fonction

function CreationPointMontage () {
mkdir /dev/hdb1 /mnt/hdb1
mkdir /dev/hdb3 /mnt/hdb3
mkdir /dev/hdb5 /mnt/hdb5
mkdir /dev/hdb6 /mnt/hdb6
mkdir /dev/hdb7 /mnt/hdb7
}

les /dev/ sont en trop !

mkdir -v -p /mnt/hdb{1,3,5,6,7}


ça c'est très bizarre :) pourquoi pas simplement

Src="${partition[$i]}"
Dest="/mnt/hdb$i"
cp -ax "$Src"/* "$Dest"



Ça ne copierait pas les fichiers cachés à la base de $Src,

cp -avx "Src"/. "$Dest"/

--
Jacques L'helgoualc'h


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Bulot Grégory
Le #9526801
Le mardi 20 mars 2007 16:28, Cédric Lucantis a écrit :

Je ne suis pas sûr que ce flag serve à quelque chose en dehors de
dos/windows; est-ce qu'il ne faudrait pas plutôt réinstaller grub/lil o?
(Mais là dessus je n'y connais pas grand chose :)



j'ai essaye sous grub (grub>) install [... beaucoup de chose en hd1 et hd1, 0]
mais il ne sempblait pas trouver les chemins (/grub/XXXX et /boot/grub/XXX) ,
j'ai pas noté les message d'erreurs ....


mais cp devrait marcher aussi, quel est le souci avec /proc? (il devrait
être ignoré par -x)



bah justement il est pas ignoré (et le kcore est .... gros !)


>                 Src=${partition[$i]}
>                 Src=$Src'/''*'
>                 echo $Src
>                 Dest="/mnt/hdb$i"
> cmd="cp -ax $Src $Dest"'/.'
> `$cmd` # ça me recréer /usr/* par exemple !!!!

ça c'est très bizarre :) pourquoi pas simplement

Src="${partition[$i]}"
Dest="/mnt/hdb$i"
cp -ax "$Src"/* "$Dest"



j'arive pas a comprendre pourquoi le shell essais de traduire le * avec la
liste des répertoire, du coups sur la parie monté je me retrouve avec u n truc
du genre /mnt/hdb3/usr au lieu de /mnt/hdb3/


Pour finir, je ne sais pas trop si c'est une bonne idée de faire ça s ur un
système qui tourne, peut être que tu aurais moins de problèmes à partir
d'un système live?



Pas de lecteur cdrom au bureau .... (demain je ramène un cdrom et un syst em
rescue cd .... j'aurais préférée une solution de disque à disque)
Bulot Grégory
Le #9526791
Le mardi 20 mars 2007 16:59, Jacques L'helgoualc'h a écrit :


Les 446 premiers octets (le code bouteur) ont bien été copiés ?



j'ai pas eu de message d'erreur lors de la copie (if=/dev/hda of=/dev/h db)

La commande dd a *tout* copié bit à bit, donc ça devrait marcher (sauf
si hda est plus gros, peut-être) --- comment est faite la bascule ? Par
le BIOS, ou physiquement ? Est-ce que les deux disques ont la même
géométrie, le même mode (LBA, etc.) ?



- la bascule est physique : je retire le hda de la machine, je change le hdb
en master et je le branche à la place du hda
- hda Maxtor 80G diamond max 20 (9DN011-326)
- hdb Western digital 80G caviar (WD800BB)

Ce sujet a été abordé sur la liste il n'y a pas très longtemps...

> > j'avais pensé
> > 1) sfdisk -d /dev/hda | sfdisk /dev/hdb

sfdisk -d /dev/hda |sed s,/dev/hda,/dev/hdb,| sfdisk /dev/hdb

mais il peut être utile d'ajuster un peu --- ensuite, c'est moins simpl e.


[...]
[pour Gregory]

Dans la fonction

function CreationPointMontage () {
mkdir /dev/hdb1 /mnt/hdb1
mkdir /dev/hdb3 /mnt/hdb3
mkdir /dev/hdb5 /mnt/hdb5
mkdir /dev/hdb6 /mnt/hdb6
mkdir /dev/hdb7 /mnt/hdb7
}

les /dev/ sont en trop !



oops je pense au montage alors que je n'étais que dans la fonction créa tion
point de montage ;-)
Jacques L'helgoualc'h
Le #9526781
Bulot Grégory a écrit, mardi 20 mars 2007, à 17:31 :
[...]
- la bascule est physique : je retire le hda de la machine, je change le hdb
en master et je le branche à la place du hda
- hda Maxtor 80G diamond max 20 (9DN011-326)
- hdb Western digital 80G caviar (WD800BB)



Compare les sorties de « hdparm -i » ?
--
Jacques L'helgoualc'h


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Bulot Grégory
Le #9526141
Le mardi 20 mars 2007 17:51, Jacques L'helgoualc'h a écrit :
Bulot Grégory a écrit, mardi 20 mars 2007, à 17:31 :
[...]

> - la bascule est physique : je retire le hda de la machine, je change le
> hdb en master et je le branche à la place du hda
> - hda Maxtor 80G diamond max 20 (9DN011-326)
> - hdb Western digital 80G caviar (WD800BB)

Compare les sorties de « hdparm -i » ?



hdparm -i /dev/hda /dev/hdb

/dev/hda:

Model=MAXTOR STM3802110A, FwRev=3.AAJ, SerialNo=9LR1WHNC
Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs RotSpdTol>.5% }
RawCHS383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
BuffType=unknown, BuffSize 48kB, MaxMultSect, MultSect
CurCHS383/16/63, CurSects514064, LBA=yes, LBAsects6301488
IORDY=on/off, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5 udma3 udma4 *udma5
AdvancedPM=no WriteCache=enabled
Drive conforms to: Unspecified: ATA/ATAPI-1 ATA/ATAPI-2 ATA/ATAPI-3
ATA/ATAPI-4 ATA/ATAPI-5 ATA/ATAPI-6 ATA/ATAPI-7

* signifies the current active mode


/dev/hdb:

Model=WDC WD800BB-22JHC0, FwRev.01C05, SerialNo=WD-WMAM9JH94127
Config={ HardSect NotMFM HdSw>15uSec SpinMotCtl Fixed DTR>5Mbs FmtGapReq }
RawCHS383/16/63, TrkSize=0, SectSize=0, ECCbytesf
BuffType=unknown, BuffSize 48kB, MaxMultSect, MultSect
CurCHS383/16/63, CurSects514064, LBA=yes, LBAsects6301488
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5 udma3 udma4 *udma5
AdvancedPM=no WriteCache=enabled
Drive conforms to: Unspecified: ATA/ATAPI-1 ATA/ATAPI-2 ATA/ATAPI-3
ATA/ATAPI-4 ATA/ATAPI-5 ATA/ATAPI-6
Bulot Grégory
Le #9526131
Le mardi 20 mars 2007 16:59, Jacques L'helgoualc'h a écrit :
> > Par ailleurs, y'a-t-il une autre méthode pour copier des disques
> > (hda->hdb), sachant que je ne peux installer mondo (a cause des
> > dépenses j'ai quasiment une reinstall complète du système, pour
> > l'instant je souhaiterais l'éviter)

Ce sujet a été abordé sur la liste il n'y a pas très longtemps...



" Copie de disque dur"

j'ai vu, aucun qui me permet de voir le problème du mbr, mais je garde da ns
mes archives
Jacques L'helgoualc'h
Le #9526121
Bulot Grégory a écrit, jeudi 22 mars 2007, à 15:29 :
Le mardi 20 mars 2007 17:51, Jacques L'helgoualc'h a écrit :


[...]
> Compare les sorties de « hdparm -i » ?

hdparm -i /dev/hda /dev/hdb


[...]

Pas de différence significative, on dirait... Reste à voir dans le BIOS,
mais c'est sans doute du temps perdu.
--
Jacques L'helgoualc'h


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Bulot Grégory
Le #9526111
Le jeudi 22 mars 2007 16:15, Jacques L'helgoualc'h a écrit :
Bulot Grégory a écrit, jeudi 22 mars 2007, à 15:29 :
> Le mardi 20 mars 2007 17:51, Jacques L'helgoualc'h a écrit :

[...]

> > Compare les sorties de « hdparm -i » ?
>
> hdparm -i /dev/hda /dev/hdb

[...]

Pas de différence significative, on dirait... Reste à voir dans le BI OS,
mais c'est sans doute du temps perdu.



Je confirme, j'ai eu la réponse .... consternante !

sur les nouveau disques ide (pata) le disque maître doit être le conne cteur
P3 (noir) de la nappe et le cavalier du DD Câble Select
le gris étant l'esclave
le bleu sur la carte mère !

depuis 10/15 ans que je bricole l'ide j'ai toujours forcé le maitre escla ve
par cavalier et non par l'emplacement sur la nappe !
fra-duf-no-spam
Le #9526101
Le 13594ième jour après Epoch,
Bulot Grégory écrivait:

Le jeudi 22 mars 2007 16:15, Jacques L'helgoualc'h a écrit :
Bulot Grégory a écrit, jeudi 22 mars 2007, à 15:29 :
> Le mardi 20 mars 2007 17:51, Jacques L'helgoualc'h a écrit :

[...]

> > Compare les sorties de « hdparm -i » ?
>
> hdparm -i /dev/hda /dev/hdb

[...]

Pas de différence significative, on dirait... Reste à voir dan s le BIOS,
mais c'est sans doute du temps perdu.



Je confirme, j'ai eu la réponse .... consternante !

sur les nouveau disques ide (pata) le disque maître doit être le connecteur
P3 (noir) de la nappe et le cavalier du DD Câble Select
le gris étant l'esclave
le bleu sur la carte mère !

depuis 10/15 ans que je bricole l'ide j'ai toujours forcé le maitre esclave
par cavalier et non par l'emplacement sur la nappe !



Si tu avais joué avec des machines sans disque et avec plusieurs
disquettes, tu saurais que l'emplacement sur la nappe est important :)

Mais il est vrai qu'il faut avoir au moins mon âge pour se souvenir de
machines avec plusieurs lecteurs de disquettes. Les nouveaux PC n'ont
même plus de lecteur de disquettes (C'est pas forcément un mal !!)
Publicité
Poster une réponse
Anonyme