copie sans doublon 2

Le
Pierre
En fait, je me rends compte que j'ai mal posé le PB.
En effet, je dispose d'une seule colonne dans laquelle se trouve des termes
qui peuvent être identiques et je souhaite éliminer les doublons.
ex::
colonne 1 colonne 2 >
> a a
> b b
> c c
> d d
> b e
> e
merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
perso
Le #4999761
Bjr

tes données en colonne A (mieux si tu as une étiquette de colonne,
mais faisable sans)

tu fais

Données + filtrer + filtre elaboré
dans "plages" vérifier qu'il y a bien tes données
Cliquer "copier vers un autre emplacement "+ dans la case "Copier
dans": cliquer sur la cellule B1
cliquer sur "Extraction sans doublon" avant de valider par OK

tes données sont en colonne B sasn doublons !

Pat REDNEF
SRV
Daniel.C
Le #4999731
Bonjour.
En B1, mets :
=SI(NB.SI($A$1:A1;A1)>1;"";A1)
et recopie vers le bas.
Cordialement.
Daniel
"Pierre" 471decab$0$27412$
En fait, je me rends compte que j'ai mal posé le PB.
En effet, je dispose d'une seule colonne dans laquelle se trouve des
termes
qui peuvent être identiques et je souhaite éliminer les doublons.
ex::
colonne 1 colonne 2 >
a a
b b
c c
d d
b e
e
merci






Utilisateur1
Le #4999431
ça marche, mais comment faire en sorte, dans une 3ème colonne par ex, pour
que les valeurs se suivent, c'set à dire qu'il n'y ait pas de cellule vide ?
Merci
"Daniel.C"
Bonjour.
En B1, mets :
=SI(NB.SI($A$1:A1;A1)>1;"";A1)
et recopie vers le bas.
Cordialement.
Daniel
"Pierre" 471decab$0$27412$
En fait, je me rends compte que j'ai mal posé le PB.
En effet, je dispose d'une seule colonne dans laquelle se trouve des
termes
qui peuvent être identiques et je souhaite éliminer les doublons.
ex::
colonne 1 colonne 2 >
a a
b b
c c
d d
b e
e
merci










Daniel.C
Le #4999411
1. copie la plage / collage spécial valeurs.
2. Edition / Atteindre / Celllules / Cellules vides, clic droit dans l'une
et supprimer.
Daniel
"Utilisateur1" 471e1cfc$0$25934$
ça marche, mais comment faire en sorte, dans une 3ème colonne par ex, pour
que les valeurs se suivent, c'set à dire qu'il n'y ait pas de cellule vide
?
Merci
"Daniel.C"
Bonjour.
En B1, mets :
=SI(NB.SI($A$1:A1;A1)>1;"";A1)
et recopie vers le bas.
Cordialement.
Daniel
"Pierre" 471decab$0$27412$
En fait, je me rends compte que j'ai mal posé le PB.
En effet, je dispose d'une seule colonne dans laquelle se trouve des
termes
qui peuvent être identiques et je souhaite éliminer les doublons.
ex::
colonne 1 colonne 2 >
a a
b b
c c
d d
b e
e
merci














JB
Le #4999321
Bonsoir,

http://cjoint.com/?kxtc5NqxyR

JB


On 23 oct, 14:45, "Pierre"
En fait, je me rends compte que j'ai mal posé le PB.
En effet, je dispose d'une seule colonne dans laquelle se trouve des term es
qui peuvent être identiques et je souhaite éliminer les doublons.
ex::
colonne 1 colonne 2 >> a a
b b
c c
d d
b e
e


merci



Pierre
Le #4998611
La version automatique de JB est intéressante. Comment modifier la macro
pour que cela fonctionne s'il s'agit de nombres au lieu de texte ?
Merci.
"JB"
Bonsoir,

http://cjoint.com/?kxtc5NqxyR

JB


On 23 oct, 14:45, "Pierre"
En fait, je me rends compte que j'ai mal posé le PB.
En effet, je dispose d'une seule colonne dans laquelle se trouve des
termes
qui peuvent être identiques et je souhaite éliminer les doublons.
ex::
colonne 1 colonne 2 >> a a
b b
c c
d d
b e
e


merci



JB
Le #4998551
Bonjour,

C'est la même fonction.

http://cjoint.com/?kyjmAzuxYT

JB


On 24 oct, 08:16, "Pierre"
La version automatique de JB est intéressante. Comment modifier la macro
pour que cela fonctionne s'il s'agit de nombres au lieu de texte ?
Merci.
"JB"
Bonsoir,

http://cjoint.com/?kxtc5NqxyR

JB

On 23 oct, 14:45, "Pierre"


En fait, je me rends compte que j'ai mal posé le PB.
En effet, je dispose d'une seule colonne dans laquelle se trouve des
termes
qui peuvent être identiques et je souhaite éliminer les doublons.
ex::
colonne 1 colonne 2 >> a a
b b
c c
d d
b e
e


merci- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -




Publicité
Poster une réponse
Anonyme