Copier les valeurs

Le
berlin1
Bonjour,
Je veux faire construire automatiquement un tableau de valeurs
quotidiennes qui va chercher certaines valeurs inscrites ici et là
dans la feuille, toujours au même endroit, (F5-F6-F7-F8) mais qui
varient en fonction de la date du jour placée en E1.
Les dates de référence du tableau sont listées de M11 à M16. Je pe=
ux
faire tout ceci facilement avec la formule suivante: =SI
(E1=M11;F5;""), ensuite: =SI(E1=M11;F6;""), puis =SI(E1=M12;F5;""=
),
ensuite: =SI(E1=M12;F6;"") etc.. Ceci fonctionne si les 2 dates
concordent. Le problème est que le lendemain, si E1=M12, les valeurs
égales à E1=M11 s'effacent.

Ma question no 1: est-il possible, à l'intérieur d'une ligne de
commande (genre: =si) d'insérer une ligne de macro qui viendrait
coller les valeurs ("selection.pastespecial paste) Pour toutes
sortes de raisons, (surtout la compatibilité entre versions de
logiciel, et aussi le fait que je ne suis pas le seul utilisateur du
fichier - donc si ça plante ) je n'aimerais pas être obligé de
créer une macro pour faire effectuer cette opération.

Ma question no 2: SVP , pourriez-vous me construire la macro en
question. Merci.

Robert, de la Beauce, au Québec
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Youky \(BJ\)
Le #18322561
Salut Le Quebec,
Prés du Beaujolais je viens de faire ceci
à mettre en ouverture de classeur
j'ai pris A1 la cellule de destination et le tout en Feuil1 changer N° si
pas idem
voir le nom en fenêtre des projets de VBA nomde gauche et non de droite

Private Sub Workbook_Open()
Feuil1.[A1] = ""
For k = 11 To 16
If Feuil1.[E1] = Feuil1.Cells(k, 13) Then
Feuil1.[A1] = Feuil1.Cells(k - 6, 6)
Exit For
End If
Next
End Sub

Youky (BJ)


Bonjour,
Je veux faire construire automatiquement un tableau de valeurs
quotidiennes qui va chercher certaines valeurs inscrites ici et là
dans la feuille, toujours au même endroit, (F5-F6-F7-F8) mais qui
varient en fonction de la date du jour placée en E1.
Les dates de référence du tableau sont listées de M11 à M16. Je peux
faire tout ceci facilement avec la formule suivante: =SI
(E1=M11;F5;""), ensuite: =SI(E1=M11;F6;""), puis =SI(E1=M12;F5;""),
ensuite: =SI(E1=M12;F6;"") etc.. Ceci fonctionne si les 2 dates
concordent. Le problème est que le lendemain, si E1=M12, les valeurs
égales à E1=M11 s'effacent.

Ma question no 1: est-il possible, à l'intérieur d'une ligne de
commande (genre: =si...) d'insérer une ligne de macro qui viendrait
coller les valeurs ("selection.pastespecial paste...) Pour toutes
sortes de raisons, (surtout la compatibilité entre versions de
logiciel, et aussi le fait que je ne suis pas le seul utilisateur du
fichier - donc si ça plante... ) je n'aimerais pas être obligé de
créer une macro pour faire effectuer cette opération.

Ma question no 2: SVP , pourriez-vous me construire la macro en
question. Merci.

Robert, de la Beauce, au Québec
Publicité
Poster une réponse
Anonyme